Cannot connect robot vacuum to Internet

I got a robot vacuum Christmas. At first it wouldn’t connect to the Internet, but then it did. It worked fine until today after I cleaned out the dust bin and brush and moved it to another floor. I tried the setup process 5+ times, but it doesn’t work.

More specifically

  1. I open the Wyze app 2.27.33 for Android and pick the device
  2. I see “your vacuum is offline”
  3. I click the help
  4. I repeat the pairing process
  5. After connecting to the vacuum’s network, I go back to the app
  6. It sits there for maybe 5-30 seconds
  7. Android tells me “wifi disconnected”
  8. I reconnect my phone to my normal wifi
  9. I name the vacuum and skip through the setup (e.g., sharing) and info (e.g., keep space around the charger)
  10. Vacuum is still offline

I tried my normal wifi network (TP-Link with multiple access points, 2.4Ghz+5GHz) and an alternative (single router 2.4Ghz). Neither works.

I tried a factory reset too (after uploading a diagnostic log), but that didn’t help.

Before it failed, the vacuum was on the latest beta firmware. App shows version 1.6.173.

I Just got a Robot Vacuum. Seeing your issues… Seems to be same like mine.
Tried using Apple IPAD. to connect to robot… Fails.
Tried Iphone 13 Mini. No matter what I tried, can not get past the Connect. 3 minutes later it CONNECTION failed!.
APP seems really buggy.
Locks up if you try to look at the firmware update… Locks up App… have to REBOOT the phone.

Robot Vacuum… works if your Just walk over… Push the start button… It will clean till battery is low…
returns to base.

Wish better APP set up… or How too For a IPHONE. As of right now… this thing is just a Manual Turn on robot.
all features, mapping, health of robot? is unknown.

Wish for IPAD, app. larger screen would be nice.
YES this is my first post… Complicated getting this far! .