Wyze Robot Vacuum Setup Issue - 1/25/21

I hope the wife has Ice Cream and Lifetime on when I get home so I can manage through this.

Yup. I also tried factory resetting the unit during testing also.

1 Like

What is Testflight/Test Flight? Is that a separate platform Wyze uses to Alpha/Beta test things without first trying it through the WyzeBeta app or something?

They are one in the same. You can use the TestFlight app on iOS to test Wyze’s Beta software.

More info here: https://wyze.com/become-a-beta-tester

Ah, okay, it’s an iOS thing, that’s what had me confused. I’ve never used iOS before, and on Android it’s just called WyzeBeta. Thanks for the clarification.

Also tried uninstalling on both ios and android. Reinstalling, Also tried, clear data, cache, Tried 4 differet phones on android with mobile data off, tried ios on an iPad. Also tried 2 different routers. There is definitely an issue but reinstalling the app doesn’t fix the problem


Glad I’m not alone. Tried all the things in here dozens of times to no avail.

1 Like

Any new info on getting these vacuums connected?

Not as of yet. There not in till 9am PT. So hopefully they slept on it.

1 Like

Same issue here as reported above. Received my vacuum today. Have been losing my mind for the last 90 mins trying to connect. iOS here as well. Spins after connecting the bot’s local SSID network.

Seems they may have went silent

1 Like

Wyze team, what is the verdict?

Hi @DeliriuM & @atlien808 amd welcome to the Community forum! :slightly_smiling_face:

Open a Support Request ticket and hang in there. . . There is no update at this time. :slightly_frowning_face:

Saw there was a new Beta on Android. Downloaded it but still having the same issues. Even wiped data/cache and factory reset the vacuum. Rebooted the phone. Set my network to 2.4 only. Connection failed…

I see it on the controller, so it’s connecting to the wifi, just not communicating with the app.

Wyze just released a new App for both iOS and Android. Information on that here:
If it doesn’t fix the trouble, open a Support Request.

The app update description doesn’t even mention vacuum setup. It did not make any difference. Still no joy.
I called them yesterday, after opening a ticket, because it’s been my experience that the only tickets they respond to are the ones I call them on. I had a long conversation with them including troubleshooting, factory reset, etc. I was told they would send me an email yesterday requesting further information including screenshot, and I don’t know what else. I never got the email. So this morning I went to see if I could add anything to the ticket but apparently they closed it when I spoke to them, leaving my no avenue to proceed. So I opened another ticket, uploaded the screenshot, and have of course not heard back. This is not going well. I have been a Beta member for 2 years, and I can say that in the first year, they did seem to pay attention to fixing problem, not so much anymore. After waiting for this vacuum for 2 months, and babysitting the tracking since Jan 4, not receiving the vacuum til Jan 24th, I am not a happy camper.

1 Like

Android app v2.17.7 does nothing to fix this issue. The problem is still the same - the vacuum connects to my Wi-Fi network, but never shows up in the app.

1 Like

Didn’t fix the issue.

1 Like

1/26/21 2:15 PM PT - We are continuing to isolate the cause behind some folks not being able to complete Wyze Robot Vacuum setup. While this is related to a separate issue, all customers using Wyze Robot Vacuum should make sure they are using at least the 2.16.55 Android app or the 2.16.48 iOS app due to the recent certificate update.

Further, we’ve found some success for some people with restarting their vacuums. If you cannot see the Wyze Robot Vacuum WiFi broadcast during setup, please remove the Wyze Robot Vacuum from the charging station and then press and hold the power button on the vacuum for 5 seconds. This should restart the vacuum and the WiFi broadcast should appear again during the setup process.

Thank you for your patience.


I just tested with rebooting the vacuum prior to the join. Still no dice.

The vacuum is connecting to the wifi successfully, and it stays connected according to my Unifi system. It just doesn’t proceed past that point in the app. The phone disconnects from the phone after it sends the wifi info. The vacuum gets on the wifi, but then the app just sits at “Connecting…” until it times out. So far no combo of factory resets, clearing cache/data, reinstalling apps or disabling mobile data has made it work for me.