Robot Vacuum not connecting

First time setting it up
Up to date app V 2.16.55

1 Like

First time



1 Like

First time - received it yesteday Jan 23.
Using Android 11 on Pixel 4a
Wyze version 2.16.55

1 Like

First time installing. I have tried connecting with a Pixel 5 and an iPhone SE. They both are experiencing the same problem. Mobile data off, recconect off for other wifi networks. Nothing is working. Not connecting. I am on v 2.16.55. Unistalled the wyze app and reinstalled. did the factory reset on the vacuum after multiple failures. Simply not working

1 Like

First time setting up
Android 11
app is V. 2.16.55
It connects to the vacuum, but then the vacuum’s wifi(WCVR) disconnects within a minute or so and disappears till I reset the vacuum wifi and repeat.

Edit I gave it a couple more tries and got the same results. I did want to test the vacuum wifi though so I connected to it outside the app and had no problem staying connected, but once the app tries to connect it disappears.

1 Like

First time. Fully up to date on iOS. You have to wonder, did quality control even happen? I mean I could understand like one version of one OS in some strange buggy scenario but to roll this out and both android and iOS users having issues across the board? I was skeptical buying stuff outside the cameras. This shows me I shouldn’t. Unless there is an update to the software on our phones that is the problem there is no way for us to fix the vacuum or it’s firmware since ya know… it doesn’t connect to anything.

I tried everything too - using 2 different phones (Android 11 and 9), reinstalling Wyze, turning off mobile data. Nothing helped. My guess - wifi chip on the vacuum is bad.

First time
Wyze app V 2.16.55

1 Like

First time connecting.
iOS V2.16.48

1 Like

First time as well. Tried 3 different phones. Samsung A71 and Google Pixels. Reset all devices multiple times. As soon as the app connects to the robot Wi-Fi it drops it and the robots internet disappears. Says connection fail and does not finish the setup.

It is with great regret that I am throwing in the towel on this. I really wanted this to be the killer Smart Home Device, and I waited with baited breath for my robot vac to arrive. I wasn’t even deterred by the news about having to upgrade the firmware and the app I received in advance. But the experience has been nothing short of terrible! I’m not inept at network troubleshooting, and I tried many of the remedies posted here before I even consulted the forums. Using the most conservative estimates of the value of my time, I could have purchased a Roomba 675 and a Roborock S4 with the time I put in trying to make this thing work!

Clearly this product was not ready for market, and I feel bad for the poor staff who are now living with the fallout from it’s premature rollout. I have always liked Wyze’s philosophy, and I wish the company well, but enough is enough. This thing is going back.

They are currently working on the issue, the thread I linked above will give you updates as they provide them

1 Like

Hopefully it’s just an app update and not having to ship it back!

Yes, it would be nice if they can fix it in the app only. But for me it looks like it is more firmware problem because vacuum Access Point disappears immediately after app is trying to connect to it. Let’s keep our fingers crossed and hope that I am wrong.


Yeah my robot drops its Wi-Fi as well. But so many people still see it connected to their router. My hope is that it becomes hidden rather than completely off. See what happens. I dont mind returning and getting a new one as the robot looks so solid built wise and I got it for a great price. I dont mind supporting Wyze if they offer solutions fast!

Same issue. I’ve tried all permutations of trying to trick the vacuum into connecting. Spent way too much time on this. Used both the latest Android and iOS devices. Used two routers as well.

Wyze just closed my ticket asking for a return for the non-functioning vacuum… no explanation.

I have called, chatted (before it was turned off) and emailed multiple times, but do not seem to have a support ticket. How the heck do I do that? I just want this to be fixed whether it’s an app or to send it back. I would hope that they would send a new one out ASAP as I have already waited a significant amount of time, and I feel like having to wait until they receive mine to either fix or send a new one is too long. I think it would be time for a refund at that point.

@nlockwood3 Do you have an open Support Ticket number? Post it here.

Not? Then goto: (

  • Just fill in a silly complaint (Kiwi ate my homework) and continue with NO answers until you finish the suggestions.
  • Eventually get to “Contact Support” & “EMAIL” prompt where you’ll be able to enter your trouble statement and contact info.
1 Like