Can't Add Vacuum to App

Hey yall,

I am running into an issue where I cannot get past the screen on the wyze app that tells me to join the vacuum’s wifi network. i am easily able to join the network but the app either does not recognize it or (insert reason).

I have tried both on my iPad and my iPhone. I have tried disabling the cellular and going that route

I have reset the vacuum wifi more times than i care to remember

I have tried with the vacuum charging and with the vacuum not

Am I missing anything here or is this a Wyze issue?

I had a similar issue. It seemed to be related to the fact the vacuum uses only 2.4 GHz. If your router has the same SSID for its 2.4 GHz and 5 GHz network, temporarily rename the 5GHz or temporarily disable it. Attempt to connect see if this works. This solved my issue.

My network does not have the same SSID sadly. I have a 2.4 only network dedicated to my IOT devices to avoid the 5v2.4 fight haha. I even tried switching to the iot network before opening the Wyze app and that did not work.

1 Like

Haha, not the first rodeo I see.

The only other thing I can think of is giving it a factory reset. Hold in the home button for 5 seconds, then again for 5 seconds. With all those steps I was able to get mine working but I did have to be patient, wait to see if an error pops up, and keep re-trying.

haha no sir. The cams were struggling with the combined network and it took me a while to figure it out but when I did…I felt like Einstein I tell ya haha.

I’ll try the rest and see how it goes.

Cheers mate

1 Like

I had a similar issue where after connecting to the vacuum’s wifi, the app didn’t do anything after that. The phone indicated that I was connected to the vacuum wifi, but it didn’t do anything afterwards while on the iOS app. Eventually, I got it registered to my account on the Android app. Sharing this info below in case it’s ever helpful for someone else.

My setup:
I have mesh wifi routers running Plume which have the same SSID / password for the 2.4 GHz and 5 GHz networks and they can’t be configured to different settings with stock firmware. I use iOS devices and to my knowledge, there isn’t a way to force my device to use 2.4 GHz instead of 5 GHz on iOS14 when connecting to a wireless network.

What worked for me:
Based on @ProjectBarks replies, I found my old LG Nexus 5 and had it connect to my wifi over 2.4 GHz (this could be set in Android under Advanced Settings; the choices were Automatic, 5 GHz, and 2.4 GHz). I retried the vacuum setup process a couple times on the Nexus 5 while on the 2.4 GHz network and on the 3rd try, the app did something after connecting to the vacuum’s wifi. I’m not sure if it made a difference, but I think that when it worked, I selected the vacuum’s wifi network in the Wyze app, then waited (instead of hitting the back button).

Good luck to anyone out there battling the same problem!

1 Like

I just received my vacuum today and cannot for the life of me get it to connect to my WiFi.

I’m using a Pixel 5 and following these steps. I’ve also

  • Verified my mobile data is off before starting
  • Verified I’m connecting to my 2.4 GHz network
  • Verified there are no other networks with the same name
  • Verified I’m using the correct password
  • Rebooted my router (multiple times)
  • Rebooted the vacuum (multiple times)
  • Rebooted my phone (multiple times)
  • Tried a DIFFERENT 2.4 GHz network

This is SO frustrating!

Yup!! I have done all of those things as well my friend. I reached out to support and they told me to do all the things we have already done. I don’t know what else to do. I am using and iPhone / iPad and you on Android. So it’s clearly and issue with them.

1 Like

Just busted out an old Pixel 2 that was factory reset. Installed WYZE app, logged in and tried to set it up without any luck as well.

@PHLAK @hagosrush Try factory resetting the vacuum with the renamed 2.4 GHz SSID. You do this by holding the home button in for five seconds, release, and then again for five seconds.

With changing Wifi info plus factory reseting the bot and not touching my phone I was able to connect.

I have already done this as per suggestion above. Thanks though

1 Like

Already tried that @ProjectBarks. That’s what I meant by “Rebooted the vacuum”

EDIT: Just read that part in the manual, maybe I didn’t do that. Will give that a try as well.

EDIT 2: Tried the factory reset and still not working.

No fix yet? I have tried all of the things listed from all of the posts regarding connecting and have had no success! It fails every time on multiple different devices. I dont have another router to try and why would I? This needs to be addressed. So disappointed… :frowning:

I Have heard nothing from Wyze support outside of the basic things we all knew to try. They have not responded to my last Email yet. I’m returning mine as we speak. At least they responded to that message.

So I found a fix that worked for me. My specific problem was that I would reset the vacuum wifi, type in my 2.4Ghz wifi password, then select the Wyze vacuum wifi network (with my data off the whole time). After returning back to the wye app, I notice that I am no longer connected to the Wyze vacuum wifi network because it has disappeared for some reason (I tried this like 10 times with slight variations).

As a last-ditch effort, I decided to uninstall and reinstall the Wyze app. Much to my surprise, after logging in, there was my vacuum at the top of my devices list.

I’ve had similar issues happen to me with the Wyze plugs, but not quite to this extent.

Hope this works for everyone else!

I had some hope for a second there haha. I tried this earlier in the troubleshooting process but tried it again just to make sure and the device is still not added.


I also had issues with adding the Vacuum to the Wyze App, it kept failing the WIFI setup.

I remembered that my Samsung Galaxy S21 was just updated to Android 11 and thought mzybe that could be the issue so I pulled out my old S10 and was able to complete the setup in one shot without any problems. Now I don’t know if it was the Android version or something else but the old phone worked fine for setting up the Vacuum and once setup I could access and control the Vac from my S21 as well.

That’s great! Too bad I don’t have an old Android device to use. :slightly_frowning_face:

I’ve spent over five hours now trying to get mine to connect to Wi-Fi. I even deleted the beta app on one device and installed the standard release app. Still doesn’t work. Turned off cellular, turned off my 5GHz so only 2.4GHz is running. Rebooted bot and mobile devices. Factory reset the bot. I’m about to pack it up and ship it back. And the fact the Wyze isn’t even communicating or giving any support is not good! Not had issues like this with any of my other devices from them.

1 Like

That is the most frustrating part. I have packed mine up as stated above for that exact reason. No comma and when they have communicated with me it’s giving me the help article that I have already read with literally nothing else.