Wyze Hub Firmware Connection Issues

We have been having a lot of issues with our home monitoring connection since the firmware update on 3/4/22. We can’t get our sensors to connect and now we can’t even pull up our monitoring application. I called customer service multiple times with very little usefulness after waiting a long time. They are going to send us a second new hub. I am hearing contradictory things. One person said they will update the firmware in 48 hours but that did not happen. The customer service agent I spoke with this morning said our issue was specific to us and that there is no firmware update to be released anytime soon. Are we the only one having problems?

Called 3 times today to customer service, Got a little more help. Now monitoring app is working again but can’t get the last third of our sensors to work again. And also tone setting is not working even though I made sure to turn tones on. Any suggestions to make it work?


You are NOT alone. FW patch is on the way. I see you already posted on the topic I was about to send you to. You should find some info\help there.


Thanks. Good to know a fix may be on the way. We tried all the suggestions given and they aren’t working. Sounds like best suggestion is to do nothing and hope it goes back online.

Here is a link to a post over in the other thread for a soft reset. It worked for me.

1 Like

I tried it but the hub is still not responsive and doesn’t say “ready to connect” like it’s supposed to. These are sensors that are already in the app but they are not linked to the hub because my front door continues to show as open when it is not. :exploding_head: Also tried a new sensor and no luck either.

I see. I would suggest following that link back over to my post and looking thru the other posts. If you see one that interests you, respond back to them and see if they have any more suggestions. I recommend any of them that are listed as Mavens or Moderators.

It is late and I have to work so I am signing off for the night.

Be safe and well!

1 Like

If your hub is running firmware version, you’re not alone with these issues. You have 2 options if you’re running firmware:

  • Wait for a firmware fix

  • Accept the replacement hub. When setting up new hub, any required firmware updates will not load the problematic firmware as that version has been halted by Wyze.


Truly frustrated ready to give up and try a new service. Wyze hasn’t processed giving me a new hub though they said they would. Everything completely stopped working again even though it says it’s connected. Can’t even get the keypad to alarm. Wasted countless hours troubleshooting. At this point cannot recommend their monitoring service. It’s garbage. Only cameras are still working because not connected to the hub.

Most of us running firmware have the same issues… no chimes/tunes, can’t add new sensors, can’t reset sensors, etc.

Have you called them and asked about the status of your replacement hub?

1 Like

I have same issue with new hub and new soft:4.32.9249.

After connecting 30+ senator after each new sensor the hub was offline for few hours. Today it doesn’t want to connect to the sensor even that it is connected to internet. There is also no “ready to connect message).

I hope I am not forced to accept replacement as it seems like everyone is having the same issue! And I have something like 50 sensors (entry, leak, motion).

I will call Wyze tomorrow but if no solution is offered I want my money back (not a gift card). I’ve spent over 1.5k on that system and i am so disappointed.

1 Like

I have exact same issues.
They sent me 3 replacements but still same issue happens.
Every time when I tried to connect more than 12 sensors, it started flashing and shows disconnected. And it will not update the contact sensor status.
Reset, deleted, re-added many many times. still same issues.
called them many times and was told a replacement will be sent.
I donot want a replacement.
It has been almost half year, and WYZE engineers could not figure it out???


Same problems. I joined the Beta program hoping the engineers had a solution for the hub issues. Nope — same software — same issues: very limited capability to join devices (sometimes no more than 12 and other times no more than 24 after many hub deletes and system rebuilds), devices not reporting, devices going off line even when hub and device have strong connection,