Wyze Cam v3 Pro, v3, and Pan v2 Beta Test - 4/13/2023

How can I update my firmware?
Also any of you guys having problems with the video quality. After about a couple of weeks it’s gotten really bad.

Welcome to the Wyze User Community Forum @rdp6109! :raising_hand_man:

To update cams to available Production Release Firmware, go to Account → Firmware Updates in the app and check for available updates.

To update cams to Beta Firmware, join the Beta Testers and become a Beta Tester to see Beta Releases listed in the Firmware Updates page of the App.

I would also like to know that.

I updated 3 out of 5 cameras. Two at home and one at the cottage. Didn’t want to take a chance and drive six hours in case something went wrong. Don’t see any improvement on the following:

I think it made it worst than it was before. The one camera that I updated is performing poorly compared to the two that I didn’t. It’s been loading forever…

1 Like

Google Home will not display Cam v3

Log: 1007213

1 Like

Under Wyze Live stream the camera loads and plays for 5 seconds and then jams up again until I refresh the browser and then repeats the same bug.

Two of my V3 Pro cameras are stuck on and will not update any further. Any suggestions? All my other V3 Pros (and other devices update fine)

I’ve tried updating from Android and iOS. I’ve restored back to by manually flashing and then trying to update to but they always fail. I’ve removed all SD cards. I’ve tried to factory reset it as well. Nothing gets it past, it just flashes purple when I try.

Im amazed nobody has reported this as of yet. Since updating my two Pan v2s they both lose connection REPEATEDLY. I have to manually restart the cameras at least 6 times per day for both cameras.

Same here, streaming on Alexa and Web Services stop after few seconds

1 Like

Wyze is aware and working in getting this corrected.

1 Like

Can you point to the “issue” being worked on?

v3 Event videos still stuttering in the WYZE app when played back from the cloud on v4.36.11.4293.

No stutter in the downloaded clip and no stutter when played from the cloud via tinyCam Pro’s “WYZE Event” viewer.

Cannot point to the issue as I am a community member as you. I just volunteer to help out.

However, I provided information to Wyze on the streaming issue on Alexa and the Google Nest devices. They are working on determining the reason why the stream stops or won’t start.

As soon as a fix is provided orni hear any feedback on this, I will post it here.


Any word on a fix?

1 Like

No Official Word yet. Let me see if I can find out something.


@bigbad614 , are you running the latest Beta Firmware on your V3’s? If so, reboot the cameras so it establishes a communication with Wyze and the servers. Once you do that, you should be able to stream.

I rebooted my cameras, for me it is easy, I simply turned off a Wyze Plug and then back on, that reboots 8 cameras. I then went to my Google Nest, which had the issue, and it streamed without issues. I am going to check an Alexa Show next.

Yep, just checked Alexa and it is working as well.

Note: A Reboot / Restart from within the App should be ok as well.


One of my V3 cams is recording events with a 5 minute cooldown between events. It has Cam Plus applied to it and there shouldn’t be a cooldown period on this cam.

Maybe I’m overlooking something? :thinking:
I haven’t noticed this problem on my other V3s.

I sent in a log. ID: 1011968


Edit: Update

I kept working with this V3 Cam and I think it is working properly now. :crossed_fingers: I removed the Camplus and then reapplied. Unplugged the cam, plugged back up and checked and reset the DZ. Also my Alexa routines on this camera started working much better as well. :man_shrugging:


Yea, the latest beta FW update on the V3 required a reboot to establish the connection to Wyze and ensure communications were in place. In any event, once that is done, you should be able to stream on Alexa and Google Nest. it may have also corrected the other issues as well.

Just received notification on this.


@spamoni - I rebooted the cam v3 and still no video feed in Google Home.

Cam Pan v3 works as expected within Google Home.

Can you provide a log please.

@spamoni uploaded again: 1012621

1 Like

I’ve not been able to stream on Google nest hub and Google home app iOS from my cam pan v2 neither.
The beta firmware doesn’t help.
I uploaded a log (1012845).

1 Like