Wyze Cam v3 Firmware Release Candidate Test 10/5/2022

You know what happens when ueatbeans!

I only install Beta Firmware on cams that are non-essential and easily accessible since I know in advance that I will be testing the firmware in multiple operational modes and network scenarios, as well as accessing the SD Card, rebooting them, and possibly reinstalling them. It is just prudent for me to not install them on all my essential security cams since I already know Beta Firmware can present some unpredictable behavior.

Also, if the installation of the Beta FW required a factory reset \ reinstall of every cam on which it was installed (rather than a power cycle), this would be a significant issue that would warrant the submission of cam logs posting those logs here so the devs can take a look at them.


I am a Glutton for Punishment. :slight_smile:

I install the Beta FW and App on all devices. LOL. It does but me sometimes, but not as much as I thought it would.


You live on the razor’s edge. I do not envy your therapist!


I’ve done that too in the past… the recent betas have really bitten me in the ass, but yet this most recent beta I did ALL my cameras too… luckily this one was a BIT more stable and didn’t completely wipe my cameras off the charts. I really dislike dismounting cameras from less-accessible areas haha.


Same. This finally fixed it for me


Installed one one of two V3 cams.
No notable issues to date. Updates seem to come in a little smoother. The updated camera is also the furthest from the WifI, so I’ll be monitoring the connection quality.


I had no issues updating my two v3 cams. However, I’m seeing a 1-2 second pause at the 4 second mark on all my event clips (both cameras). This has been happening for at least the last two updates. I had hoped the latest update would resolve this, but no. I’ve seen other posts about this but haven’t seen any resolutions. I’ve sent a log to support.


Do these firmware updates auto-update on their own? I just noticed that I had version in the past. I normally clicked on Firmware Update so that I could manually update them. Is there a way to disable and manually update?

Normally I like to read what others are experiencing before updating.

That is the last Public Release Firmware.

You will only see a Beta Firmware update available within the app if you are participating in the Beta Program and have the cam set in the app for Beta Updates.


Hello Wyze Andy, I am having a heck of a time trying to install this firmware on my V3. I put the file at the root of the SD card. I hold down SETUP and plug it in, the red LED never goes purple and all I get is “ready to connect” over and over. I’ve also held SETUP down for more than a minute and still nothing. It currently has and I’d like to try Please tell me the steps of how to do this successfully. Thank you in advance

This is a “normal” beta firmware. If you are a beta tester, it’s just a normal over the air firmware update. No uSD card update required.
However for a uSD card firmware update, the big one is getting the filename correct. By default, Windows hides filename extensions, so people often add an extra .bin to the end and that won’t work.

So how do I get my V3 to go purple (fast red/blue)? I’m frustrated, ughhhh

I fixed it, it was the SD card, I swapped it and it now goes purple, thanks for your input

This firmware is no longer in Beta. It is now a public release Firmware available for OTA update on the public app or download from the Release Notes & Firmware page.

It is also being pushed out for update gradually, so it may take some time to get to everyone’s app for update.


Is this another type of Beta test?

1 Like

Yes, this version was a beta firmware when it was released a month and a half ago. Since that time, Wyze released a newer version publicly. But the public firmware was supposed to be coming out in stages over the course of 2 weeks…but now that it’s past 2 weeks, EVERYONE should have the new public firmware:


Anything posted here in the Beta channel is supposed to be about Beta stuff.


I’m still running…

This is what my FW update screen looks like in my app… strange

I will check on the timeline for this then. I just looked at the release notes and it said it was released Nov 2nd. Then toward the end it says the firmware was paused to investigate a report they had, then they got another update saying they were releasing it over 2 weeks. I’d originally assumed the 2 weeks from the date of release, but maybe it’s from whenever they resumed the update, which isn’t listed. I’ll see what I can find out. I assumed it should be done by now though, but if you don’t have access to it, maybe not. I’ll ask Jason.


Yea I find it strange to.

It’s been long past 2 weeks now and I’m still waiting . Definitely looking forward to this update bc it fixes the 90 gb limit on 256 gb micro sd cards .

Please let me know what you hear , as I haven’t heard anything yet. Just that it was going to be rolled out slowly in 2 weeks…

Thanks carver :slight_smile:

1 Like