Wyze Cam v2 - Alexa (Echo Show 8) - "Camera Is Not Responding"


I’ve had 2 Wyze v2 Cams working for about a year, linked to my Amazon Alexa Echo Show 8 - Voice commands to show “Son’s Room” and “Daughter’s Room” working fine, until about a month ago.

When I give the command “Alexa, show me daughter’s room” it immediately says camera is not responding. Like it’s not even trying to connect. It works totally fine in the Wyze app. “Son’s room” works just fine through the Echo Show 8, it’s just “Daughter’s Room” not working. I’ve done all the reset/relinks/reboots/etc. of both the camera and the Echo Show 8 - Does not help.

What DOES help is renaming the camera. If I change it to something else (for example from “Daughter’s Room” to “Lauren’s Room” it immediately start working again on the Echo Show 8, for about a day, before it returns to the same message about it not responding. All the while, the other camera works just fine. Never any issues with both camera’s in the Wyze App - so I know it’s an issue on the back end between Wyze and Amazon servers.

Any one else? Wyze Team, can you offer and help?


I’m experiencing the same issue.

I have 4 Wyzecam V2 cameras (all of them are on the RTSP firmware, All 4 are working fine and viewable in the Wyze app. However, 3 of the cameras are inaccessible on my Echo Show 5. It has the same issue as what you’re experiencing (Alexa says “ok” when I ask her to “Show me [camera name]”, then she immediately says “Sorry… [camera name] is not responding”.

I tried deleting the 3 cameras that are not work from the Alexa device list, unlinking the Wyze skill, and relinking the Wyze skill and re-adding the 3 cameras. That didn’t resolve anything. One thing I did noticed though… under the settings page within the Alexa app, for the 3 (not working) cameras, I don’t see the “Announcements” tab, and I don’t see the “Alexa, show me [camera name]…” in italic as the suggested command. For the 1 remaining camera that is actually still working, in its settings page, I can see “Announcements” and the option to turn on/off announcements for person detection". I’m afraid to delete the good, working camera from Alexa to see if the proper settings page would reload if I add that camera back in.

My Wyze skill in Alexa says it was last updated 7 months ago. Has there been any more recent updates to the skill? What could be causing only 3 of the 4 cameras I have at home to not work with Alexa?

I don’t use the Echo Show so I don’t know about this one. Only thing I can suggest is to try unlinking and relinking the Wyze skill. @Mavens- anybody use it or have suggestions??

1 Like

Good suggestion by @tomp! Definitely try removing the skill and re-linking it with your account. Also, ask Alexa to “discover devices”.
You may also need to go to devices, then cameras and remove the camera(s). Then ask to “discover devices”.

1 Like

I have no experience with those particular devices so that is knowledge I would have to get from one of the other mavens. Sorry I can’t be of more help

1 Like

Yes, I’ve tried it multiple times (disabling the skill and removing it, then reinstalling/relinking the skill back to Alexa), but to no avail. It feels the skill is not installing the right drivers for the Wyze cams (the ones that should have the “Alexa, show me [camera]” integration enabled.

Can you try ‘renaming’ one of your camera’s in the Wyze app, then see if Alexa will show the new camera name. It works for me, but only for a day or two before it says camera not responding.


How is the quality of the livestream in the Wyze app?

Your solution/workaround works! Change the name of the camera on Wyze cam, then went into Alexa and click on the camera’s device settings and it showed the settings with the “Announcements”… Tested it out and now works. So I guess the question is, if this stops again after a day or two, how do we fix this permanently?

1 Like

The livestream in the Wyze app is fine. No drop frames or freezes. Signal indicator shows full strength.

Don’t get too excited - it will stop working (usually a day or two) - then you can rename again, and it’ll temporarily fix it again - the cycle goes on.

Wyze - Can you guys do something about this? Let me know if you need me to do some troubleshooting for you. This issue is affecting many out there - It’s all over reddit and other sites.

Using Wyze on the Amazon Echo devices is one of the reasons for buying Wyze. It’s my baby monitor, security system, and entertainment - all through Echo Show 8.

1 Like

Some semi-good and some bad news.
Let’s start with the bad ones.
I’ve talked to Alexa team at Amazon and they said that they have seen that problem with other brands of camera, ie. problem might not be related to Wyze Cam but something between Alexa and the RTSP protocol used by Wyze and other brands to integrate with.
Their solution has been to change the underlying protocol from RTSP to WebRTC.
Problem, this is not a trivial change.

Now for the semi-good news: We have been working on WebRTC for the last 6 months for our Cams and we are now in beta testing. So it is almost ready but quite ready for prime time just yet.

One little hint, actually two, the unlinking/linking usually works when everything fails. It has to go with credentials expiring. so if you have one camera working and one that does not, unlinking is unlikely to s
When you link the skill, we are allowing Alexa to access your account for a very short amount of time and the ability to request a new authorization for a longer period of time like a month or two (don’t remember exactly the length). Alexa is supposed to ask us to renew that last authorization and we are happy to oblige but if they fail to ask us, then we are expiring the authorization. Every command to Wyze after the credentials have expired will fail. This is when unlinking and relinking is usually beneficial.
Also another way to refresh the list of the devices is to ask Alexa to “Discover devices”. Alexa will say, that there are no new devices BUT it will refresh the definition of the devices already linked. Process takes about 45 seconds.


Great info, @Frederik , thanks so much for being straight and informative.

So a very easy short term workaround is periodically saying “Alexa, Discover”. Easy peasy. (I haven’t noticed this issue myself.)

1 Like

I’m not sure if the discovery would address the issue specifically because I’m not sure what the exact root cause of the problem is. But it usually refreshes the definition of the devices in Alexa. It might be enough.

Hopefully we will be able to stabilize our WebRTC implementation for Alexa and release it soon. We found a couple of issues during beta testing that we are working on.


Would your WebRTC implementation be implemented in the RTSP firmware as well as the standard one?

There is no plan for the moment that I’m aware. We are really trying to complete the development for the regular firmware and propagating to all the cameras for the moment.

I will take that feedback back to the product manager for the camera.

Thank you,


It would be great if you took this opportunity - rejiggering the firmware to use WebRTC - to also use the efficiencies saved from that and other conserved resources (e.g. no Xnor) to incorporate RTSP back in to the main line firmware.

Has there been a long term answer to this. Mine does same thing.

This was one of the main reasons I bought a Wyze cam.

1 Like

Is there a permanent resolution for this issue? I have about 16 cameras not working on the Echo Show 5, Echo Spot, and Fire TV Stick. It says, “Sorry, [camera_name] is not responding”.

There’s one camera that was shared to me and ironically, that’s the only camera that works flawlessly.

I have tried unlinking the Wyze Skill, removed all Wyze devices from Alexa, then re-enabled the Wyze Skill. All are Cam V2 and Pan cameras.

In the Alexa app, this is what a WORKING camera looks like:

In the same app, this is what a NON-WORKING camera looks like:

Those are the only clues I have.