Echo Show doesn't show Wyze video feed (Sorry, [Camera] is not responding...)

I recently discovered that some of my WyzeCam V2 cameras were not accessible from the Echo Show. I have 4 Wyzecams throughout my house and only 1 of them were accessible when I tell Echo Show to “Show [camera-name]…” When I tried to access the other three cameras, the Echo show would reply “Sorry, [camera-name] is not responding”.

I went through all the troubleshooting tips that I can find on the internet, including:

  1. Rebooting the problem Wyzecams, Echo Shows, and my routers/extenders.

  2. Deleting the cameras and Wyze skill from Alexa and re-enabling the skill and adding the camera back.

  3. Check the camera feed from the Wyze app and signal strength on each. They were all fine and accessible from the Wyze app.

In digging more into the problem, I noticed that in the Alexa app, the 1 good camera that can be accessed from Echo Show would have a different settings page than the rest. When I go into the camera settings within the Alexa app I can see the sub-heading for “Announcements” that gives me the ability to turn on Person Detection Announcements. However, the other three cameras did not have this sub-heading. All 4 Wyzecams are configured exactly the same thing with the same settings (only person detection enabled in notification).

I just want to know why 1 of the camera seems to have a different settings page and that seems to be the only camera accessible from the Echo Show. How do I get that settings page on the other three cameras?

Any help would be appreciated.

Only immediate suggestion is telling Alexa “discover”.

I’ve tried deleting the cameras from Alexa and asking it to discover them again. They show up and allowed me to add them no problem. But their settings page is different than the one camera that is working. And I don’t want to delete the working camera from Alexa in case I can’t get that camera working again.

And these are all on a single Wyze account? And a single Amazon account/user profile? If so, I got nothin’.

Yes, all the Wyze cams are under one account, and same with the Echo show… it’s under one Amazon account.

1 Like

Same exact issue. 2 of 5 cameras work, all same cameras except 1 cam pan that doesn’t work. And same announcements on the 2 that work. Will let you know if I figure it out and you do the same.

There is another thread that has more information and a temporary workaround:

But you said you already tried rediscovering. Is there another thing that worked for you?

Edit: never mind, I see you meant the renaming part.

That works as crazy as that is - thanks for the info. Also, it really doesn’t have anything to do with the Show as it also affected my Firestick. I just recently got the Show and was testing it out when I saw the issue. I actually fixed one of the cameras, but didn’t realize how I did it when I renamed it because of a conflict with the name and a group.