[SOLVED] Alexa Echo Show is not showing Wyze Cam v2 streams

I have 6 cameras (WYZE Cam v2, FW version latest as of today: 4.9.8.501). All are shown on Alexa Echo Show except for one. While investigating, That cameras is listed under Devices → Cameras on Alexa app with my phone, but it is saying: Wyze - Live view is not supported. (as shown in the attached screen shot) below:

Can you please help me to find a solution.

Note that, the streaming of that camera on the Wyze app is working perfectly.

Hey @jamilur_rahman, I am seeing a similar anomaly with a Pan Cam V2 in the Alexa app all of my other cameras that support the Alexa Live view including other Pan Cam V2s show the live view. I will poke and see if I can’t goose this somehow.

1 Like

Eventually, I found the root cause of the problem and the solution.
If your camera was renamed (name changed after first time activation) then Alexa will show this message (Wyze - Live view not supported).

My solution:
When I renamed the camera back to its original name (which was used at first time activation), Alexa could detect the camera and it is also streaming on Alexa Echo Show.

Probable cause:
I assume, the Wyze Cam v2 backend server doesn’t update the original camera name if it is renamed later after first time activation.This can be easily fixed by updating the backend DB table.

For @R.Good and others having the similar issue can try either of the following solutions:

  1. Rename the camera back to its first time activation
  2. Reset the camera to its factory setting then install as a new camera and give a new name as you desire

For Wyze tech support team:
This could be a bug in the Wyze Cam v2. The renaming of the camera should also be updated at the backend service where Alexa pulls the streaming data

2 Likes

Thanks for the follow up and detail! Unfortunately for me my Pan Cam V2 had the same name since deployment. But I will try to remove the camera and re-add in the Wyze App

The things I did try that offered no resolve;

I tried to remove the Wyze Skill from Alexa and reenabling

Removing the Camera from Alexa and rediscovering

Power Cycle of camera

I recall similar stories where renaming to camera to anything different helped, at least for a while. Might fix you up @R.Good .

For me, one of my V2s was not Echo viewable after the AWS outages but a later power cycle brought it right back. Of course I can’t get to them via the Alexa app at all for some reason (probably my ancient firmware).

Thanks, yea, Im going to give it a try when I get back to the house.

I haven’t added or redone a camera in awhile, curious if I will run into the QR Code scanning oddities I have been reading about.

Maybe to be fair I’ll start a new thread since this one is tagged as a V2 and I’m working with a Cam Pan V2.

Well… Just renaming the device didn’t do it. Was foyer V2 then I renamed to Main Hall Camera.

So I removed the Camera from Alexa, Removed from the Wyze App, Cleared the Wyze App Cache, Closed the Wyze App, Reopened the Wyze App and re-Added the Cam Pan V2 that was giving me the business and it now shows without the live view not supported, but the camera doesn’t want to pull up in the Alexa App and my Fire devices just keep saying the camera is not responding.

Ima let it percolate for a bit and see if it will come up.

1 Like

Hello @R.Good , I am sorry to hear that my solution didn’t work for your pan v2 camera.
One last thing I would suggest, reboot your Alexa (assume, you have Alexa Echo Show), which may clear all the cache from its local db.

Share your result.

This is actually a valid approach. Amazon Alexaworld works in mysterious ways and often does take a day or so to clear things up.

Of course it works the other way too, where commands that worked great for months just stop working randomly from day to day. It’s a toxic relationship really.

1 Like

Yep, working now. Just needed to steep a little :wink:

1 Like

@R.Good , Happy to know that all are good now :slight_smile:

1 Like

proxy-image(18)

I am having the same exact issue, but still have not been able to resolve it. I have several Wyze pan cam v2 cams that work fine, But one of them is not showing up with live view in Alexa. The only thing I can think of is that I had one camera go bad and I had to swap it out with a brand new camera and when I installed the new camera I gave it the same name as the previous bad camera. So, I wonder if something on the backend is reading the newly named “living room” cam as the old now-disconnected camera and that’s causing the issue. Of course, I have already named the new camera “living room” and changing the name doesn’t solve the issue. Any other thoughts?