Wyze Cam v2 - Alexa (Echo Show 8) - "Camera Is Not Responding"

Does anyone have a good suggestion for a replacement of the wyze cams since they don’t work with the Echo Show 8. Mine worked for 2 days then stopped. Tried all the steps above, no good.
I would like to be able to have cams streaming to my Echo Shows. Any suggestions for cameras that will work with Alexa Echo Show?

The blink works great. I’ve been a very strong supporter of the Wyze cam’s but this is really making me begin to look elsewhere.

Hi Dylan,
Thanks for taking the time to respond to me. I have seen the blink. I will go check it out.

Thanks !!!
Best Regards,
Pete C

Hi, I bought an Echo show 8 in order to see my Wyze Cam Pan and another two Wyze outdoors that are coming to my house, but…by my surprise, I saw my Wyze Cam Pan in the Echo show only one day,. I tried everything to solve but nothing, doesn’t work! so sad. I felt cheated.

I read here that the solution is coming by firmware? because the trick to say to Alexa “discover my devices” doesn’t work in my case.

in another hand, in a desperate moment, I setup my Wyze cam pan from zero, and now the app is telling me that I haven’t my subscription to Cam Plau, but in the site tells me my subscription is ok… could you please confirm?


I do have two cameras, one is Wyze Cam Pan and is not working with Alexa Echo Show 8, but the another one is TP-Link KASA outdoor is working so good!

Folks, the ~10 minute limitations on using Echo Shows were discussed in the forum for a while. That’s why I got a FireHD tablet instead. It can run the Wyze app and/or TinyCam directly, so none of the limitations apply. I later added TinyCam to some Fire sticks.

Yes, WyzeFrederik’s post indicates that once WebRTC support is entirely rolled out the direct streaming will bypass the Show time limitation.

I am having the same problems with the echo show 8. My wyze app on my phone works great. The cameras showed up at first and now they do not. It’s pretty disappointing. Anything else I can try.

Rename camera.

Uninstall / reinstall Wyze skill in Alexa.

Uninstall / reinstall Alexa app.

Tell Alexa “discover”.

Restart app.

Not necessarily in that order. Good luck?

I’ve done that with no luck. Thanks

1 Like

I have done everything on this forum. No luck. Wyze please help.

1 Like