5 Camera setup and two cameras do not respond to Alexa,

They are recognized by Alexa , I get a screen saying waiting for WYZE camera it flickers a couple of times and then come back with the voice prompt Camera not responding. They work fine on the WYZE app I have disabled the Alexa skill and did discovery ,Alexa sees the cameras but can’t display them. any suggestions, is it an Alexa issue or WYZE issue?


Are they V2’s or Pan?

V2 with the latest firmware update


I have seen a couple posts around here about potential Alexa issues. Here is a link. I am not using Alexa with them, but hopefully this may help a little.

Thanks I’ll look at it.

1 Like

Just an FYI, I have 2 cams that haven’t been working with Alexa for several days now, the others 5 work fine. I noticed today that those 2 cameras have been showing an excessive amount of uploads over the past several days also. One camera showed almost 8 GB just today. I suspect something’s stuck trying to communicate with Alexa. I had to power cycle the camera to stop it and now it is back to normal… the uploads, that is. The cameras still don’t connect.

1 Like

This is the same problem that I am having. I have 2 of each camera, 2 version 2’s and 2 pans. I cant get any of the to work with my Fire TV Cube. I am using the latest firmware and the Beta Wyze app.


8 GB is a lot. Maybe its the NSA/CIA using Alexa to spy on you. :stuck_out_tongue_winking_eye:

Yes, it is. The other one was almost 6 GB for half of yesterday. A power cycle stopped that one too.

1 Like

I’m having same issue, the smaller cam seems to work with Alexa but my 3 cam pam do not.

1 Like

Thanks for letting us know, folks! If you’re running into this, please try power cycling your Wyze Cams (I know that some of you have already been trying this). A lot of the time, the connection failure is due to the IoT connection being offline. If that doesn’t do the trick, please message me the MAC address from the camera, the last date and time that you tried and failed to connect, and your time zone. I’ll ask the team to look on the back end. :slight_smile:


I am having the same issue with one camera out of 5. 4 work fine with my Echo ecosystem, but one will not display. My Echo(s) see camera, and say waiting, flicker and then fail with message camera not responding. Signal is strong, same AP as 2 other cameras that do work correctly. Mac: A4DA222A2BDC Eastern time zone, will try again now.

I messaged you

1 Like

Please message me WYZE

I will give you mac addresses. I have 2 V2 and 2 Pans Only one PAN works, all on same wifi, and I cannot see the remainder. Frustrating. All have latest firmware, Including the 2 PAN updates yesterday. Frustrating.

Same problem. Two cams - a V 2 and PAN. They both work fine communicating with Android phone app. However, neither have worked correctly on the Echo Show since the first two weeks. I even upgraded to the Show 2 and still not look. Message is camera is not responding and I get nothing. We purchased the cameras and show to help keep an eye on my 89 year old mom. This is so aggravating. Wyze tells me it is an Amazon issue and Amazon tells me it is a Wyze issue. I have done all of the updates, factory resets, removed and reinstalled the software to no avail. Would LOVE to get this resolved before I have to leave Wyze and go with a competitor.

This is what I find troubling. A lot of folks having these issues and all we want is an acknowledgement as to why and if this is being addressed. I almost clicked on Amazon to purchase more cams. I have two netvue Pans and zero issues with Alexa

@LJPOKAS and @MARINE, we’re working on it! I’m not sure which end it’s at (it may be both) but we’re trying to collect data so we can sort it out. We’re collecting the MAC addresses and date/time of connection to try to figure out where the problem is so that we can work with the Alexa team to fix it. We understand that this is frustrating and we apologize for the experience.

Info sent. Thank you for acknowledging

1 Like

Good news. I hope it is resolved soon. It has been quite some time - my first Messenger conversation with Wyze was July 18, 2018 regarding this buffering issue with Echo Show! It has never worked consistently since.

You’re welcome, MARINE! I received your message and appreciate the data.

@LJPOKAS, we hope that it will be resolved soon, too. That’s definitely a long time to go without a stable connection and we appreciate you letting us know. We’ll keep working on it. :slight_smile: