Wyze App 2.28, Wyze Cam v2 & Cam Pan, Wyze Light Strip & Strip Pro, Wyze Thermostat Firmware Beta Test 1/19/2022

Wyze App 2.28 RC Test:

App Versions:

  • iOS: 2.28.0 (7)
  • Android: 2.28.0.b100

What’s New:

  • Fixed a bug that displayed the incorrect default time when creating a new rule (iOS)
  • Fixed a bug that muted sound when dragging the timeline in playback (iOS)
  • Fixed a bug that caused a crash when deleting Wyze Bulb White (Android)
  • Fixed the flashing blue light issue on Wyze Base Station when viewing the Solar Panel Settings page (Android)

Wyze Cam v2 & Wyze Cam Pan:

Firmware versions:

  • Wyze Cam v2:
  • Wyze Cam Pan:

What’s New:

  • Fixed a bug that caused Error 05

Wyze Light Strip:

Firmware Version:


What’s New:

  • Modified the color temperature range of Sun Match to be the same as Wyze Bulb
  • Improved color accuracy

Wyze Light Strip Pro:

Firmware Version:


What’s New:

  • Modified the color temperature range of Sun Match to be the same as Wyze Bulb
  • Improved color accuracy

Wyze Thermostat:

Firmware Version:

  • 1.2.0

What’s New:

  • Added support for collecting weather data for an improved energy saving algorithm
  • Added support for Restart through the app
  • Fixed a fan operation problem while heating


  • Android App Installed without issue
  • iOS App installed without issues


  • Light Strip Pro Updated without issue
  • Light Strip Strandard Updated without issue
  • 1 Cam v2 Updated without issue. The other required me to remove and resote power before the udpate worked. In all fairness, this one camera has always given me issues.

My Thermostat hasn’t connected to the WiFi in about a month now, but it is still running the schedules and everything okay. It even still shows up in the app with how much it is running each day (most days), but always shows as not connected and won’t let me do anything through the app. So weird…so it is apparently connecting but says it isn’t. I tried pulling it off the wall and putting it back on, but it didn’t change anything.

I need to probably reset and set it back up again. Not sure why it suddenly stopped connecting though. I haven’t been too worried since it’s still functioning to keep the house warm and running on the schedules, but maybe I’ll try to reset it now that there is a new firmware test and see if I can fix that.

I got this RC App! I didn’t get the previous beta for some reason though.
@mbrindle see if you can get this new RC beta now, it let me get this one.

All the Camera firmware installed successfully on the first attempt except for 2 of them. on the second attempt, one of them immediately said successful (so it must’ve actually been successful the first time as well since it was immediate this time (no time taken to download or install it the second time, it just switched right to updated)…not sure why it said failed), and other V2 failed the second attempt too. I went for a third attempt (still through the Account tab - Firmware section and it was successful on the third attempt. (this is a V2 cam that has always had the most problems, including the perpetual rebooting issues in the past).

Update: in the RC App, it is impossible for me to add any new rules or Device groups. The + symbol on the upper left side of the home tab is not accessible at all on my Google Pixel 5. I tried at least 100 times, it will not trigger. Either it is overlayed on the camera or too close to the top or both. Can anyone else use this or have problems with this? Maybe it is only a problem for certain phone resolutions (though a Pixel 5 is a pretty common model). @spamoni4 I know you have a Pixel 5 and a Pixel 6, so if you have this RC, maybe you can verify (it’s okay if you can’t though).

1 Like

Updated my Motorola g7 power and #$%^&* iPhone8 without any issues. My tablet is in the truck so it will be later.
Updated 15 V2 and two Pan cameras from the Account > Firmware update page. All except one V2 updated on the first try. Updated the one missing one from the camera page and it worked fine.
@carverofchoice I am unable to duplicate your + symbol problem on either phone.

1 Like

Checking now for you:

Pixel 6: On the home screen clicked the + sign top right, the popup appears to add rules, devices Etc.

Pixel 5: Same as Pixel 6, screen come up without issue,

Maybe restart your phone?

1 Like

This actually did fix it! When I rebooted the phone, the plus sign was now slightly lower than it was before restarting the phone and it works now. Interesting. You’d think it should show up the same way.

To be fair, I am running Android 12 with the latest Beta update, and the last 2 Android Betas have been a little buggy. Probably not Wyze’s fault.


I am Android 12, Pixel 6 just got the security patches. Not going to Android Beta as I had issues in the past. May eventually do that on one of the Android phones I have.

Glad it is fixed though

Yeah, I intend to opt out of Android Beta when I get around to looking into it. I originally opted in so I could I get Android 12 early, just haven’t opted back out since it was officially released…I remember them saying something weird at the time about how you can’t opt back out without reformatting the phone, but I think that was just because you’d have to revert to 11 at the time…hoping I can opt out now without losing all my data…just been too busy working to check.

1 Like

Yea, I had the beta and then opted out. Problem was I had to set the phone up again. Did this twice before I gave up.

1 Like

FYI: to get the individual Wyze AI Event Notifications, all I had to do was go into the AI detection settings (on a V2, V3, Pan V1, or Pan V2 cam) and change ANYTHING at all (I tested multiple combinations). Remove a single detection or add a single detection…ANY change at all, or multiple changes (though not necessary) and it will then update to allow the individual notification options in that cam. No other steps necessary.

  1. Assuming you already have Cam Plus on the cam, Go to Settings for that cam
  2. Select Event recording
  3. Select Smart Detection
  4. Make ANY change at all on any one of the toggles, even toggling it off then back on…any toggle change at all or multiple changes if you wish
  5. Now go back twice to the Settings main screen
  6. select Notifications
  7. Select which detections you want notifications for

Now we can detect everything we want without being forced to have notifications for all of those things. We just have to make any detection change at all for it to show up first.

On a separate note, it will allow you to select to get notifications for something even if you don’t have it set to “DETECT” that category of event. Some people should test what happens if you select to get person notifications but don’t have person selected in the detection settings (or pet or vehicle or whatever else…it just seems like “person” will be the easiest one to intentionally test).

Secondly, there are no longer options to detect or be notified about Crying, Meowing, or Barking detection through the AI. I haven’t seen this mentioned anywhere yet, but these options have now disappeared completely from the app.

CORRECTION: V2’s still have Meowing, Barking, and Crying DETECTION Options, but NOT NOTIFICATION options…so it seems like it will no longer alert me if my baby is crying on my V2 Baby monitor. This should be updated, because the previous app would alert me when my baby was crying, but it seems that it will no longer offer this as AI notification (though I can tell it to alert me to sounds in general, it won’t only send me crying sound alerts now). (At least I THINK it used to send me crying alerts before…maybe it was just sound alerts? But it should probably be something added as an option to V2’s regardless since people like to use these as baby cams and want to be notified when the baby is crying, and not just sounds like a loud car driving past) :slight_smile:

I was thinking the “Pet events” notification toggle might be used to also include Meowing or barking detection notifications, but even if that were so, that still leaves out “Crying” notifications.

Video Doorbell Pro does not offer Individual Notifications separate from detections yet. You can detect all motion and all AI events or just certain AI events but no other motion and notifications stay with only allowing you to get notifications for ALL AI events or none of them. Definitely needs an update here.

WCO also does not offer individual Notification options yet. It is also ALL or NOTHING still.

Tested my office cam with all notifications set to OFF except for the Face events, and it appears to be sending me notifications about ALL movement, and saying “Complete Motion detected on Office Cam” all the time, despite everything turned off except for face events. We might need to test for similar false notification errors.


I finally deleted my thermostat from the app and reset my thermostat back to factory settings, and it finally connected again and let me set it all back up. I then told it to update the firmware, and partway through the update, it said the update failed and the thermostat was back to showing offline again.

Log 442788

I am sure I just need to contact support and maybe get a replacement after some troubleshooting (since it was having offline issues for the last month), but just in case there is something related to this beta firmware update (since it started to update and then failed partway through the attempt), I submitted a log for you.

Well I have 2 v2,1ptz v1,1ptz v2,that all were bricked during the update,the 1 ptz 1 the blue light flases,and it will flow you,but the IP adress is not showing up on our list,l of them are not,the v2 after power is add it shows blinking blueight,blueish, v1 pts blinking blur light and it will follow you,base Lee worthlress,worthless, try to add them to the add and they will zip 3e

No issues updating 8V2s and 3 Pans v1, everything is fine.

The issue on iPhone 12 and 13 is still there when you set your zone detection in lanscape mode. 2.28.0 (a7)

I got it… still stumped why I didn’t get the other…

1 Like

App installed without any issues on my iOS device and 2 Android devices

2 Tstats
1 Light Strip
1 Light Strip Pro
4 V2s
3 Cam Pan V1s
Firmware updated without issue

@Yichen, I did want to point out that this is still an issue on iOS with this latest update.

Thank you

Ohhhhhh and Happy Birthday @gyzmo No cake after midnight for you. :partying_face:


Hey, new to the Beta program, joined via Play Store but I don’t see any options to update, specifically one of my Pan cams that didn’t get the 8.746 update which is paused, but is still stuck on 8.501 indefinitely with an unknown status.

I’ve been having issues since later in december (whatever firmware came out then) with Person Detection not working on my Cam Plus Wyze Cam v2. Log: #443379. Person Detection works on that cam when Cam Plus Lite is enabled but not with Cam Plus. It’s running this most recent beta firmware. I’ve tried this on two different Wyze Cam v2s and it doesn’t work on either. This goes back at least one or two firmware revisions.

On iOS with Wyze App 2.28.0 (a7)

When selecting tags to submit a video for AI research
On recorded events for the Wyze Cam v2, v3, Cam Pan v1, WCO, VDB, VDBP

If at any point you tilt the phone backwards or tilt to the left or right far enough for the screen to rotate the tag selections automatically deselect themselves.

If the Screen orientation lock has been turned on the behavior does not happen.

This same behavior DOES NOT happen on Android.

LOG ID: 443739