Wyze App 2.28, Wyze Cam v2 & Cam Pan, Wyze Light Strip & Strip Pro, Wyze Thermostat Firmware Beta Test 1/19/2022

Great find. Never had this issue, but never forced it to rotate.

A discord member, brought it to attention in a discussion. I just validated and tested deeper scenarios.

1 Like

Added a Test Mode for testing Wyze Cam Floodlight and Wyze Lamp Socket during the day

Did anyone figure out how to use this Test Mode on the floodlight or lamp socket? I couldn’t find anything that indicated any kind of test mode on either device. The only things I could find were what was already there (manually turn it on or off, but no way to test the automatic controls or anything when it daytime).

1 Like

@Yichen Collecting weather data? Please do share more.

Also remote install w/ iPhone 12 :+1:t2:


This was provided by @WyzeJimmy in the Discord server in response to another memeber curious about this.

Member Question - “Do you have any more in-depth info about what the updated algorithm using weather data actually does with the beta thermostat firmware?”

WyzeJimmy Response - Here’s what Dr. Chuan has to say about it!
“The new firmware can anticipate heating demands thanks to outdoor temperature data, which lets us provide better heating time estimation and fine tune the heating point steps based on the temperature difference between outdoor and the temperature setpoint.”


Huh. OK. Thx!

Even if the vehicle notification is off, I continue to receive them. 2.28.0 (a7)


I would love it if the outside temperature influenced the humidity setting. When the temperature goes below 25°F, I start having to manual adjust the humidity level down.

The same issue is also on the official released 2.27.37. I had never noticed that. :+1:

Edit: 2.26.0 has the same issue. The farthest we can go with TestFlight.


My Thermostat “Auto Switch” was set to off, but when I left home today it notified me that auto switch changed me to away then back home again when I came home. I checked and the APP GUI still said the Auto Switch was set to off, so it shouldn’t have done that.

I will mention again that I recently reset the thermostat to factory settings and set it back up again. Then I tried to do this firmware update and it failed. Then I reset to factory again and tried the update again and it was successful. Any one of those things could’ve been involved in causing this issue, but the main point is that the App GUI said Auto Switch was set to OFF, but it was still running. I just now switched it on then back off to see if that fixes it.

Just in case someone wants to look into it to see if it is related to this new thermostat beta firmware or Beta RC App release, I created a Log for the devs:

LOG 444736

1 Like

Good catch @carverofchoice . This could be related to the toggles not actually displaying what they are. Similar to the additional Notification items. THere were times where Android would show one toggle setting and my iOS showed another for the same device same setting. When I reset it, using the Android device, things started to work again. I have not seen it as much as I have in the past, but on occasion I have noticed this with the Android Devices.

Now it is an additional step which I do when I update the app or Firmware. I reset the toggles of critical items. Or I at least verify against my iOS.

1 Like

@WyzeBaohua @WyzeAndy @Yichen

Toggle Issue Continues… :slight_smile:

I was going through my settings for my Driveway Camera. I decided to toggle off the Event Recordings settings including the Smart Detection. I also went to Notifications and toggled off the Wyze AI Events and Notifications.

I then went back and toggled on Detection Motion as shown in the image below. Wen to Smart Detection and turned on Person and Pet. I then went to Notifications and turned on Notifications shown in the second image. However, I could not toggle on any of the toggles below it. Notice the circled message indicating that I will not receive notifications until I toggle on Event Recordings. But as you can see it is on.

I did get it to work by backing out and going into Event Recording, Turning Off Detects Motion, Backing out one menu, going back to Event Recording and then Turn on Detects Motion. When I went back to the Notifications Menu I was then able to toggle the Wyze AI Events and select what I would like to be notified of.

I submitted log #: 444773


The new separate settings for notifications are gone. They’re back “old fashioned” iOS 2.28.0 (a7)

This morning:



The controls for 30 seconds backward or forward for SD card Playback now show up, but they don’t work. When I press them it pops up this little timestamp thing overlay on top of the video I’m watching with two little arrow each direction, but it never actually moves forward or backward:

I tried single press and double tap and tried pressing the thing that pops up on the video. Nothing works yet. I tried several different models.

Correction: If you tap the backward or forward icons repeatedly and watch the timestamp, it does seem like you can make it jump forward or backward a half a second or a second or so, at least according to the timestamps not moving consistently up 1 second per second. So maybe it is doing SOMETHING, just not working as intended? Can anyone else confirm?

(Yes my daughter does like to sleep like that often…she hoardes things underneath herself so she knows where to find them if she wakes up :rofl: )


It is working as it should on my side. I don’t see your issue. 30 sec backward or 30 sec forward on each press. No issue in landscape too.


That’s iOS right? (glad to hear it is working, this indicates it is intended to be active for everyone right now)

Anyone able to get it to work on Android?


I just tested on my P5 and P6. It functionsnfor me. However, I have noticed that if your SD card is setup for event only recording, the advance and rewind stays within that recording. I then have to click on the left or right arrow (chevrons) to advance or go to the previous events and then I can use the 30 second advance or rewind.

I will check another camera where I do continuous recording.

Just checked and functioning as well.

1 Like

@WyzeBaohua @Yichen @WyzeAndy

@R.Good noticed alignment differences with live streaming different camera’s. Impressive find by him. :slight_smile: . He asked if we could confirm the same results which I was able to do. Since I have both devices, I compared both devices and 4 camera’s.

In any event, we thought it would be worth reporting so that the developers can ensure consistency when streaming different camera’s, you know fit and polish of the app. Consistency goes a long way when using the app.

I am providing 4 camera’s and the Live Stream placement on an iPhone (Xs model) and an Android phone (Pixel 6).

This is the order, left to right, Cam v2, Cam Pan v2, Cam v3. WCO, VDB v1:

This is what it looks like on Android

This is what it looks like on iOS



Cameras in Order, Cam Pan V1, Cam Pan V2, Wyze Cam V2, Wyze Cam V3, Wyze Cam Outdoor, Video Doorbell, Video Doorbell Pro

iOS 12 Max Pro


Android Pixel 6


Appears to function as intended for me on the Pixel 6 and Samsung Note10+


Pixel 6
Video too large to post… But I promise it worked :wink: