Wyze Air Purifier & Thermostat Beta Test 7/18/2022

Wyze Air Purifier Beta:

Version: 1.0.9

What’s New:

  • Improved Wi-Fi stability
  • Fixed a bug that prevented the available Wi-Fi network list from showing during setup

Wyze Thermostat Beta:

Version: 1.2.3

What’s New:

  • Improved Wi-Fi reconnection after going offline

Installing now, will report back if there are any issues.

Question: With the T-Stat will it correct the issue with the Remote Sensor being removed from Comfort Settings randomly?

EDIT - Air Purifier Update

Installation seemed to work well. However, it did not install via the Firmware udpate Menu I had to go directly to the Air Purifier and do it from there.

1 Like

Updated my 3 Air Purifiers, though I likely won’t be able to give much feedback on the changes since 2 of them never had a single connectivity issue and the other one rarely did, so I can’t say I’ll be able to tell much difference. I did try resetting the Wi-Fi in the past too, and never had a problem with the WiFi list to my knowledge. But I will mention if anything else new is noticed. :+1:

I’m updating the Thermostat too, but since I rarely went offline in the first place, I also probably won’t notice much change with the new firmware but I will keep an eye out.


I let @towelkingdom know, she was having connectivity issues. Hopefully she will be able to do testing to see.

My T-Stat never went off-line, but the remote Sensor started to remove itself from the Comfort Control area after the last Beta Update 1.2.2. Will see if the Remote sensor loses connectivity after this update

1 Like

Ah, I wouldn’t have noticed that. I temporarily paused the comfort control feature after my brother-in-law moved in (just while he’s waiting to buy a house). I trust you to check on if there is a difference.

1 Like

@jentsang @WyzeBaohua @WyzeJasonJ

FYI: Just tried twice updating the T-Stat and received the following, tried twice so far:

Log Submitted: 650760

I am going pull the T-Stat from the wall and try again to see, now that I submitted a log.


Just pulled the T-Stat off the wall for about 30 seconds or a bit less. Put it back on the wall, waited until if fully connected and then tried. Same results as above. Firmware Update Failed.

Note: My previous Firmware version was 1.2.2

----------ANCILLARY ITEMS --------------------------------------------------------------
Additional item, not necessarily related but interesting to say the least

My Wyze App Screen just went White will trying to submit a log. I restarted my phone and the app will not start. :frowning: Just uninstalled the app and installed it again. Seemed to have corrected it. Might have been an issue with my device.

For Fun, just tried again to see if the Firmware would load after removing and installing the app again. Nope, same error.

New Log Submitted 650814

Same here, I tried twice. Thermostat update failed twice.

Log 650782

1 Like

Same here. Also never had a WiFi connection issue before. I also noticed that for some odd reason, my Air Purifier has a new MAC after applying this firmware update.


Interestingly, I had both Purifiers named on my Router. After the update, they went back to the default. Only thing I can think of is a change in the Mac Address as with you. I just named them again.

1 Like

Yeah same issue, failing to update firmware as well for the thermostat. Was on 1.2.2 as well.


@carverofchoice , were your T-Stats on 1.2.2 as well?

Updated my t-stat this morning. Seams to have fixed the sensor problem I had. Will test more and see.

What was the FW version of you T-Stat prior to updating? A few of us are having issues.

It was 1.2.2.

Interesting – I will try again. Maybe something got fixed.


I upgraded through the (account firmware) group page

and it went to completion?

I just tried again via the T-Stat Settings area and it failed.

Will try via the Firmware update page as you did.



@budbuss , trying it our way and it is functioning differently. But it just failed again.

Can you check your version just to be sure it updated.

@WyzeJasonJ - is there anything you or Wyze would like us to do or test for the T-Stat? FW update is not working for some of us.


1 Like

It upgraded to 1.2.3


Thanks, I wonder what the difference is. I have 6 sensors connected, but that should not make a difference

It shouldn’t, I have the same amount