Wyze Air Purifier & Thermostat Beta Test 7/18/2022

Well, you are one of the lucky ones. :slight_smile: there are some of us who are having issues

I’ll dig out my old spare and see if it will update.

I was hoping you were going to say that you used iOS… :slight_smile:

But you have Android like me. ugh.

All is good, we will figure this out.

Thanks for doing a test, but don’t go out of your way

Already done. Updated with no problems. FW was 1.2.1, now on FW 1.2.3

Man - you are lucky…

Wonder if it is network related

Probably took around 3 minutes to update

1 Like

mine was taking sometime also and then it said Failed

Waiting to hear from Wyze

I wanted to report back, mine was too failing to update as I posted earlier but now I’ve been able to get 1.2.3.

I was updating through the Firmware Update group through settings. I was on Android 11 device and the only difference I made was I reset my modem and I then tried updating for fun through the Android Emulator for Windows 11 (Based on Android 12.1) and it’s updated. I am unsure what changed, but those are all the major things I had done.

1 Like

Thanks… I will try my iPhone and my Pixel 5 to see if that makes a difference. Will report back

@Stilkdog , tried the Pixel 5 and no luck still. Then based on your write-up where you indicated that you reset your modem, I got to thinking. So with all of the failures, I figured I would try one more thing before resetting my router. I disconnected from my WiFi and used LTE, and ended up being successful. So thanks for your info on what you did.

@carverofchoice , try using Cell Service / LTE, mine worked when I did

@jentsang @WyzeJasonJ - Just wanted to provide an update that I finally got my T-stat updated, but had to do it via LTE / Cell. Not sure what was going on, but at least it is updated.


So what it sounds like is to me some sort of network communication issue/config issue with WiFi, probably presented in the 1.2.2 firmware. Probably had a feeling resetting my network did the trick vs updating through my PC.

Some devices I have had some weird issues with WiFi with. The T-Stat and Outdoor plug have been oddities like this at times and can never figure out why, but I hope this firmware does help solve this problem.

1 Like

I agree. This was a first for me, but now I am updated. Thanks for the push in the correct direction. Hopefully @carverofchoice will have success as well.


No problem and same, hope this just happens to be from the last firmware and still isn’t a issue moving forward, but Wyze does have our logs now so they will be able to catch it.

@carverofchoice good luck and hope you see this and give it a shot.

Mine has failed 6ish times:

  • 3 times on my Pixel 5 (Android 12) -latest beta app
  • Once on Android Studio Emulator running API 33 (Android 13) on an emulated Pixel 4 (latest production app)
  • On a Note 8 with Android 9 and the current production app — it said I am up to date on firmware 1.2.2 and won’t even give me the option to upgrade to this beta firmware. THIS IS REALLY WEIRD…it didn’t exactly FAIL because I never got the option to even try updating :man_shrugging: which is another issue in and of itself
  • iOS (latest OS version) --latest testflight beta = failed update

Have you tried a full network reset? (Modem and Router/s)

1 Like

Not yet, although that’s never been an issue in over a year since I got these awesome ASUS mesh nodes with a great ISP and 1Gbps bandwidth. Never had a memory leak issue in over a year, but it is something I’ll try it eventually anyway (when Wife and others aren’t using the internet for something important). :+1:

Going to try with Mobile data right now first. :slight_smile:

Initiating the update through LTE Data on my mobile Phone did not make a difference.
I’ll try @Stilkdog 's suggestion to reboot my router in a little bit. Might try hard booting my tstat again too.

1 Like

I hear you and don’t worry, I do not think it has anything to do with the actual routers or modems, I just think it’s the device, I use to have to do this all the time when I had random issues with the the outdoor plug where it would just lose network connection when the network reset and a format of the plug just kept it in a stuck state of offline and would not connect. As soon as I reset the routers or network it would then just start working. I’ve not had this issue with the latest firmware so far but it’s annoying and I’m not network engineer but some sort of miscommunication is happening either software side or network side, but I hope you can get this going.

Anyways I’m rocking a AX88U connected to a AX58U in AP mode that’s connected to a mesh network with a AC68U.

1 Like

Have you turned off your WiFi and used LTE?

Just saw this… :slight_smile:
This is odd. Maybe it is a load on the server.

I will say that mine finally worked immediately after it failed. I did not wait, I went from my Pixel 5 - which failed to my Pixel 6 on LTE which worked. maybe it is a timing thing