Vacuum won't save map

I got the Vacuum excited about it’s potential, however after having it for a little over a week, and 11, yes 11 tries to get the vacuum to map my home, it still has not. I have had numerous problems ranging from:

Losing its place in the home…can’t get back to dock.
Losing connection to the internet, despite it being literally 10 feet from the router.
Never saving a map, even if it’s “clean complete”. I have literally tried to vacuum/map our home 11 times and it won’t save/complete a map.
The map is visually skewed and it starts to overlap where it is, so it has to start over.

I would greatly appreciate any support here on this, as Wyze actual support is never responding to me.



Hey David, I’m having the same issue as well. Several runs successfully complete for me and the map is there. But then I send it out again. And the map resets. Not sure why, and it is pretty annoying. I’ve been sending the logs in each time in hopes the devs can identify the bug. Good to see it isn’t only me, but it seems like others are not experiencing this issue.

Do you have the production version of the app or the beta?


The app is the production version. I am running FW 1.6.75 on the Vacuum. It is quite frustrating to not have this vacuum work. As an individual who has been in product design for almost two decades, this is inexcusable. Most of these problems should have easily been found in testing and QA.


Hi @DRESEN.HP and welcome to the community forum. :slightly_smiling_face:
There is a new firmware update coming out soon to fix several troubles.
If you had problems w/setup you might want to check this out:

1 Like

While not the same, I’ve had very similar problems regarding map and accuracy.

I have had it for going on 3 weeks now and it worked flawlessly out of the box for 9 days straight, saving the map and cleaning based on the original mapping for those 9 days. Placement of dock, furniture, etc. has not changed since day 1.

However, since then, it has yet to successfully know where it is and not completely screw the map up two days in a row. I’m talking about it drawing rooms on the other side of physical walls, rolling through where walls actually are on the map, and disregarding virtual walls. So I’ve had to resort to watching it when it kicks on every night, inevitably seeing it screw up, send it back to dock, deleting the map, starting it again, watching it run for the first ten minutes so I can place new virtual walls where they need to go, and then do it all over again the next day.

I’ve had the same issue with the map not being saved and if it is saved, the robot seems to ignore it and creates a new one. In one instance the robot got stuck under a piece of furniture and when it was freed and restarted, it completely lost track of where it was located and wandered around aimlessly.

Until we exhaust everything that hasn’t been documented yet, I just play with Rosie as she learns and forgets things. Yes, Ive seen my map mysteriously disappear on one occasion, but I was able to create a set of rooms and successfully schedule them to be vacuumed individually, Mapping needs a few pillows at this point to “automatically define rooms” and NO, you can’t move the :zap: after mapping. That said, this toy is pretty fun, also she does a great job as a vacuum. Here are some of my maps/rooms that have been working from a schedule this week.

Is there a way to block out a area that is at a 45 degree angle? Our home is in a C-shape with two wings at a 45 degree angle to the central portion of the home. I haven’t been able to rotate the ‘do not vacuum’ zone.

Not Yet

I am in the same boat.
I don’t have an issue with its cleaning ability just it’s software app. In fact my unit won’t down the latest firmware…it just keeps spinning, saying “do not disconnect”. Went to bed and in the morning it was still spinning, and still not downloaded.
Call to Customer support resulted in 3hrs and still was no help.
Wyze needs a real tech support line…or detail training videos, and a better app.

APP Features Needed:

  1. This app needs the ability to save multiple room maps so you can divide the house into sections.
  2. Also have the ability to recall from a list which map to use it a larger home or upstairs / downstairs.
    3.Need a simple map edit feature so you have the ability to adjust boundary or modify vac path after the fact.
  3. Be able to select multi rooms from the a map list.

I shouldn’t have to create a new vac map ever time I want to vac a room…and that’s what it does now.


After a solid 10 days without a single hiccup and performing flawlessly, the vacuum now will not successfully run on the same map for more than one cleaning.

I have to delete the map every single day and place new virtual walls every single day. Going on 12 days waiting on a response to my support ticket.

@WyzeGwendolyn, can I message you my ticket number to get someone to respond?

Pretty impressed with the vacuum, everything seems to be working fine so far. Running latest firmware - 1.6.75. Thanks

The first time after reseting the map, it will redraw your floor plan and assign names to what it thinks are rooms. I had to place a few pillows in a wide entryway to get it to recognize my dining room as a separate room. Once you have some rooms,

o You have to tap to check a room name before you tap clean to clean just one room.
o You can also schedule a single room or multiple room.

Knock on wood, my floorpan, virtual walls & rooms haven’t disappeared

How did you setup individual room schedules. I finally for the vacuum to draw a complete map of my home. When I go to schedule it shows me a screen for starting time, how often and suction level but does not show a selection where I can select specific rooms.

Never mind, found the problem. The robot needed to have its firmware upgraded. Upgraded it and now I can select rooms !

1 Like

Welcome @DRESEN.HP, @gerutzen & @pauld315 to the community forum. :slightly_smiling_face:
Also welcome: @rcpostel, @wolfcorner, @skkyup & @craigfennessy

As @pauld315 & @mtsbst stated, there is a new F/W update 1.6.75 (December 17, 2020)

In addtion there is a new app to address additional troubles:


Thank you,
Important to be on the current updates when comparing notes.

1 Like

There is another vacuum f/w update just released 01/18/2021:

I am having the same issue with the map not saving. It took 5 days for me to Finally get a full clean and a full map and now it won’t save. How did you get yours to save the map?

Boy, I’m having the same problem and having to reset, then re-create the map each time. While the new firmware and app adds the much-needed room editing feature, I really haven’t been able to use it. If the vacuum gets stuck during mapping, or needs a bin change, it loses much/all of its map (or the map becomes corrupted and mis-drawn). Let’s hope Wyze is on this and help is on its way!