IMPORTANT FIRMWARE UPDATE: Wyze Robot Vacuum 1.6.97 and Wyze Plug Released - 1/18/21

Howdy, forum folks!

Wyze Robot Vacuum 1.6.97 and Wyze Plug (the newer version with a key design on it) have released! These add support for room editing and match a server-side change for the vacuum and fix a plug bug with the status light.

If you have a Wyze Robot Vacuum, please update as soon as possible so your service isn’t interrupted!

Read our Release Notes:


What is the typical time for the update to happen? I have tried multiple times to run the update and it just hangs on the updating screen for a while until the app crashes.

1 Like

Welcome Anthony. If you’re talking about the vacuum firmware update, mine took about 4 minutes this morning with a good WiFi signal from an Android phone. Vacuum was fully charged and docked.

I have same problem. I have tried 6 times and waited over 15 minutes. Will not update.

I had this problem yesterday as well. The firmware would not update. Another user suggested uninstalling and then reinstalling the Wyze app and then trying to update the firmware. That worked for me! Give that a try.


I also tried deleting and reinstalling the app. The update worked right after that.

1 Like

Woo Hoo, room editing is here!! Easy to use as well, bonus! Thank you Wyze for listening to us all. But, I still have a small issue - mapping missed a bathroom, how can I add it, or (holding my breath) do I have to re-map the whole house? Finally, what does re-set map on the settings menu do? Thanks, Rodney.


Thank you, that worked. Sometimes we overlook the simple fix.

I downloaded the new firmware. Now my vacuum continues to clean areas that it has already done and won’t go into rooms that it hasn’t cleaned.
I have cleared the map.
Any suggestions?

tried re-installing app, but when i tap into the vacuum in the app it just goes to the updating screen with the gears, and seems to be doing nothing. been over half a day now. vacuum itself is pulsing with white lights, and a brick now. it was working just fine prior to trying to update the firmware. how do i get it going again. this is quite frustrating.


This thing is junk. Started vacuuming and then gave a message to move to a level surface which it is on. It is now is stuck running in a circle and has been moved several times. Power button doesn’t work. Anything I try in the app causes the vacuum to say to move to level surface. I have it outside circling now so that the battery can die and I don’t have to listen to it. Of course, Wyze has no live support. What garbage!

Cannot use internal walls or the newly created wall as an anchor point. Trying to square off the area on the bottom right is impossible.


Anybody else having trouble updating from 1.6.95 to 1.6.97? No message, just doesn’t do it.


Nevermind. Following suggestions here, reinstalled app and update works. Note: looks like beta app is done, so installed regular app.

was your vacuum pulsing white at any point? reinstalling the app doesn’t do anything for me as it doesnt seem like the vacuum can reconnect to internet after I first initiated the upgrade. it’s stuck in limbo

1 Like

This is what my vacuum is doing. I have tried uninstall/reinstall of the application with no luck. When I log back into the app it still shows the Updating… status. The unit lights are slowly flashing or pulsing. I started the firmware update over an hour ago and it has yet to resolve.

1 Like

Mine just shows a red line and says “the splitting line must all be contained in the room.” No matter which room I try or where I place the line it says the same this (see attached.)

How do you actually split a room? Or is it still broken?

I did uninstall and reinstall the app and the vacuum firmware is the latest edition it has the same issue.


Updated my Vacuum now it sits blink white lights and will not respond. What can I do? Also while it was charging I tried to merge rooms and name rooms. It failed each time. I was really happy with the vacuum and now the update.


This is the same issue I have been having. Was told on another thread that the lines must be on exterior walls, but as far as I can figure out they are and no matter what portion of the map I move the end points to, it gives me this same error message.

1 Like