Wyze Robot Vacuum Pairing Survey

Hi, everyone!

The manufacturers of Wyze Robot Vacuum asked me to send a survey out to people that have received their vacuums.

We noticed data that indicates that there can be improvement with pairing success. We aren’t seeing a whole lot of reports about pairing trouble so we suspect that it is generally working when people try again. We’d love more data about the customer experience to help with our investigation.

If you have received your Wyze Robot Vacuum and worked on the setup process, we’d greatly appreciate you taking a few minutes to fill out this survey.

Thanks for your time! :slightly_smiling_face:


Amazing vacuum. How I can connect the vacuum with Alexa?



There isn’t an Alexa skill at this point but I’ll share your interest with the team! :slight_smile:


I answered the survey. I have yet to get my vacuum to connect. I spent too many hours with it and had to set it aside. I’ve gone through all of the suggestions including putting the phone in airplane mode, allowing precise position, doing a factory reset, etc… I work on networks for a living so I’m not new to this but I’ve run out of ideas other than taking it to someone else’s house to try their WiFi or standing up another router to try. I have Wyze cameras and have never had an issue with setup.


I solved my pairing issue but rebooting my phone, weird…

I often have to reboot my modem and router when I have pairing issues. The other problem was not having the password (making sure the right password is visible before continuing).

I have Google Mesh Wifi and unable to connect the vacuum. I suspect that it may be an issue with 5ghz vs 2.4ghz, but cannot figure out how to resolve. I got it to connect one time and it started mapping but the battery ran down in the middle of the room. Had to carry it to the docking station and it will not recognize or connect to a wifi. It may be a user problem, but this needs to work easily and flawlessly or it kind of negates the reason for having.

I just set up my Robot Vacuum this evening. Didn’t read the instructions (I’m a guy :rofl:), snapped the edge brush in, plugged the dock in, charged the vacuum until full. Opened it up to verify a HEPA filter was installed. Added it to the Android app and went through setup without a hitch, updated firmware to the latest… super easy. Did a test run through the messy main kitchen after cutting the straggler IPs off the area rugs. We formed a human chain to create a virtual wall to limit this cleaning session to the kitchen. This vacuum worked awesome cleaning everything from cat fur tumbleweeds, crumbs and whoknowswhat from the kids’ party, then returned to base. I’m impressed so far and will let it venture out onto hardwood tomorrow, then into some carpeted rooms. Will fill out the pairing survey if it’s still up, although I have nothing negative to report.

Edit: BTW… I connected mine via Google Mesh WiFi network.

After my purchase and the receiving of my vacuum when I tried to setup the WiFi it told me I need 2.4GHz. I don’t have 2.4GHz my system runs on 5.0GHz and most to the items from Wyze also require 2.4GHz. Why haven’t you concerned those that only have 5.0GHZ systems.

I had no issues pairing but I did have it drop from wifi a number of times. I found that powering it off and back on it usually reconnects. I also disabled 5GHz SSID broadcast leaving 2.4 broadcasting. This helped as well and the frequency is now down to every few days at most. It seems to lose connection when docked for more than 24 hours. It’s well within range of the nearest AP when docked, and throughout my small house.

I use Comcast extenders and they link to the best WiFi I can possibly get so 2.4GHz is no option for me useless I disconnect my extenders which defeats the purpose of having them.

Totally disappointed in this product, I had hoped it would be an improvement over my 10yr old iRobot, it isn’t, it paired but did random amounts of cleaning despite full charge, got stuck several times and could not find it’s way back to the charger, despite the charger being in the center of a hallway. It does not pick up as much as the iRobot, but the last straw is that the wheels stained my white marble floor…Not for me…

i have the same network in my home and it would not hook up at first either. i finally found out that it wasn’t my network it was my phone. the phone has to be set to 2.4 only. you have to turn off the 5g or use an older phone with only 2.4g and it will set up right away.

I’m still trying to get mine to connect to the app with no luck using a 2.4 g network. I’ve tried everything including shutting off phone data and it’s always a no go. My Wifi connection shows as excellent and on my phone settings am able to connect to wifi and even the robot vacuum, but then it always times out and says connection failed. I’m holding out hope I can get it working, but it looks like I’ll have to return it as things sit…

1 Like

The only other thing I can recommend, if you haven’t already tried it is to disconnect the mesh and use the providers router. Or try using a different phone to install the robot. Remember, after it is at up you can use any phone to control it.

When scheduling the Wyze Robot sometimes it does not pick up the room I want to clean and just does the whole house. Also, sometimes when manually picking a room it sometimes just does the whole house.

1 Like

Hi @suzukipro and welcome to the Community forum. :slightly_smiling_face:
FYI: There is a new app for Android and iOS to address some vacuum problems.
Also, some have had trouble with the connection to the Vacuum.

When you get to the part where you connect your phone to WVCR_XXX (Vacuum’s WiFi) it will disconnect from your home WiFi and switch automatically.
You may see a waning that Internet is not available and if you want to keep the WVCR connection, you want to keep it.

Hope this helps clear the trouble. :pray:

Finicky pairing even when just a few feet away from the central node of a mesh wifi network. Then when the Electric Company cut power for a few hours, the vacuum couldn’t reconnect so had to reset everything and start over. So yes, connectivity is an issue.