Unable to perform network setup of Wyze Robot Vacuum

Android, Wyze app v2.16.55, first time setup.

Received my new vacuum on Friday and I can say without a doubt this is THE VERY LAST Wyze product I EVER buy. Thus far I’ve wasted easily 6 hours of my time trying to get this junk connected so it can actually be used.

Android with 2.16.55
THREE different iOS devices with 2.16.48

I reset the vacuum holding home for five seconds. I hold power and home and it resets WiFi settings. Connect my phone to my IOT WiFi ssid (which is a vlan that has unfettered access to the internet) and start the setup process in the app. Enter the ssid/password for the network, hit next, connect to the WiFi access point of the vacuum, return to app. Watching the app, after a few seconds it returns to the IOT SSID, then Three to five minutes of the connecting animation passes and it times out and says unable to connect. Two of the three iOS devices along with the android device have no data plans… so it’s WiFi or bust.

If I login to my wireless access point, I found the MAC and up addresses of the vacuum. It’s connected to the network. I CAN PING ITS IP ADDRESS… yet, still fails to actually WORK.

Yes. I understand my home network is way, way more advanced than 99% of the population… so I go buy a tplink wireless router and plug it directly into my cable modem and go through the whole thing again. Guess what doesn’t work, STILL??? Logon to the routers RUI, guess what has an up address that responds to pings? The vacuum. Yet here we are, money wasted for something that I can’t even use.

I’m literally about ten minutes away from calling my credit card company and disputing the charges for this heap of garbage. I simply cannot believe this is the level of a PRODUCTION PRODUCT that Wyze seems is worthy of public release. Like I said before… even if this thing starts working through some magic miracle, it’s the last thin dime Wyze gets from me.

1 Like
3 Likes

Thanks for this update. I’ve been pulling my hair out today trying to add this thing. Same issue everyone else is having. Even after turning of 5Ghz and ensuring even B is allowed, still can’t get this think to connect.

I’m with you man. The WCO is when it started going downhill for me. WCV3 seems okay, but I haven’t used it much. Installed a thermostat last night and it continuously told me the green wire was not connected. Pulled it out and resat it several times. Pulled out my meter and tested it for voltage and tested the thermostat and baseplate for continuity, still says green wire not connected. Fortunately the setup app gave me the option to skip forward anyway and I got it on. Several hours yesterday and today trying to get this freaking vacuum to work, calling tech support and telling them everything I’ve tried only for them to walk me through the same steps again then tell me to send them a screenshot of the CONNECTING screen that never connects by replying to their email that they never sent so they could forward it to someone else and have them look into it when it’s a known ubiquitous problem yet they act like they’ve never heard of it before my call and… I’m done. Cancelling the doorbells and the sprinkler controllers. Sending back the vac. Curious too why the unit says it’s a “Mop Vac” when the base unit speaks? Poor QC, poor management. C-ya.

I’ve been using Wyze products forever and LOVE them. All of the devices have setup quickly and worked extremely well!!!

Until…

This Robot Vacuum. This is crazy. I have 10 Wyze devices on this network working perfectly.

Press and hold HOME & POWER. Get prompt for WiFi reset. App goes through the motions. But…just sits on connecting FOREVER. I’ve been working on this off and on for about a week now.

I’ve removed ORBI. Changed Modems. Moved from Comcast to AT&T. Used Cellular hotspot. Nothing seems to make this vacuum happy. It vacuums great but have to push button each time since I can’t get it setup in the app.

It’s not your setup. App/setup is booked.

I work in technology, and if I can’t figure this thing out, I feel sorry for the poor souls that are accustom to things “just working”. I’ve tried everything mentioned in the posts above, with no luck. My email to support yielded a reply cut-and-pasted from their KB with no real answers. My wife is literally laughing right now that her techie husband can’t figure out a simple vacuum cleaner that’s supposed to save us time!

3 Likes

If you’ve read this far and are still attempting, I discovered that for my Mesh router, the only way to isolate was to set up a Guest account for 2.4, and force my phone to connect to that. Dlink doesn’t have any way to isolate sides in the main part of the router programming. While this did not get my vacuum set up because Wyze has another problem they haven’t yet resolved, I was able to connect other 2.4 devices successfully this way. The only drawback is that those devices won’t be able to access the router’s administration site. Which IOT devices shouldn’t be allowed to anyway.

Interesting. That may be a smart way to setup all IOT devices. Keep them on their own network.

absolutely. It’s far more secure. Many IoT devices that might not have security in mind and that won’t get security updates, ever, can be used to pivot on to someones network. I’ve heard of lightbulbs being compromised and used as a pivot point to a private network. It’s always best to keep IoT devices on a separate network.

I have yet to do it but I am going to use my guest network my google wifi provides as the IoT network, I think. Or else I should get a completely separate router that is only 2.4Ghz to make it easier since most IoT devices are 2.4Ghz anyway.

iOS attempting to configure on my iPad with new v2.17.21 and still having the exact same issue. Factory reset my vacuum. I noticed that the vacuum attaches to my network almost immediately during the setup. As soon as it connects, the vacuum’s access point drops and my iPad switches to my 2.4Ghz network. The vacuum is sending and receiving data but it just never completes the setup with my iPad. It looks like the problem is that Wyze’s web certificate expired 1/22 and they need to update it. That’s the error I get when attempting to browse to 44.238.135.25. Interesting since they told people to configure before 1/20 because their certificate was expiring.

1 Like

This might only work for iOS users. I was running into problems as well with getting the app to do anything after I connected to the robots WiFi network. I read in a Reddit thread that someone changed the wyze app to allow precise location and it worked. After allowing precise location the phone immediately found the robot vacuum. Hope this can help others!

1 Like

I received my vacuum on Jan 3rd. Was not able to fully run the connection setup. I have other IoT devices in my home and noticed a specific few were not and had not been connecting since Dec 30th. Don’t judge been busy and troubleshooting can take a while depending on the issue. Once I realized this I knew it was a network issue of some sort. After researching and troubleshooting on my own I came across a very simple solution. What I found to solve my issue was lowering the security on my firewall (in my router settings) for a moment so the devices (Nest, Wyze Cams, Ring Doorbell) could connect and then resetting it back to medium or high. I am now running a fully functioning vacuum that connects, maps, and schedules cleans from my mobile device. Hope this helps someone.

1 Like

Apparently, there is a “known” issue with the Vacuum. Not known or explained by most of the Wyze Support personnel but I finally received this from Support via Twitter. I have wasted hours troubleshooting this issue and have also reset everything multiple times only to find out there is nothing to do on the user side to get the Vacuum working. Must be exchanged.

3 Likes

I got the replacement vacuum and it is still having the same issue!
The firewall is not a problem in my case. I have created a different AP with extender behind the firewall and both robots connected successfully from the first try.
Wyze Vacuum does not work the way Wyze Cameras do. I got 6 Wyze cameras that are totally fine and with the 30 other IoT devices it is an obvious issue with the Wyze Vacuum.
Customer support is useless. From telling me contacting my ISP to the point explaining me that I need Internet for it to functioning. Will ship it back probably. There are a lot of alternatives.

1 Like

63 - random character wifi password here. Disabled 5ghz via Eero app.

Won’t connect.

Must use guest network.

WPA is a STANDARD for a reason…

I switched internet providers recently and had to re-add my Wyze Vacuum to the network using a new router. I had many of the struggles mentioned above, and after tinkering around with my router’s configuration settings, I ended up creating a guest 2.4 GHz wireless network with a simple password in order to get it to connect. I’m convinced the underlying issue I was experiencing was tied to either the length of the WPA2 password or using special characters (since my previous setup was a simple 10 number key).

I did not have the patience to keep testing to figure out the precise root cause, but wanted to post my experience out there to help anyone else who might encounter a similar obstacles and searches through this thread like I did.

I recently received my robot vacuum and upon setting it up, ran into all of the network connection problems mentioned earlier in this thread. I was getting ready to send the unit back for a refund when I ran across one of the posts that mentioned WPA encryption as a problem. I’m using a Netgear Orbi router system and it’s main subnet is set up to have both 2.4GHz and 5GHz subnets. I defined a 2.4GHz subnet for use by all of my home automation hardware and specified this subnet when I tried to set up the vacuum (without any success).

I decided to try setting up a separate 2.4GHz subnet just for the vacuum when I noticed my “guest” subnet that I had already defined. I decided to try using the guest subnet for the setup and “voila” it worked and the robot vacuum is happy now.

I’m not sure what caused it to work but I started looking at the differences between my “normal” subnet and my “guest” subnet, expecting to find something in the security options but I did not. Both subnets are set for “WPA2-PSK [AES]” encryption. Both subnets have relatively simple passwords without any special characters in them. The main subnet has a password which is a sequence of alphabetic and numeric characters and the “guest” subnet is 2 words separated by a space. I don’t think the password is the issue here.

My guess as to what the significant difference is between the subnets that work and the ones that do not is that the one that does not work is set up to automatically choose which of the defined subnets to use and it preferentially chooses the faster 5GHz subnets. The “guest” subnet that I have that works is only capable of 2.4GHz connections.

I hope this helps others that are having this problem.

Been have issues with the wifi for several months. Tried everything several times and have submitted numerous logs and filed troubleshooting cases but I never get any help. The vacuum is currently a piece of furniture completely useless. I would like help to get it going.