Pre 2021 Wyze Plug setup failing

Early Wyze Plug (pre 2021, Wi-Fi setup) will not complete setup. This appears to be a problem with the latest app update. Setup worked 3 weeks ago.


Those plugs are very particular when being set up. This is because of the method they use and the way modern phones manage their Internet connections.

The plugs create a very weak WiFi network of their own for the phone to use for the install. When the phone realizes that that WiFi does not have any Internet connectivity, it immediately reverts to the next network that does.

Turn off your Mobile Data when installing. This keeps the phone from flipping back to the Mobile Network before it can setup the plug.

If the phone tells you there is no Internet on the Plug’s WiFi… Do you still want to use it? Answer yes.

Thanks for the comment but this did not solve the problem.

Can you be a little more specific…how does it fail? When in the setup process? Any changes to your network?

1 Like


I have attempted plug setup multiple times. I have tried different plugs to rule out a defective unit. I have tried two wifi(2.4ghz) networks. I have tried setting up with an iPhone 14 pro (IOS 17.0.3, wyze app v2.46.0 (6)) with cellular disabled. I have tried setting up with an iPad Pro (IPadOS 16.7.1, wyze app v2.46.0 (6)) with no cellular. In all cases the wyze app goes to the “Connecting… This could take a minute” screen. The blue light immediately goes to a slow blink and stays there until it reports “connection failed”. I have four cameras that all connected without problem.

Thanks for your help with this.

I don’t use iOS, so I’m not sure how they “connect” over there… But, on Android, when the install process starts, a new WiFi Network appears as available (the plug’s ULP generated WiFi) and I have to click on that network to connect to it so that the setup is transmitted to the plug over that ULP WiFi. When my phone realizes that WiFi has no internet, it tells me it has no internet and asks me if I want to still use it. As soon as I click yes, the setup works.

It sounds like your phone is never connecting to the plug’s ULP generated WiFi and remains on your home WiFi throughout the process which will make it fail since the app can never communicate with the plug.

I select the ULP network. If the app isn’t using it and staying on the home network then that’s the problem and it’s in the app.

BTW. I’ve had these plugs for probably 4 years and I’ve set them up for different applications several times. Setup has always worked in the past so that’s why I suspect the last app update broke the process.

1 Like

That certainly indicates you’ve connected to the plug and that it initiated the setup. You say you’ve tried two 2.4gHz networks…are they also 5gHz and using the same SSID?

I need to see what version of the app I’m running. I’ll try to reconfigure one of my plugs tomorrow to see if I get the same error. Is the SSID you are using one that the plugs connected to before? Have you tried deleting the plug from the app and then re-adding it?

1 Like

One of the networks I tried had a shared SSID for the 2.4 & 5ghz frequencies. Two networks I tried used a unique SSID for the 2.4ghz frequency.

Your suggestion to delete the plugs from the app before trying to install was a good one. I hadn’t thought of doing that. Unfortunately, it didn’t help. Setup still fails.

Been lazy this morning…going to look for a test plug.


Can now confirm an app issue. Tried a re-install with iOS beta version. 2.4.60(6) and it failed. Rolled back to 2.45.0(6) and re-install completed without issue.


Thanks for your efforts. Is there a way I can roll back the install to an earlier version so I can complete my installations?

I’m part of the beta group so I have access to older versions. If you add yourself to that group, I think you should be able to install some previous version of the app.

Become a Beta Tester – Wyze Labs, Inc.

1 Like

I experienced this recently. Reset a plug (without removing from app) because I hoped to get back this:

Failed to complete reinstall as described upthread.

Just rolled back Android app from 2.46.0 (6) to 2.43.5 (313) and retried.

Success! :clap:

And Run Time History has revived. :slight_smile:

1 Like

Exact same issue…app update broke wyze plug (old version) install…continually failing to connect…so where is wyze on this…fix it!!!.
Im ensconsed in wyze hardware…and had updates brick a cam pan and a cam v2…and put up with it…im pissed now this is continuos…considering tossing the whole lot…
So now i have to go find an older version of app to install…to get this plug to install…terrible!!!
installed older version app…( And Confirmed…!..installed first time no problem!..
This needs to be fixed …cmon wyze…these forums are monitored…and this needs to be escalated to programers to fix this issue…i now have to have older version on different device incase i run into this again

How do you roll back the app?

On iOS you need to be a member of the beta group and install Test Flight. That gives you access to previous versions of the app.

ANDROID FIX… You can download the previous app version and don’t need to mess with the beta thing. I downloaded V2.45.0(342) from “”. The whole process was pretty painless. Now I have working bulbs again. The downloaded file is in the Android “APK” format and is easy to install. All Samsung phones have a built-in APK installer; make sure you have “Install unknown apps” checked.

1 Like

Same happened to me with 2 older plugs. Tried everything… Gave up and got 2 new ones with the BT setup. :slight_smile:

1 Like

Thank you for sharing this information. Downloading and installing the V2.45.0(342) version to my Pixel 4a resolved issues for me as well. The current version in Google Play would not provide an IP for the plug while trying to move it to a VLAN for devices.

1 Like