Bulb and pre-2021 plugs cannot be re-added

There seems to be a problem with the latest app. Seeing many posts about older bulbs and pre-2021 plugs not re-adding correctly. Confirmed this personally by trying to re-add a plug with current production iOS app which failed. Rolled to the previous beta and it worked without issue.


This issue is precisely what I’m facing. Two pre-2021 indoor plugs fail to re-connect after numerous attempts. The comments here indicate the current version of the app simply won’t accept the older plugs. Has anyone uncovered an alternative explanation?

Until they fix it, or, get sued and fix it, the only option is to install a much older app, then add your devices.
Then, re-install newer app again and hope the older devices don’t get reset.

They have got to fix the current apps.
Notice the lack of official response here and on the other posts.

I like the one where advice is given on preparing for a lawsuit.
Class action anyone?

This is an issue we are aware of. We have found the root cause and are putting in the fix. It may be in the current 2.47 RC, if it has not made that version it should be in the public release.


Not in the current beta, Android: 2.47.0.b372…
But thanks for being here for us!

1 Like

Thanks, I appreciate your input.

Not in the current TestFlight build 2.47.0 either. Any idea when the next public release will be? Of course the one time in 3 years I need to set my two older ones back up, the app is broken… :slight_smile:

Go backward … 2.45.0(6).

1 Like

Thank you for confirming, I will see what the hold up was.

I don’t believe that’s possible on iOS, even with TestFlight.

Yes, it is. Check here:


So it is! It can only be done once the beta is installed, before that (just after accepting the invite) the previous builds section isn’t shown.



Yes, this was super helpful, I’ve reverted back to an old ios version and now my bulbs and outlets are discoverable and back online.

Thank you thank you!

1 Like

Wish android was as easy…

I don’t have android, but I suspect that the beta works in a similar fashion. There have been other posts (@SlabSlayer I think) about getting an older APK for the app.

1 Like

There is no fallback mechanism in the Android beta app. Android users have to delete app and sideload from an apk mirror site like APKMirror.

1 Like

Yea, not good.
Us android folks should be able to do the same thing without going through such hoops.

I too would like such a feature. Only place I have found to send feedback to Google regarding is below. Then send feedback on the bottom right.

You can download the previous app version and don’t need to mess with the beta thing. I downloaded V2.45.0(342) from “Older versions of Wyze (Android) | Uptodown”. The whole process was pretty painless. Now I have working bulbs again. The downloaded file is in the Android “APK” format and is easy to install. All Samsung phones have a built-in APK installer; make sure you have “Install unknown apps” checked.

1 Like

I had issues with adding my original wyze bulbs. They wouldn’t connect to wifi ever during setup and if they did, they would disconnect just as quick. So I never could get them to be recognized. I tried to re-add them because they wouldn’t stay online ever. So I’d try and set them up again only to get stuck at the wifi screen each time.

Replaced them with new bulbs. Well now these things won’t stay online more than 20 minutes. Literally any time I try to use them in the app, there is no response. Funny, that’s ANOTHER issue I had with my original bulbs so I thought maybe the bulbs were messed up. I threw them all away and replaced with new wyze bulbs.

NO change. The new bulbs still won’t stay online more than 20 minutes. To control them, I have to re-add them to the device list. They work for 30 mins and then they go offline again until I set them up again.

This is RIDICULOUS. My bulbs worked great until whatever point that this all started. Now they’re no more useful than dumb bulbs.