Wyze Plug Pre-2021 Cannot Re-connect

I’ve got a Pre-2021 plug that I had to reset, delete from my account and now trying to re-add. Following the factory reset I am running the add device process on my iPad. I get to the point in the process where I have selected the wifi ssid and password and connect to the plug’s setup wifi and then the process just dies.

I have a bunch of these and this is the first time I’ve had a problem. Already tried disabling cellular data and location services are enabled. Tried a different AP and subnet. Also tried a previous app version on my iPhone to no avail. And no, I don’t have an android device to use for testing.

App version: beta 2.30.0 (a7)
Plug firmware:

Any ideas?

Finally got the plug reconnected. Steps to fix: clear cache in app, logout, reboot iPad, leave the plug without power for several hours, re-run installation. It’s now back online and accessible via the app.

1 Like

What would android have to do with this?

Nothing…just didn’t want a bunch of responses “Did you try it on android?”

Yes I have many