Light bulbs wont connect to new wifi

i have recently moved and got a new router/wifi. i brought my light bulbs from the old house and i was trying to connect them to the new internet but when i try to enter the wifi name it doesnt automatically pop up just the old ones and i cant even delete them to see if thats the problem. it tells me i can manually enter my wifi name and password so i do that and it takes me to the page that says to select the internet with the light bulb name in it and when i do that and go back to the wyze app nothing happens it just stays on that page and doesnt progress any further.

Make sure the new WiFi is 2.4 GHz and NOT WPA-3 encryption.

1 Like

And turn off IPv6. You also need to make sure location services permissions are allowed for the Wyze app in iOS settings and location is turned on for your phone.

In case you’re not aware, you need to do a bulb reset when changing WiFi credentials:

If you haven’t already reset the bulbs (and other Wyze devices), you can change your router’s SSID (WiFi name) and password to the same as your old router and your Wyze devices should automatically connect to your new network.

1 Like

AND Best thing that you can do… change the name & password on the new router to match what your old one was. Everything will reconnect.

1 Like

My 2019 Wyze bulb suddenly quit working today, and I have no idea why. I deleted and attemted to re-add it. It actually goes all the way thru the process, and when the “CONNECTING” screen comes up, it just sits there even though the bulb is on solid now. I understand that my phone must be set to to 2.4G with WPA/WPA2 security, and therein lies the problem. No problem with setting those 2 settings in my T-Mobile Gateway router; I just added a 2.4G-WPA/2 network with a different SSID to the T-Mob router. The problem, I think, is with my Samsung S22 phone which is running the Wyze app. The phone will not allow connecting to a 2.4G (or any network) with the older WPA/WPA2 security… it demands WPA2/3 security or it won’t connect. I didn’t have this issue with previous Samsung phones. Do I need to buy the newer bulb? Will it run with 5G and WPA2/3? Bulbs are cheaper than new phones! Is there a hack somewhere that can resolve this?

FYI: I tried using my LENOVO tablet with the Wyze app also to no avail. The tablet let me add a 2.4G WPA/2 network, but the same thing happened when trying to connect to the Wyze bulb. It tried connecting for a couple minutes and then failed with the “Connection Failed” message. So what’s next?

Older Wyze white bulbs, the 2019 version, will not connect to any networks.
I believe it may be changes to the app.
I am using the same network, same APs, same password, and WPA2, not 3.
There is no IPv6.

I helped a friend change their password on their network, then went around and re-added all their devices, Wyze and non-Wyze. Everything connected fine except their 2019 bulbs. I replaced their bulbs with the newer bulbs that I believe are Bluetooth, and they connect fine.

I brought their bulbs back to my house that has not had the password changed, nor any network settings, and NONE of them (8) will finish the connect process.

I really believe this is an app issue. It does not work on my Androids using latest beta, and it does not work on Apples with latest Non-Beta app. I know it is the app, because I still have 2019 bulbs in my house all over the place that are still working because I have not had to re-set them. So the bulbs have no problem communicating with the network in it’s current state.
If someone does the magic on-and-off 3 times, I will be screwed.

Please test at the Wyze labs and verify if the latest apps can add 2019 bulbs, and please fix it when you see that you can’t.

Don’t break the app, and then try to get us to buy newer bulbs. This is not good for customer service, and surely not for me letting people know if they should buy your products. My friends received their Wyze products for free from me, and they are currently not a Wyze fan because of this issue.

1 Like

I have the exact same issue. I now have an open ticket with Wyze support, but they seem to be sticking their head in the sand on this one and insisting that there is no problem. My rep will not acknowledge that others may have the same issue even though I suggested he look at this forum. This is the 2nd time this has happened with Wyze. My outdoor cams’ base station has never connected wirelsessly to the network, and they just told me “too bad, use a cable.”. Finally after enough complaining, they gave me a $5 gift certificate to buy another one. I am on the verge of packing up all my Wyze “stuff” and leaving it out on the curb for the trash collector.

If you can, go back to an older version of the app. Android users should be able to find an APK. iOS users need to join the beta program and then you will have access to older versions. There seems to be a problem with the current app version preventing many older devices from connecting to wifi.

1 Like

Exact. Same. Problem.
Reset one of my access points recently and the bulb previously connected to it went offline. Could not get it to reconnect after trying all methods. Pulled an old bulb out of the box and had the same problem. Replaced it with a color bulb and everything works fine. Seeing how I have two other of the older bulbs in service I took advantage of the recent sale and ordered a 4-pack of the newer Wyze white bulbs. The other ones will have to go in the trash. :disappointed:

1 Like

I am having the same issue with 2019 bulbs. One bulb went offline, Two are still working. Tried using the same iphone and ipad to connect the one bulb and keep getting a message that the bulbs has no internet connection. Had an extra 2019 spare bulb (never used) and that one also will not connect Forgot all my home networks and used the one that says it is 2.4 GHZ. Turned off all VPNs. NO matter what I do on the iPhone and iPad, I cannot connect the bulbs. Does not make me want to buy newer bulbs if in a few years Wyze makes them obsolete even though they still work. Now worried about all my cams, door and motion sensors. Will the same thing happen to them?

Exact same problem. 6 bulbs and 3 plugs fail to connect.
Several other devices connected fine. I’ve been a wyze user since they came out but I’m ready to jump ship to something else.

Support says they are working on it, but the coding is crappy.

I have the same issue. I have spent about 5 hours trying to connect. Making my SSID different for 2.4 and 5. Moving out of bounds to try to only get 2.4. Etc. Etc.

I have about 14 devices, 5 of them our down mysteriously and can’t get them to reconnect!

So frustrating.

Have been trying all day to get my bulbs and plugs to work with my new router. I have over 20 devices connecting to my router and half are not Wyze. Was able to get them all connected in about 30 minutes. The half that are Wyze will not connect except for my camera and thermostat. Spent over an hour with support trying to get my 2019 bulbs and plugs connected, with a no-go. I finally gave up. I understand they need to connect at 2.4G and my new router is doing that with all my other devices that need that, so don’t get it. Support had me switch my phone with the app to 2.4G which I figured out how to do by turning off 5G on the router. It still did not help at all. I initially thought it would be quite easy to just go into the app and change the network for each device, but there was no way to do that, so I ended up trying to add them in again, but that failed just like everyone else on here. I’m leaning towards that the app is at fault and needs to be fixed also. If anyone comes up with a way to get these working please share on here.

the only solution that worked was buying a bunch of new bulbs.

The sad thing is, they spent all that time trying to help you, knowing that it would never work unless they told you to go to an older version of the app.

They know that is the problem, and just sat with you wasting their and your time.

If they didn’t know, that is inexcusable too, because it is a known issue in their camp…

I use iOS app.

How do I go to an older version of the app?

BTW: they know it’s a bug. See

It’s a known bug. See

Advice from AI concerning a lawsuit against Wyze…

I’m not a lawyer, but I can provide some general information on this topic. If a company releases an app update that causes your device to no longer function properly, you may have legal options available, such as filing a lawsuit. Here are a few steps you could consider:

  1. Gather evidence: Collect any evidence that demonstrates the connection between the app update and the malfunction of your device. This may include screenshots, error messages, or any communication with the company regarding the issue.

  2. Review terms and conditions: Check the terms and conditions of the app or any agreements you have with the company. Look for any clauses related to warranties, liabilities, or damages that may be applicable in this situation.

  3. Contact the company: Reach out to the company’s customer support or legal department to explain the situation and express your concerns. Provide them with the evidence you have gathered and request a resolution.

  4. Consult a lawyer: If the company refuses to take responsibility or does not provide a satisfactory resolution, you might consider consulting with a lawyer who specializes in consumer rights or technology law. They can evaluate your case and advise you on the best course of action.

  5. File a lawsuit: If your lawyer determines that you have a valid legal claim, they can guide you through the process of filing a lawsuit against the company.

Remember, it is crucial to consult with a legal professional who can provide advice tailored to your specific circumstances. Laws vary by jurisdiction, and the specific details of your case will determine the best course of action.

THANK YOU!! Your advice (suggesting to go back to the older version of the Wyze app ) totally fixed my problem with connecting the older 2019 Wyze bulbs!! Thank you so much! I CANT BELIEVE Wyze customer service reps couldn’t come up with this solution….