Wyze Plug Not connecting to network + iOS

I purchased a couple Wyze Plugs on Amazon’s Prime Days and can’t get them to connect to my Wifi.
I have the plugs within 2 feet of the router and phone, I used “RouteThisHelps” and it confirms that the appropriate ports are open. I have tried all the bands available on my router, I’ve rebooted the router multiple times and it still times out.

Any suggestions would be welcomed!


Wyze cams only work on 2.4ghz. Make sure your router seperate both bands on diffrent ssids.

No ports need to be open.

What step of setup are you getting stuck on?

Running setup process again, don’t recall exact language.
Got to “Connecting… Keep your phone near the plug” and it failed - I’ll create a new 2.4 ghz network and see if I can get it to work on that.

Net new 2.4ghz wifi network was created, same error as above.

Make sure your choosing the correct model. The new plugs are called the CFH. If you bought your plug a while ago click the text on the setup prompt.

I don’t really have an option to choose what plug I’m using.
from the main window (where I can see my currently functioning Wyze Cams), I click on the “+” button in the top left, then click “Add Device”, then select “power & lighting”, then “Wyze Plug”. Once that page loads I select wifi network, enter PW, and click next. The only option where I can select a model is where the app has a link if you purchased the plug prior to 2021

Turn on Bluetooth on your phone. The new plugs use it for setup.

1 Like

I’ve got BlueTooth running, do I need to pair before the wifi sync portion of the process?

Shouldn’t need to pair. Try disabling and re-enabling then try to add the plug. There isn’t any wifi sync portion other than having the plug join your existing wifi network.

1 Like

I restarted BT, and tried it, but no luck. Turned off BT, restarted the phone, started BT, tried again - the same result. it fails at the same spot. I just double-checked, I have the latest version of the app for iOS.

Did you also see my post above to not select the Pre-2021 option? Also, do you have more than one plug to test?

I did see that note, these were purchased a few weeks ago, so I didn’t touch that link. I have two plugs and have tried the processes on both each time I test - just incase I have a bad one.

Can you upload a screenshot from the phone when the setup fails? Also another stupid question, the light on the plug is flashing? Have you tried a factory reset on the plug?

I’ve been using PC to chat here… I’ll switch to my phone so I can screenshot and share that here.
Yes, the light is flashing on the plug. Just tried a factory reset on the plug(s), same result.

And I have quadruple-checked my passwords.

Not sure if part number helps at all but both are “WLPP1CFH-1”

Do you have a router that combines the 2.4ghz and 5ghz wifi SSIDs? Can you turn off the 5ghz? The problem is with your network connection, not the plug.


I do have a router that does both… I’ll try killing the 5mhz and testing.

1 Like

Yea like I said first, makes sure the 5ghz is permanently disabled or it’s on a seperate ssid (name)

1 Like

Yup. Wasn’t clear what the error was.


My 5Mhz Is a separate SSID and password, do I need to change anything?