Wyze Plug Not connecting to network + iOS

The new plugs will have a black key printed on the back to identify them.

Make sure your phone is logged into the 2.4GHz network and your Bluetooth and GPS are on (like the T-stat, it uses the GPS to pinpoint your network). Then use the 2.4GHz SSID and PW when adding the plug.


Confirmed, I have the Black Key on the back of both plugs.

I think I’ve tried to configure using what you have laid out there but I’ll try again (or almost anything at this point) to make sure.

I am sure rooting for you. :mega:. But I am an Androidian. I enable my connectivity system wide, not app specific. No idea how that works on iOS.

I just installed 4 of the new ones bought on 7\3. Smooth as a Gravy Sandwich. All were online in a couple seconds using the app. Single SSID dual band network, phone logged onto 5GHz. My router will cross bands so it doesn’t care if my phone is on one and the Wyze widgets are on the other since it is single SSID preferred band switching.

Good luck! :crossed_fingers:

1 Like

Another brainstorming question… Your SSID isn’t over 31 characters is it?

Nope, the SSIDs are all well below 31 characters.

SA’WING and a Miss!

The count is 0-2.

Appreciate the help - I really do. I’m usually technical but this one is stumping me good. I’m O’fer 20-30 at this point.

I understand. Very frustrating. For some reason it seems that your router doesn’t like to play nice with the plugs. I have heard rumors about some routers not liking Wyze. Do you have other Wyze gear on the router?

I wouldn’t be able to let it go till I hammered out the cause, perhaps literally.

Do you happen to have another old router on the shelf (I have like 4 old crap routers laying around) or a friend’s \ family member’s network you can hijack for an install test to see if they will load to a different network? Would certainly narrow it down to your network. If it fails then, it might be your phone. See if it installs on a different phone ???

Just spit balling.

1 Like

Any possibility of a space at the end of the ssid or password? Sometimes my Apple devices will add one.

Two additional questions:
Are you using MAC filtering?
Are you out of addresses on your dhcp server?

Three questions:
Have you tried turning off your cell service temporarily?


I do have a few Wyze cameras on the network, but those are super old, maybe 3-5 years? I’ll try an old router I have and see if that solves it… I’ve stuck with NetGear routers for the last few revisions… hoping it’s not a netgear thing.

1 Like

I use MacFIltering on my 5Ghz network but not the 2.4Ghz SSID. I shouldn’t be out of addresses unless it’s holding on to old ones for some reason - another thing to check out. I’ll try the no-cell thing tomorrow too.

Thank you so much to everyone for trying to help me - it means the world to me that strangers are willing to help like this. Kinda restores my faith in humanity a bit.

1 Like

Mac Filtering (or “Access Control” on some routers) isn’t usually restricted to one network band. It is per network, and the two bands (2.4 and 5 GHz) and part of the same network if they are transmitted by the same router (the Ethernet ports on the router are a 3rd route into that network).

So if you are using one router, try either turning Mac Filtering off, or add the hardware addresses of the Plugs to the approved list. :slight_smile:

1 Like

Just for informational purposes…dd-wrt allows MAC filters per SSID. I have a router with four SSIDs spread across both bands and they each support MAC filters for that specific SSID.


MAC filtering is turned off, Cellular data is off on the phone and still no luck… my wife has an android tablet, I’m going to try that and see if I have a better experience…


Well then, I tried my wife’s android device which was a [problem] unto itself… but I finally had a friend come over with an older iPhone (it was an iPhone 10 with super old iOS) and was able to add the two plugs in about 3 minutes.

Not sure what the issue was but I have an iPhone 12 with the latest iOS.

[MOD NOTE: post edited to remove language that violates the Community Guidelines]