Help needed setting up wyzeplugs

I am trying to setup a pair of wyzeplugs with no success. I have followed the basic troubleshooting instructions in the app and on the website with no help. The setup just keeps timing out with either/both of the plugs that came in the package. I did get 2 packs, 4 plugs, but am not wanting to open the second pack since it will be easier to return if the seal stays intact.

Any assistance would be greatly appreciated.

My wifi is an Apple Airport Express and I am using the 2.4g port for setup of the plugs. This is not my first setup of “smart” devices I have several up and running with little issue.

Thanks in advance

I’m not familiar with the Apple Airport but just in general:

  1. Be sure you are on a 2.4 wifi. If you have a dual 5g/2.4g and can split the SSID and use only the 2.4 this works better with some routers. I have an ATT combo router running parallel with an Eero router and I found I had to split the ATT to get it to work but not the Eero.
  2. Sometimes rebooting the router when setting up any device helps - like the old’ if all else fails, pull the plug and start over’ trick.
    Let us know if this helps.
1 Like

Thanks for the reply/suggestion. But am still stuck.

While looking to reboot my Airport Extreme (i was incorrect saying express) I did see that it had an update waiting so I updated the firmware and rebooted. It does have a SSID split for 5g/2.4g and I have told my phone for forget the 5g because at first it was going to it automatically during setup. So I am using the 2.4g network.

After this it still times out during setup of the plugs. I’ll give some time to see of anyone has experienced this before sending on to support.

You should visit this thread (many suggestions):

Thank you, I will. I did try a search with no results before starting a new thread.

WildBill, the link doesn’t work for me, says it’s private.

Sorry, was for early access. Here is a summary:

As a WiFi device the Wyze Plug will have a lot of the same general caveats as the Bulb. That said, if you are having setup troubles, make sure none of these things are interfering:

To start, if you are on iOS 13, confirm that you are using the most recent version. Also, iOS 13 users should update to version 2.5.53 or above of the Wyze app using the Apple App Store. iOS 13 won’t allow the app to see your local networks if location services for the app are turned off. You can turn the location permission off again once the last device is set up (Settings > Wyze app).


  • Plugs must have access to a 2.4 GHz network.


  • Turn off mobile data (some phones don’t like connecting to a WiFi network that doesn’t have an Internet connection, which is what the plug looks like to them).
  • On Android, after connecting to the Wyze Plug, wait 5-10 seconds to see if it warns you that the network has no internet access , asking if you want to stay connected anyway. Tap Yes you want to remain connected, then proceed with the rest of the Wyze Plug setup.


  • Turn any MAC filtering off during setup (you should know if you engaged this unusual item on your router.)
  • Sufficient range of DHCP network addresses must be available (some people restrict this).
  • Depending on your Plug’s firmware version, if your network name (SSID) is 25 characters or over , you may have trouble setting up the Plug. The workaround is to set up the Plug on another network (like your Guest network), update the firmware, then set it up on your intended network. If using another network isn’t an option, then reducing your network name (SSID) long enough to set up and update the Plug will be necessary.
  • If you have a PLUME WiFi mesh network and your Plug times out repeatedly (you may also get a 404 error), then temporarily disable “Online Protection” and/or the “Advanced IoT Protection”, as they appear to block access to either Wyze or the Plug. After the plug is activated you can re-enable protections.
  • If you are having trouble connecting to the plugs, check to be sure WMM (Wi-Fi Multimedia) is turned off in your router options.
  • If you have band steering on your router, know that some implementations won’t allow the Plugs to connect to the 2.4 GHz network if the 5 GHz network is available. The solution is to turn off the broadcast of your 5 GHz network long enough to set up the Plugs.


  • When the app asks you to input your network name and password, click the closed eye at the end of the password line to see the password you enter. Remember the password is case-sensitive.
  • Set up the plugs close to the router . Once all settings are in and the plugs are working, they can be moved to the desired location and all the settings will remain.
1 Like

I had zero issues with my plugs but I did have issues with One camera. All I did was take it to a different room do the exact same steps and it paired. Then I brought it back to the original room I wanted it in plugged it in and all was good so maybe give that a try? :man_shrugging:

I have tried in 3 rooms now.

Other things I have tried most recent:
Loading with a 2nd Iphone
Manually setting the IP address in the plugs WiFi

It seems that the plug(s) are losing their wifi connection with the phones when they are connected direct, without going through the Airport. Hopefully I can get through this as a Wyze camera is being delivered tomorrow.

****It did seem to connect one time to where I was able to give the plug a name, but lost connection when moving it to a different outlet.

Is your phone dropping the plug and reconnecting to mobile data then or your wifi? Is the mobile data disabled on the phone during install?

Mobile data is turned off and I have also turned off the “auto join” for all wifi networks.

Turn on then off airplane mode. Not sure why but works.

I did get them working. Actually my pan cam arrived Monday and it wouldn’t setup either so I got on chat with WYZE support and Alyssa hooked me up. She had me forget the wifi network for the devices and router, reset the devices by holding the buttons in for 20 seconds. and then all three devices were setup in a matter of minutes.

I have 2 more plugs to do yet, if I have this issue with them I will try the airplane mode off/on first.


I have an ATT U-verse router and I have not been able to split the two bands. The installer told me I’d never need to but it appears I do need to. My searches are not providing info to do it and the link on ATT goes to an error. Can you provide some info on how to do it?