Cams work great...can't get plugs to pair

Have two cams at two different locations that set-up without issue on Netgear dual band routers set to 2.4GHz. Cams set-up fine, but the plugs are a no-go.
Any help appreciated.

Welcome to the community, @cwbigdog. Please see this topic for tips on how to set up your plugs.

I just bought 6 plugs through home depot. After 2 hours of frustration, I was able to get one plug to connect. Running through the connect and timing out after such a long time is not user friendly. I have followed all directions (obvious I think, since I was able to get one plug to connect). So, I do not know what issues exist, but spending $60 for plugs that don’t work when I can spend $7 for a timer to turn on and turn off my light seems a no brainer. I was going to buy bulbs, but I think I make a good decision not to buy them. More info:
My router is a TP-Link and works with everything else, including 4 cameras, motion detectors and door sensors. My app is on an android 7.0.

Any help would be appreciated. Played around with this some more and discovered that for another plug to connect, it seems I have do this one at a time, taking out the previous plug. If this is correct, it should be noted in the directions. Thanks.

Hi, @trackmanpete. Welcome to the community! Sorry to hear about the negative experience you are having with the Wyze plugs. Here are few things you have to consider when setting up the plugs.

Also, If you would like to contact the Official Wyze Support Team about this issue, you can create a support ticket Here.


  • Plugs must have access to a 2.4 GHz network.


  • Turn off mobile data (some phones don’t like connecting to a WiFi network that doesn’t have an Internet connection, which is what the plug looks like to them).
  • On Android, after connecting to the Wyze Plug, wait 5-10 seconds to see if it warns you that the network has no internet access , asking if you want to stay connected anyway. Tap Yes you want to remain connected, then proceed with the rest of the Wyze Plug setup.


  • Turn any MAC filtering off during setup (you should know if you engaged this unusual item on your router.)
  • Sufficient range of DHCP network addresses must be available (some people restrict this).
  • Depending on your Plug’s firmware version, if your network name (SSID) is 25 characters or over , you may have trouble setting up the Plug. The workaround is to set up the Plug on another network (like your Guest network), update the firmware, then set it up on your intended network. If using another network isn’t an option, then reducing your network name (SSID) long enough to set up and update the Plug will be necessary.
  • If you have a PLUME WiFi mesh network and your Plug times out repeatedly (you may also get a 404 error), then temporarily disable “Online Protection” and/or the “Advanced IoT Protection”, as they appear to block access to either Wyze or the Plug. After the plug is activated you can re-enable protections.
  • If you are having trouble connecting to the plugs, check to be sure WMM (Wi-Fi Multimedia) is turned off in your router options.
  • If you have band steering on your router, know that some implementations won’t allow the Plugs to connect to the 2.4 GHz network if the 5 GHz network is available. The solution is to turn off the broadcast of your 5 GHz network long enough to set up the Plugs.


  • When the app asks you to input your network name and password, click the closed eye at the end of the password line to see the password you enter. Remember the password is case-sensitive.
  • Set up the plugs close to the router . Once all settings are in and the plugs are working, they can be moved to the desired location and all the settings will remain.
1 Like

Sorry, but all that you sent along, I already read and followed to a T. After 3 hours I now have two plugs connected and 4 plugs refusing to be recognized…It should not be this hard to connect these things. My next took less than a minute to connect and work for me on both my android phone and on my Mac. Hmm…

Wow, I know this has to be very frustrating for you, and I agree it shouldn’t be that difficult to setup. :smirk:

If you would like to report this to the Official Wyze Support Team and create support ticket, I recommend it. Submit a New Request

It is possible that these plugs are defective, if they are, they will replace them for you.

1 Like

Thank you. After many hours, I was able to figure things out and got all 6 of them “on line”. I let support know the process I went through in hopes that they might make it clearer to others as to what might happen with Android OS. There was a missed step or misdirection as there was no notification if there was a “binding” of the plug to the software, as the message continued to say that the connection timed out and no connection. Out of the 6 units only the last one sent a confirmation of a “bind”. Thanks for your effort to help out. I hope I didn’t come across too rudely. No excuse for that, my apologies never the less.

1 Like

You are welcome! Glad you got all the plugs working. I didn’t take it as rude so not a problem. :slightly_smiling_face:

Wondering what you did to connect the plugs. I just bought 2. And while I have several Wyze products, which work great, I cannot get the plugs to pair up. And I’ve followed all the recommended steps.

Could you please tell us all at what point in the pairing process it is failing, and any error messages you are seeing?

I’m not seeing any “error” messages per se. I connect to my home network (2.4) , then connect to the smart plug. Then I get to the screen where it’s trying to connect to the device, with a 149 second countdown. I’ve checked, and my device is staying connected the plug throughout the setup process. But ultimately, the time elapses, and I get the connection timeout message, with an option to retry. I’ve tried this several times.

Some people have had success with temporarily turning off mobile data on their phone. Have you tried that yet? I also had to do this when my phone was upgraded to Oreo, and not just with Wyze devices.

Yes. I’ve tried turning off mobile data. I’ve even tried on a separate phone that doesn’t have a sim card, and is only connected via internet.

Hmmmm, there’s only a couple other things I can think of. Is there a chance you need to extend your DHCP address range, or you have reached the device limit for that band on your router? Some routers only allow up to 32 devices per band. I had an older router that got fussy after 28 devices connected.

1 Like

I’m gonna try a couple other things. Then they are going back in the box for return. I’ve got 3 cameras, a motion sensor, and a door contact sensor, all from Wyze. No setup problems with any of them. Too bad, I really like the brand

First I only did one plug at a time, disconnected the plugs after installation took place. I also was confused by the time out issue. What I did is go back to the plug before the time out and clicked on it and all was installed. That is my recollection. I have had no problems since my initial attempts of installing. All works as it should and I am 1,000 miles away turning on and turning off lights. This has worked well now for 3 weeks.

I also had non connection issues with the Plugs. I tried everything that support suggested including
shutting down 5ghz on my router, disabling mobile data on my Galaxy s7 edge phone, locating everything next to my router and rebooting everything multiple times without success. In chat they suggested sending them a device log - I have not heard back from them yet. Nothing would work until I picked up an old Fire HD tablet which also had the app installed and suddenly I could connect. Apparently some phones will never connect to set up the plugs, though once set up I am able to control the plugs from my phone. I had Alexa install the Wyze skill and now control the plugs by voice. If the support chat lady would have asked if I had a different device to try, I would have saved hours of frustration.

1 Like

I also am having some trouble. Step 4 setup screen keeps displaying " 5GHz not supported" but I am not on the one and have forgotten it so I am 100% not connected to it. My pan and Cam had no problem with us having a 2.4 and a 5G option but it looks like the plug may be grouping them together since they have the same name but one having 5G on the end and both having same password may be throwing it off? But again I’m not connected to the 5G so it shouldn’t be trying to either? I’ve turned off cellular data as well.

It seems to me that smart devices are going to have to catch up to mesh router’s. And legacy devices are going to have to somehow figure out how to connect to mesh routers. I spent several hours with net gear and then also even more hours on my own to get my garage door to connect to my new mesh router. Linear the maker of the garage door said that it was impossible so I had to send them a video showing them that it was working and I also sent them each step that I took and every adjustment that I made so that they would have it for themselves to implement in the future. They said that they would not implement it because it was illegal to have an entry device work on a mesh router. Explain to them that door locks worked on mesh routers so what was the difference between that and a garage door and they didn’t want to discuss that. So right now I am the only one that I am aware of that has a linear garage door that works on a mesh router. I also was able to get it to work on their commercial app which again they said was impossible because you could not sign into both apps so I sent them a video of me signing into both apps and working the garage door but this time I did not send them the steps on how I made it work

1 Like

Just bought 2 Plugs. Had the same issue with Step 4. Called tech support, spent 1 hour repeating what I have done, almost gave up, but the last SMALL thing helped: Reboot iPhone! somehow the Wyze APP took my previous 5ghz WiFi as default, only after rebooting the iPhone, did the Wyze APP show step 2: showing the existing 5ghz WiFi setup with an option to change back to 2.4ghz. After passing this step, everything else is just easy.
Lesson learnt: just reboot the iPhone, possibly the wireless router as well when you encounter these weird issues.