Wyze Outdoor Plug will not connect to WiFi

Just wondering if anyone else has had luck in getting it to work?

Got my Outdoor plug today and having no luck getting it to connect to WiFi, Have tried several times but never get past the step where the Wyze app “seems” to see it (in BT Pairing mode), but never completes. I tried the 5-second reset to get it back in pairing mode, and just for the heck of it to see if it would show up in other devices area of BT, but nothing,


1 Like

My two (received yesterday) worked perfectly.

1 Like

I received one new outdoor plug yesterday. It will not complete setup and connect to WiFi. I have tried rebooting: Wyze plug, my android phone, my router and cable modem. I have tried both bands 2&5 on my wifi access point. The setup calls for a solid blue status light which never happens, only blinking. This is the first Wyze product I have ever had an issue with. I have transmitted two logs to Wyze. I hope to hear something Monday.

1 Like

Hi @KeithA and welcome to the community. Any logs transmitted to Wyze need to be referenced from a Support Ticket. You may open one through this link: (https://wyzelabs.zendesk.com/hc/en-us/requests/new)

Just continue with NO answers until you finish the suggestions.
Eventually get to “Contact Support” & “EMAIL” prompt where you’ll be able to enter your trouble statement, contact info. and the log file numbers.

1 Like

Hi @talkingcat and welcome to the community. :slightly_smiling_face:
I can’t speak to the outdoor plug but in general terms.
All the Wyze products only work on 2.4Ghz WiFi (not the 5Ghz).
Shutdown your phone’s mobile data connection during setup.
Click Here for other tips. Hope this helps.

1 Like

not working for me too everything else by wyze works fine but the outdoor plug wont connect at all please help

1 Like

I’ve submitted a support ticket and waiting for a response. As suggested above, I did try killing my phone’s Cell service, but that did not help either.

Just a dumb question, but are you guys setting up the plug outside? Do you have wifi where you are setting up the plug, or are you setting it up indoors close to the router? Probably an obvious question, but I didn’t see any mention above if there was wifi within range.

Most of my Wyze products seem to take a couple tries before it connects, but usually I get it to work. I’m still waiting for my outdoor plugs, but I have an extended wifi access point that I have successfully tested in open country up to a mile away. In town, and with the AP pointing out of the basement window, I can still get wifi down the block, so range isn’t a problem for me, but the main router barely reaches outside the walls of the house.

i am not happy with this product at all


No, in my office within about three feet from the router. I’ve got a couple of hours into this, trying different things to make this thing work.

1 Like

i tried everything i can think of to make it work but i think the company is making junk now will see when i get the watch in the mail if its junk like this i am done with wyze

Does it pair if you have it Close to you tablet or whatever? Do you have Plaster walls? They are a faraday cage"

No my house is all wood so far and no it wouldn’t pair when the phone was right next to the plug

Make sure your phone/tab supports Bluetooth v4.2 minimum, the Wyze app has location permission and location is precise.

1 Like

@dr.know has some great tips.
I will piggyback on his suggestion to shut off mobile data on your phone. Also turn bluetooth off and back on. I had to hold the buttons to do a reset multiple times with the outdoor plug.
Also if you are still having trouble you could try a different bluetooth device for the initial setup as it could be something specific to the phone/tablet bluetooth signal.
I have a Moto Z3 and love the phone but often have trouble with bluetooth connection setup 1st time and even for my Flic Button Hub I had to set it up with my Samsung tablet as it will never complete bluetooth connection on Moto device.

I just got my Wyze Outdoor Plug today. I had to try a many times to get it to pair. I was on the phone with tech support. I’m not sure why it worked after about an hour of trying. But, I do know that it only works with the 2.4Ghz band. Also, there was a firmware update that it performed immediately after establishing a connection.

For mine, I had it about 3 ft away from the router in the same room. This was after I had tried in a different part of the house with good 2.4 coverage, and it did not work there either.

I had seen that suggestion, and tried without luck,

Same situation here. 2 plugs received. Neither can connect. Both timeout. Asks for a system log by pressing both power buttons then get the message no log received. Not real happy with these plugs. All other Wyze devices working fine. Very disappointing

1 Like

My plugs were delivered 5 minutes ago. Already have one of them set up and working in the app. The first instruction in the app was to look for a solid blue light. Mine was blinking. It made more sense to me to have a blinking light for set up mode, so I ignored the instruction. I didn’t touch anything other than plugging the plug into an outlet. Didn’t touch any buttons. The app did the rest and it works like a charm.

My only advice is to make sure the blue light is blinking instead of a solid light.