Outdoor plug network issues

Can’t get it to work on my network. I have many Wyze cameras and other devices from them that all work on my network with no issues. The Outdoor Plug is the only one that isn’t connecting to my network. I can find it, add it to the app, but it won’t ever get a solid blue light and find my network. Furthermore, you can’t control it manually either. This is my second one and it looks like I’m going back to the store to return it and look for another solution. :frowning:

Can you provide the Version and Type of Device you are using?

I would move the Outlet closer to the WiFi router. By doing this, it will be unplugged and plugged back in, which will establish the WiFi connection again.

If it still is not connecting, remove it from the app, while being close to the router. Then add it back to the app again. However, before adding it to the app, Go to the Account Menu, Click on App Settings, clear the cache, Then shut the app down and restart the phone. Then go through the adding of the plug again, see if that works.

Something to try as it could be some form of interference.

1 Like

I tried all your suggestions and no joy. I’m using an iPhone 12 PRO MAX runing version 14.7.1. I’m using the Wyze app version 2.24.36. The outdoor plug is running version and I can’t update it because it won’t connect to my network. I’ve tried it on two different 2.4 ghz routers within 6 feet of each of them. My phone and the Wyze app see’s the plug, the plug just won’t connect to my network. If I click on the plug in the app is says low internet connection. Addtionally, if I try to manually turn off the sockets they just come back on. The blue light cycles from slow flashing to fast flashing never going solid. This is the second plug I have tried and both did the same thing. I have no issues with any other Wyze products I own. Finally, even if the plug was able to be added to my network from 6 feet away it would be no use to me if I can’t use it further away. Thoughts?

1 Like

I beta test the apps (iOS and Android) as well as the Firmware. True, if you cannot get it connected, then you cannot update.

My App version is 2.24.41, you can try updating the app to the Beta Version by signing up here: Become a Beta Tester – Wyze, it is easy to revert back to the prod version, All you need to do, in iOS, is uninstall the app and go to the app store to get the latest prod version. You would use test flight to get the latest Beta Release.

In iOS there is a setting for the App which allows it to utilize the local network for devices as there is new Privacy settings. Go to Apple Settings, select the Wyze App from the main page and ensure Local Network is selected.

Then turn off the Dynamic Mac setting for your phone on a WiFi network, You do this by starting the Apple Setting app, again, Tap on WiFi, Tap the “i” next to the WiFi network you are connected to then turn off Private Address. You can always turn this back on, but it will allow a fixed Mac Address. This may help out.

Just tried all your suggestions and its still a no-go. Sent my log into support. Hopefully someone can figure it out. :frowning:

I’m seeing this same issue with the Outdoor Plug and on my second one as well with the same results. It’s odd because I have an existing Outdoor plug which still works fine. It’s just attempting to set up a new one that gives me the issues.

Longshot but worth a try: iOS Settings > Wyze > Location > set access to “Always” and toggle Precise Location on.

1 Like

I have a similar issue. My setup fails, but the device is connected to my Wifi network and I can PING the device. However, it will not show up in my WYZE app. Any suggestions for that?

Welcom @pmcbrayer1969 , question regarding your outdoor plug. Seeing it on your network implies it was connected at one time, correct? But it just is not showing up in your list of available Devices?

Couple of things to try, reset the plug and then connect it to your network again. When setting it up, make sure your phone’s bluetooth is on. Here is some steps to try:

Here is a page with some trouble shooting information:


I have precisely the same issue as the OP. All my cameras have been working for over a year with essentially no problems. My Wyze outdoor plug worked for about a day and a half before losing connection to my very robust WiFi network. I have spent all night unsuccessfully trying to reconnect it and update the firmware (which you can’t do if it is not connected). I have tried everything. I rebooted my network. I tried set up next to both my router and my access point. I turned mobile data off. I uninstalled the Wyze app and reinstalled. I have deleted and added the plug ALL NIGHT. No matter what I try I just get a slow blinking blue light indicating it is still trying to connect to the WiFi. It is annoying because it worked out the box the first time I set it up. I will have to go with TP-Link or some other brand which will require using a whole new and separate app (what I was trying to avoid by sticking with Wyze). It is 2022 (or close enough) not sure why it is still so hard to make devices that can easily connect to a network.

I have the exact same problem. IP address is assigned. It is visible in the router client list. Through many attempts it either appears to be connected and does nothing, or it says the WiFi connection is too weak( not possible).

When I say “ appears to connect”, the Wyze app is displaying on/off controls, but the plug is still slowly blinking the blue LED

I unplugged the device and put it away for a week. Today I plugged it in, and it is working??? Don’t know what changed. Just glad it is working

There was an AWS outage that was causing all sorts of issues last week.