Wyze Outdoor Plug will not connect to WiFi

Great info and I forgot about this. I had the same experience of the instructions not matching the lights. After setup the blue light is solid.

1 Like

Received 3 Wyze Outdoor Plugs today and so far the two I tried will not connect. The app finds the unit then goes to the “connecting” screen and that’s where it all ends. Spent about 4 hours on it with no success at all. Wish I could send all three back for a refund. This just isn’t worth the aggravation. There are other options that are more expensive but they can be setup to work. Actually these are the more expensive ones if they can’t be made to work. Pretty ugly paperweight.

1 Like

Same exact problem here. Have two and cannot get them to connect to WiFi. Always have some issues connecting Wyze devices but eventually they work after a few tries. Lately the devices I have ordered seem to have more issues than earlier products.

1 Like

Another hour last night and I managed to get one of them to work. Today after nearly an hour another one started working. I did the same exact thing to make them work that I had been doing for hours. Go figure.

Finally got both of mine to work. Just kept trying and eventually they connected.

I’ve given up. Got both of them to connect after many attempts only to have them both lose their connections the following day. Complete junk. Very disappointed in Wyze

1 Like

I assume those having this issue have all used a GFCI circuit for initial setup of the outdoor plug. As required in instructions.
I have 3 outdoor plugs and they all connected perfect. Have been testing one for over a week with no issues
Guess I’ll play with the other 2 for awhile to make sure they work properly

“I assume those having this issue have all used a GFCI circuit for initial setup of the outdoor plug. As required in instructions.”

You must have a newer or older app than I do; Mine just says, “You might need a GFCI outlet” Would you mind checking to see if your instructions show that it’s required and not the above line. It’s on the page titled “Pairing Mode” I’ve tried with and without using a circuit that has GFCI protection still can get the thing connected. BUT, if you have a different version of the app, it would point to something that would give me hope that what I have will someday work.

It doesn’t say it in the app. To use a GFCI receptacle that I saw
It says it in the setup procedure pamphlet that is included in the box with the outdoor plug to use a GFCI receptacle or circuit.
I found that it would not connect without connecting to the GFCI

I got 2 plugs, had them both connected quickly using the interior electricity plug on the same wall I intend to use the plug on the exterior of my home. I put on plug into storage for Christmas, and placed the other on my back porch. 3 days later (I think) it had stopped showing a connection and I have been unable to re-connect it, nor discover how to factory re-set it. I do not want to remove it from the app for fear of not being able to re-discover it later. I have sent two logs on different days and have heard nada in the last 2+ weeks.

Disappointed with the Outdoor plugs so far.


I have this issue too.

@talkingcat hey Jim, were you able to make it work (eventually)? Tried the other tips mentioned above but with no success.

I have a similar issue. I bought 2 outdoor plugs, and received them in the middle of Feb. I was able to set them up successfully but a week or few days later, both started getting disconnected from the wifi. First troubleshooting step I did was to unplug and plug it back. One of the 2 plugs can reconnect to the wifi successfully, but the other one can’t. I contacted support, they suggested to remove and re-add the device. I tried that, but that did not help. Contacted support again, send them logs, no reply until now.

1 weird thing I noticed though (hopefully one of their tech team could be in contact with me) since I am using TinyCam Pro, I can see the list of Wyze devices when going to the Camera settings/status, I see 3 outdoor plugs in the list. 1 physical outdoor plug should show as 2 separate plugs in the list.
This is how it looks - 03.15.2021-12.00.32
I have a hunch that the rogue outdoor plug in the device list may have something to do with my issue - not able to re-add it to the app (after removing it). So instead of being able to address my initial issue with the connectivity, I now have 2 issues. Same as @garykaminsky , I’m very disappointed with Wyze too for not being able to help me resolve this issue, or at least give me some updates.

Has anyone gotten any resolve to this issue or seen anything to try? Still no response to either of the logs I sent, I have now moved my plug at issue to very near my router (2-3 feet), no change.

I ended up doing a hard reset on my router then the plugs both connected right away. The first one I moved it to within only a few feet from the router and for the second one threw caution to the wind trying it at about 40 feet and it worked first try.

I don’t think Wyze monitor the log system. I too sent in a log on a camera and never heard back. I ended up calling and got the help I needed on the phone.

Thanks for the reply.

When you say “Hard reset” what are you referring to?

I have an analog timer on my modem/router that re-boots it every morning until I can get a WiFi 6 (due in this week).

I can’t get mine to do anything other than flash the Blue light at me, no matter the length of time or power/button sequence while holding my other hand in the air and hopping on one foot. I am going to feel like a Felon soon. (Sorry, that might be a regional Cop kinda thing)

I’ve never had this issue with my Outside Geeni plugs from Walmart.

Somewhere on your router there should be a little hole with a button inside it. If not may be another way to do hard reset. Check your router manual. However if you have a new router coming this week I’d wait for that. Doing a hard reset will set your router to factory settings and you’ll need to set it up all over again including any port forwarding, port reservations, security and anything you setup on it in the past. Additionally any equipment you have connected may need to be setup again also. Best to wait for the new router.

Silly question, are you sure you’re connecting to your router and not a neighbors. Be sure to select the correct router. Even sillier question are you sure you are using the right password?

Yes. I already had it set up and connected. Then it suddenly became disconnected (not sure how long it was connected past 2-3 days) and would never connect to the WiFi again. I’d like to factory re-set the individual plug rather than be forced to re-connect 40-50 smart/wireless devices via any hard re-set, especially since it is a rented Router right now. I had hope the new Router will be able to use the same pass, etc and I wouldn’t be back to square one. I’ve never changed any setting on the present router past the password/network name.

I have somewhere in the neighborhood of 20-30 Wyze devices of varying types, not all connected at the moment, some in storage as surplus or future use. All have been initially set up for use, though.

figure it out?

Nope, Nada from Wyze help, either. Resetting these things must be a classified Secret.

This is how i resolved my issue. in my case im using an Android phone. Also, your WIFI SSID, 2Ghz and 5Ghz needs to be named differently. Disable your mobile data from your phone, Select to add Outdoor plug and make sure you select the 2.5 Ghz Wifi. after this steps everything works. The app should not show 5Ghz Networks. This resolve my issue