Lamp Socket Auto settings don't seem to work... lamp is always on

Here are my Lamp Socket Settings

  • Motion is detected in the dark
  • Timer → keep lamps on for 5 min

I have no other schedules enabled and no other device triggers enabled.

Here’s the behavior I am expecting…
If it’s dark (ie if the time is after sunset and before sunrise) and the camera detects motion, then the lamp socket should turn on for 5 min, and then turn off.

However… It’s 11AM, the sun is out, and my socket is still on from last night. When I look at my motion events from last night, there aren’t many. So I don’t think the motion detection is too sensitive. But even if it was too sensitive, and the lamp was on all night, shouldn’t the lamp socket have turned off at sunrise? What is the expected behavior?

I am running the latest firmware on both my socket ( and my cam-v3 (

I should note that I’ve been having issues with the lamp socket rules since I first installed it ~5 months ago, but I’ve never taken the time to write them up because I was assuming they would get patched by a firmware update.

I had the exact same problem. Light was on for 2 days, day and night. I also had activate with motion. I noticed a few times the light icon would be on in the app, i would manual turned it off, thought was just motion, it wasn’t, The tiny little icon could not have been harder to spot. After pulling power to it, operating normal again, been about week or so. Right now, not ONE Wyze product i own working without problems, Extremely frustrating.


I’m having this problem lately with my lamp sockets too. They used to work well, but lately they won’t ever turn off. I mentioned it in last week’s fix it Friday event, but I wasn’t sure if others were experiencing this too or if it was just me because I hadn’t seen anyone else report this before now.

I think it turns on okay, but the timer stopped working so it never turns back off unless I do it manually.


I am having this issue as well.
The light turns on but never goes off.

I have this issue from time to time as well.

1 Like

If more than one customer having same issue, it’s not a bug; it’s feature :slight_smile:

1 Like

Hi, thanks for the info. If you still have this issue today on daytime. Could you please submit logs and I will connect with dev team to look at this.

1 Like

Here is a log from me:

Log 655727

My Lamp socket timer has not worked in many weeks, maybe months. I have tried different intervals on the timer (1, 3, 5 min). I have reset the camera and the sockets and even hard reset them by cutting the power off and back on. I can manually control the sockets still and rules tied to other devices will also turn them off (ie: when contact sensor closes → turn off lamp sockets), but they will never turn off automatically anymore with their auto settings. They used to, but it hasn’t worked in many weeks now. Seems like I am not the only one. I hope the log helps. :+1:

1 Like

Mine seems to happen for 1 day occasionally. Used to be more often, not as much anymore. I can get a log if you want, but currently it’s working fine

Yes, you are not the only one.
I have the same issue. Turns on when triggered by the camera.
Suppose to turn off 3 minutes later but now it just stays on.
Worked for a while when I got it.

1 Like

Will you grab a log for Wyze Desmond too? Open the cam, Go into the cam settings (the gear icon on the top right) Then click on Wyze Support → submit a Log → Lamp Socket Issues

and then submit it and post the reference number in here so he can forward it on to the developers and hopefully get this fixed for us. :slight_smile:


No, I’m not going to bother.
I have issues with sprinkler and outdoor plug. and these are serious issues.
Users have been sending them logs for 6 months without a resolution.
What can I say…

Weird, both of those have been completely flawless for me since the day I got them. Sorry to hear of your struggles, I recommend making sure to update firmware, app, contact support and sending logs so the devs can see why yours are having problems when most others don’t or figure out if there is a bug of some kind (newest app and firmware helps them rule out lots of things and make sure they are testing on the same stuff, even if you’re confident the firmware and software are not the issue, they often need it that way for verification and testing on their end). FYI sending a log for this product won’t affect anything with the timetable on the others, they’re separate dev teams, so it wouldn’t be taking anyone away from the things you want addressed most.

You can always report the issues you’re experiencing in the Fix it first Friday events they have on the first Friday of every month where you report bugs and if others are also experiencing them, they’ll vote that it is a widespread issue and those get the highest priority for getting fixed first over other bugs with an outline of what they’re doing about it and estimates of when they expect it to be resolved, etc. I don’t think I’ve seen either of those issues reported in the Fix it First Friday event yet. Next one is in 2 weeks on the 5th of August. You should report them then so it’s more well known, or just talk to support directly if you think it’s just your individual device/unit and not the product in general since many others are functioning.

Either way, good luck and best wishes. :+1:


Really hope this is going to be fixed soon. I have two light socket with the exact same problem. Some times they never turn on and sometimes they stay on.


Not everyone seems to have the problem, and most of the people that are experiencing the issue aren’t submitting and posting the logs for it. I am sure this is a big reason it is taking so long. It is always helpful if we can get more people to submit logs and post their reference number in here to be passed on to the devs.

I have sent quite a few logs. To be fair, doesn’t happen all the time. Can go 2 weeks or 2 days without that issue.

I contacted the support and sent my log already. They sent me a replacement and I have the exact same issue with it.

If either of you still have the log #'s for it, can you post them in here and tag WyzeDesmond so he can make sure they get to the team investigating the issue? Or whenever it happens again, create another log and send it to WyzeDesmond? Hopefully support passed on your logs to right team, so thank you for contacting them! :+1:

I also plan to bring it up for this Friday’s “Fix-it-first-Friday” event to get it more attention.

I’m close to replacing my lamp sockets with Wyze bulbs instead since the lamp sockets rarely turn off anymore :frowning: Mostly trying to keep them going so I can help test it, especially since I know others having trouble with it. Thanks for confirming you guys :+1:

log id 661651 , 637207

To be honest i’ve given up on expecting things fixed. Just went thru most hilarious customer deservice e-mails. I have cameras in 2 countries, 3 separate locations, different equipment and ISP’s, only thing in common the same cameras (v 3’s). V2’s and doorbell do exact same thing too. My phone, Android gets stuck at 1 of 3. I have to Shutdown app and open app, and logs back on to cameras every single time. They trying to get me to install 3rd party apps and insinuating its a network issue with the cameras. I give up. Good luck with the logs

1 Like


Sorry to hear you are having multiple problems with your cameras. I know they are currently testing firmware fixes for several bug resolutions. Hopefully, when that goes public it will help with some of those other things too.

@WyzeDesmond we got another set of logs for you!

1 Like