Lamp socket not turning off light bulb automatically

I have a lamp socket and have camera v3 connected to it. It is configured to turn on when motion is detected in the dark and have timer set to keep lamps on for 5 minutes.
Detecting part works very well and the light comes on.
However, it does not turn off the light after 5 minutes. In fact, it stays on forever until I manually turn it off using the lamp icon in the app.
What am I doing wrong?

Same, I have to open app and manually turn off light.

I think I may have found a “solution” or “workaround” for this issue.
I changed the motion detection sensitivity in detection settings to 1 from default value. Now, light is being turned off correctly on time.
I guess the default motion sensitivity was too high and the light being turned off may have been triggering as another “motion detection” and turning on the light again hence making it look like the light never turned off.

1 Like

Thanks for your tip @jeteyenight

Anyone else still having this issue after changing the detection settings to 1? This worked for a short time, but no longer shuts off automatically. Need to turn the light off in the app.

1 Like

Yep, having the same issue and the workaround above didn’t work for me at all.
Now I have to keep the socket off…
Wyze, please fix this problem.


Just wondering if this has ever been addressed???

I have the same issue. Additionally, I have the socket configured OFF. but it comes on anyway.

I was having the same issue and was irritated that the answer wasn’t here. After messing around a bit, I found the simple fix - or at least it worked for me …
Manually turn off camera.
Go to settings and scroll all the way to the bottom of the menu and click on “restart camera”. Wait 5 minutes.

It’s been 24 hours and the light is still off.

I’m glad worked for you. I’ve done that several time to no avail.


Finally found a work around by using a plug not being used and setting up a rule to turn on plug and turn on the socket after xxx notification for which ever camera you choose, then make a rule for plug after being on for x minutes to turn off plug and turn off socket, this should be only rule used for this plug, may need to reset all to get it to work (plug, camera, socket), but should solve issues until Wyze solves this for socket (note this was previously noted on Wyze site)

I have the same issue - lamp socket won’t turn off by any means except for turning it off from the Android app. This issue has been open for 11 months and no indication that anyone at Wyze has even acknowledged the issue. User experiences like this have a strong negative effect on future buying decisions by existing users.

Same here, wish they would fix this.

Same problem. Worked well for the first couple of months, then this. Not so useful for me anymore.

Wyze updated the app to include off after x minutes in the rules for socket and it’s been working fine for me when set by rules for the socket with an event from different camera, haven’t tried rule for the same camera, but something to try if not getting the off after X minutes to work on socket controls, I’ll have to try from same camera and see

Well, setting up a rule for the camera V3 attached to the socket to turn on the socket for 5 minutes worked to turn on the socket, but then the socket did not turn off, not sure why it worked for camera not attached to socket, will try to reboot camera and socket tonight and see that works

Update, after turning off power and resetting camera, I’m happy to report that the attached camera to the socket rules have been working correctly turning on socket (light) and socket (light) turning off after 5 minutes, not sure if I had to reset camera or if a mere power off and on might work, but since I was up on ladder decided to do whole works before weather impacted me climbing up there again

Same problem here. It’s been happening for at least a couple of months now. None of the resets have helped. I’ve contacted Wyze support, they haven’t ever made any suggestions or explained what might be going wrong. 3 weeks ago the support person said they were sending me new lamp sockets under warranty but I haven’t seen them yet. I’m so frustrated and just about done with the Wyze system!

Have you tried setting up a rule to turn it off or just going to the the lamp socket settings. under the attached camera settings to turn it off?

I ended up creating a rule that turns off the lamp every day during mid-day when the lamp should be off anyway.
So far, that seems to be an effective workaround.

I agree, Wyze support has been rather poor in my experience as well.
The people on the phones seem to only know how to walk you through reset and/or factory reset of your Wyze device.
The issues logged on the forum never get resolved or even an official reply.

I found a workaround (may have been suggested in earlier reply to the thread on this issue) that has worked so far.
Create a rule that turns the lamp socket off each day mid-day when you would not expect the socket to be on anyway.
So far, that seems to have been effective for my wyze cam and lamp socket.
Hope it works for others.