Google Home link available, integration doesn’t work

Luckily (or unluckily) I had only bought 1 Wyze camera as a test before I purchased up to 4 more for our property (rural Northern California.) It is a V3. It has never displayed in my Google Nest Hub or in my Google Home app on the phone. I always get a black screen with an error message.

So far I have purchased 2 additional Reolink cameras. Both display perfectly in the Hub, obey Google Assistant commands, and even allow display in the Windows Reolink app in a 2 up window. They didn’t cost that much more than the problematic Wyze cam V3. As an added bonus, the Reolink cams don’t need the internet to deliver their feature set and Reolink doesn’t try to upsell me 24/7 with cloud services.

The V3 is sitting in a box, so far a complete waste of money for my needs. All in all a very disappointing experience. Good luck with yours. Hopefully they will sort it out. I’m not holding my breath.

I will still monitor this forum to see it they ever fix the problem. The V3 camera itself was nice, good clarity, nice night performance, and an attractive price point.

As a side note, the Reolink cameras also work with Home Assistant right out of the box. The Wyze camera required an RTSP firmware hack that Wyze actively discourages. So not only will Wyze not address this issue, but they seem hostile to third party solutions. Sounds like a winning strategy to me.

I’ll share my experience here as another data point. I have 3x V2 cam, 1 pan V3, and 1 outdoor V2. I am able to have everything else but outdoor V2 display on my Nest Hub. I have tried unlinked and relinked it with no success.

Almost perfect in my case, fortunately I guess. If only the outdoor cam can work …

Sorry to hear it’s not working for you. I’m still baffled mine started working then went to not working and now back to working again (except for the newest v3). I ended up letting some time go by and I think it might have been unraveling (resyncing) everything after I resolved the 2 account issue. I didn’t do anything else.

It’s interesting that you seem to be having the same problem with 1 camera not working with the Nest. Hopefully someone will figure it out soon.

This worked for me! Thank you Earl!

Google Nest cams work fine on Google Home, though with less features than Nestcam App. Google has been working on porting the Nestcam features over to Google Home for at least a year if not 3. … … … so definitely not their priority… as they must have the source code from Nest … …

My Wyze cams do not work on Google Home.

They do work on Alexa but only one at a time. Nestcams do not show in Amazon Alexa iOS app.

Both Wyze & Nest cams will display on Amazon Fire TV, one at a time umless other app is used sucj as TinyCamPro.

I’ve given Wyze and Google Home additional time to sync but the one new cam v3 will still not stream on the Google Nest. I might try removing it completely (again) tomorrow and then let Wyze and Google completely sync before adding it back. Last time it took a couple of days for the removed camera to finally disappear from Google Home. So, it might be a total of 4 or 5 days before getting the camera back on Wyze and finally synced back to Google Home.

I deleted the errant cam v3 from my Wyze account. Google Home almost instantly alerted me that a camera had been removed (recall it was in the list but not viewable). At least it was gone pretty quickly. I added the same cam v3 back to Wyze, and as expected it took half of a day or so before I could re-add it to Google Home using the “works with Google” and “reconnect” options (discussed above). After Google Home listed it as a camera again I attempted to stream it on the Google Nest, but it shows up with the same non-streaming video player type screen. It literally looks like all of the other cams in both Wyze and Google Home, but this one will not stream. :man_shrugging:

My Wyze devices disappear completely when I unlink, and all come back when I relink. The lights, sensors & plugs work fine, but the Video streaming has never worked???


I think I got this to win the Fix-It-Friday even on Reddit for this month. So we should get an update from Wyze about it sometime this week.

I also brought it up with the Google Home Team during their AMA over the last week, and I got a response that they were going to take this back to their team to look into.

This isn’t affecting me at all…all my devices including camera streams are working great on Google, but I submitted it since so many of the rest of you are having it not work right. Hopefully now that Both Wyze and Google are looking into it, we can get it running for all the rest of you again.

3 Likes

@carverofchoice Much appreciated. Let’s hope they can get it fixed.

2 Likes

Thanks @carverofchoice.

I am hoping that this time they will take a serious look at this problem.

I am also having an issue whereby I am only able to turn on the Wyze cam using a Google Home automation script but not turn it off (I get a device not found error when the script tries to run). The turn on automation command works fine. I’m hoping that if they fix the cam streaming issue then that might also fix the off-action failure as well.

2 Likes

In my spare time I have been making a spreadsheet/list of all the new commands and features Google Home has enabled this summer that could be added to each Wyze device. I want to make a presentation to Wyze of all the options they could add to each of their devices and ask them to look into adding them all. I’m sure they won’t add EVERYTHING, but now that Google has added support for tons more things as of 1-2 months ago, I want to make sure they at least consider it. Google can actually be really useful now and compete against Alexa for smart home automations after their latest updates this summer. I’d love to have Wyze take advantage of the new options to make Google more useful now.

2 Likes

Never worked for me either . Same exactly situation.

1 Like

And to Alexa !

Oh for sure. I use Alexa more. I mostly mentioned Google because I don’t think they were even aware of all the new updates that happened to Google this summer.

1 Like

This worked!! thank yoiu @night_butt3rfly

I joined this forum after spending hours troubleshooting my Wyze Outdoor Plugs’ failure to work with Google Home on Android. I’m tracking a lot of other complaints to Wyze forums about Google Home integration, covering numerous products including Wyze garage door openers, lights, cameras, and plug devices.

I am using a newer Pixel phone with updated Google Home.

I have 6 Wyze cameras and 2 Wyze Outdoor Plugs.

The Wyze app works on all 8 devices. I can see all cameras and control both plugs.

I’m only interested in getting Google Home to recognize the plugs, which worked with Google Home for two years until recently.

I have submitted a service ticket, but I’m not getting any help…

I have tried the following:

  • Turned off device isolation on Eero router
  • Checked firmware, up to date 1.2.0.333
  • Power cycled the plugs
  • Logged into Wyze using 2FA
  • Unlinked and reconnected Wyze Home in “Works With Google Home” many times
  • Emptied the app cache for Wyze and Google Home before and after unlinking Wyze
  • Asked Google Assistant to resync my devices

After multiple attempts, Google Home just lists only 1 Wyze device, and I can’t figure out what it is.

All my 8 devices appear as “offline” in Google Home.

When I try voice commands, Google Assistant says, “Sorry, it looks like Wyze Home is unavailable right now.”

My Kasa plugs work flawlessly. I’m about ready to dump my 2 Wyze plugs and buy $15 Kasa plugs, now so disappointed……

I’m not seeing this issue in the latest “Fix-It-Friday”… Does anyone know whether it is on their radar?

I haven’t noticed a big pattern in people’s plugs not working through Google Home. I have Indoor Plugs (pre-2021, 2021, and 2022 indoor plugs) as well as several outdoor plugs. I just checked and all my plugs seem to be working with Google Home when I tell Google Assistant to turn them on and off. I am not sure why it’s not working for you. That would be good to figure out since everything is working on my end. I wonder what the difference is. I am currently using a Pixel 5, though I am upgrading to Pixel 8 Pro this week. I also set up my Google account a while ago, so maybe there is something wrong with newer activations.

I know Google Home stuff in general is on Wyze’s fix-it-friday radar, at least it was for cameras:

Maybe go here and leave your info for Wyze just in case it is related to the same issue:

Hi. I have tested on both Android and iOS, and I can confirm that live video works on Android, but not on iOS. Did you get any feedback from Wyze?