Google Home link available, integration doesn’t work

I figured out that this was a “feature” that neither vendor seems interested in addressing. I was prepared to buy 4 more Wyze Cam v3’s to cover the outside of my property. Luckily I only bought the one to test it out. I am out on Wyze Cam until they fix this.

I also run into minor issues between the Wyze Thermostat and Google Home. I can turn the Thermostat off from the Wyze app and Google Home but once it is off Google Home says it is no longer connected. But the Wyze app turns it on just fine. The Wyze scale I bought works flawlessly but it is only linked to my Fitbit (Google) account.

I think the core of the problem lies in the fact that there is little incentive for any of these vendors to truly make the equipment interoperable. All vendors would like to keep you fully in their ecosystem so they put their efforts in that direction. It might have something to do with the use of the personal data they are collecting from their customers. That is where the true value lies and they are reluctant to give up that income stream.

As a side note, I installed Home Assistant on an old computer and was stunned how quickly it found all of the connected products in my Home, TP-Link Kasa, Google, Roku, Yamaha receiver, Dish Network DVR, everything but Wyze. I think these manufacturers should either charge enough for the products so that they don’t have to make up for the small or negative profit with back end data collection or add-on cloud services (where the real money is.)

I don’t think we are going to see a change any time soon. Maybe Matter will make a difference as it has the heavy hitters behind it. I won’t hold my breath.

I must admit I an starting to lean towards Home Assistant as a final interface. The thing that stops me is that it is very time intensive and requires a steep learning curve. It does offer the advantage of home hosted services and program execution. That would likely make it a more robust solution in the long run.

Thanks for the response.

Hi everyone. The newest updates require 2FA Authentication to connect Google Home to WyzCam now. Go to your WyzeCam app, Account, Enable 2 factor authentication. Then open the Google home app, Devices, Add using Works with Google, select WyzeCam, reconnect the account, sign in with 2FA. Then you should be able to see all the cameras again!


Similar story. I had no issues adding 5 cameras to google home a year or 2 ago. I can stream any one of them on a google hub. I was also able to add a 6th camera to google home a few weeks ago, but cannot stream it on the google hub. I’m now trying to add a 7th camera to google home, but when I link to wyze (logins successfully) it says no compatible devices.

I ordered 3 more cameras and a wyze doorbell a couple of days ago. With the google/wyze link being broken, I’m thinking I need to just return the 4 wyze devices when they arrive, and buy nest devices to ensure they will keep working with the hub long term.

Edit: i started my post earlier and didn’t see night_butt3rfly’s post until now. Will try 2FA.

Thanks for the suggestion but that didn’t work for me. My Cam V3 will still not display in the Google Home ecosystem. The camera shows up but only displays a black screen with an error message. The camera display fine in the Wyze app.

It is the third time I have tried this method. There must be a reason why there are numerous YouTube posts telling you how to reconnect your Wyze cameras to Google Home. This is not ready for primetime. At this point I consider this claim from Wyze to be false advertising.

The sad thing is that I like the camera.

1 Like

night_butt3rfly’s suggestion didn’t work for me. What worked was buying a Reolink camera. It worked right out of the box.

I also have weird issues with the Wyze thermostat and Google home. Most of the time it works, sometimes Google Home gets “amnesia”. Maybe it is just an authentication issue. Maybe Wyze’s cloud and Google’s cloud are not synching properly. Maybe Wyze uses AWS so they are more Amazon friendly. Who knows. All I know is if you claim that your product is compatible that influences buying decisions. A good way to alienate your customer base is to not live up to posted claims.

This only happens with Wyze products. TP-Link Kasa, Yamaha, network equipment, and all other Google Home/Assistant integrations are flawless.

Good luck. I gave up.

Nope. I unlinked Wyze from GH, added 2FA and reconnected with Google Home (now with 2FA set up) and re-attached the camera to the account. It doesn’t make any difference. Still same problem as before.

My Google home stopped recognizing my Wyze products (lights & cameras) about 2 days ago. I just followed your suggestion and worked like a charm!! Thanks so much!!

1 Like

It works! I enabled 2FA in the Wyze app. Then from Google Home app I “reconnected account”. All Wyze devices are controllable by voice again.

@wafglobal Unfortunately, I’m having a similar issue even with 2FA but with mixed results. I had a couple of cameras on my Wyze account but had not added them to Google home. When I added them to Google home I can ask Google to stream them on a Nest and they work correctly. The newly added cameras and doorbell added to Google home without issue (can see them listed), but they will not stream. Most of them will come back with “something went wrong” error. One of them will come up with a play screen (nothing like any other camera) and a play button but will not stream anything. Not ready for prime time. Contemplating returning 3 cameras and a doorbell.

Spoke too soon. Now none of the Wyze cameras will stream on a Google Nest. Today’s error is something about not being able to reach Wyze Home. :frowning_face:

As @wafglobal pointed out my Kasa devices have never failed to work.

Got Alexa to work after 2FA but not Google Home on an iPhone. Really want the Google Home to work on iPhone/iPad.

In Google Home… Go to Devices → click the + symbol to add a device —> On the this screen, press “Works with Google” → On this screen is all of your “connections” from various companies you connect to Google Home. You should see Wyze. Click it… on the pop-up that comes up. Choose “Reconnect Account”. Re-login to your account.

See if that helps.

1 Like

I’ve done that about a dozen times. All my other services are up and working, just not Wyze

Yep. Doesn’t work for Wyze. Everything else works. :man_shrugging:

For all of you having issues with this, I submitted this issue to the Wyze subreddit Fix-It-Friday Event:

So far it’s the only issue there that has even been submitted, let alone voted on, so I feel pretty confident that this issue will be added to the next Fix-it-Friday Report with an action plan and updates about how the resolution progresses.


Wow How frustrating in the year 2023 to not have my Wyze cameras connecting to Google Home. This should be a no-brainer get it fixed for the company. None of my cameras show on Google Home, but everything else works fine and I do have 2FA.

1 Like

All Wyze cams except a new v3 are streaming again.

I have 2 google accounts I use with Google Home. Both are authorized “managers” in Google Home. The “second” account is a shared account that is on the Google Nest. I was using this second account for all of testing/trials in my posts in the last few weeks where reconnecting and 2FA were not working. Keep in mind, I was attempting to add new Wyze cams to Wyze and Google Home for streaming on the Nest. Again using that second google account. Also, all of the devices were showing up in both Wyze and Google Home and working correctly in Wyze but not in Google Home. Since I was at this new juncture (all devices present vs adding new a week ago), I went back up the thread and ran through a step that @carverofchoice detailed where you can reconnect your Wyze account to Google Home. But, when attempting this I realized there was no Wyze account in the list of connected accounts. I initially related this to the overarching Wyze connection with Google Home issue thinking of course it’s not showing since it’s broken. I decided to change to my “first” Google account and then Wyze showed up in the list of connected accounts. I clicked reconnect account as mentioned above, and all of the prior devices are now streaming again. Now back to trying to connect new devices. I did get a new doorbell to stream, but still unable to stream a new v3 on Google Home/Nest. It works in the Wyze app. I removed the new v3 from Wyze and re-added to see if it would resolve streaming in Google Home. It hasn’t yet. I guess I’ll give it some time to sync.

1 Like

That didn’t end well. Only the doorbell is working now.

yes my cams act the same as yours. Interesting though that my Wyze lights work fine.

Seems to be all over the place. I’m back to all cameras except the latest v3 (mentioned above) are working with Google Nest again. They are all configured the same way with the same account. That one just doesn’t work. Random.