Google Home link available, integration doesn’t work

I have my Wyze account linked to my Google Home account. My Google Home app recognizes that the cameras exist (they are in “rooms”), but they cannot connect when I ask my hub to show a live feed of any camera.

I have a camV1 and two camOG. The V1 is able to be turned on and off via Google, but nothing is able to “connect” to the camera to view the feed.

I am gathering this is an issue for other platforms and has been an issue for awhile. Please fix the integration issue!

1 Like

Same here on all 9 cameras

1 Like

@aegeiser I don’t currently have a V1, a WCOv2, or an OG (I lent mine to my brother to check out), but I do have 40 cameras with every other model camera represented and just checked them all on my Google Home and they are all currently functional/streaming. So this means it is possible this issue is limited to V1’s or OGs. Maybe someone else with V1’s or OG’s can check theirs to confirm.

I have seen some people in the past who have had a streaming problem on Google or Alexa fix it by reconnecting their Wyze Account to the platform. In the Google Home App, if you go to the settings tab at the bottom right, then click on “Works with Google” in the Services section, then click on Wyze Home, it will give you the option to “Reconnect account.” Several people have said that fixed their streaming issues, so it is worth trying.

If that doesn’t work, then other people have found that there may be router settings that can help (make sure device isolation is turned off, that they’re both on same 2.4GHz SSID, QoS and MMS isn’t interfering, etc.). Some people have found success testing a different router temporarily and found that their previous router didn’t like WebRTC protocol for some reason or other parameter and timeout implementations specific to a particular router.

Let us know if you figure out anything that helps so we can help give similar suggestions to others too.

I can look into router settings—haven’t tried that.

But I have disconnected/unlinked and reconnected the app multiple times without any change.

Very frustrating it doesn’t just work. I wouldn’t expect that they have the same functionality on the devices as in their own native app (or that the same brand products have with their own network communication), but if they’re advertising “works with google”, seems like they should make sure they actually do.

1 Like

Verizon Fios here 1ghz up and down and no son or Qos. And all other cam works ring/ nest and lorex which is hard wire.

none of my Wyze cams are working on Google Home currently… Pan v2, Pan v3, v3, v3 pro, doorbell pro, OG

I unlinked and relinked. They still will not work.

Not sure if this Google Home update TODAY was the cause… or an attempt to fix it.

My Wyze cams do not connect BUT my Wyze lights do work in Google Home

also I can see my Wyze Cams on Chromecast using Show “Wyze cam name” cam


Hi @tc10 I had another user confirm that the problem is with the new Google Home app on iOS specifically. They were having the same problem as you and found that their cameras all worked on Google Home with Android, but not with Google Home on iOS. This leads us to believe this is an issue with Google Home’s iOS build since everything works fine everywhere else.

If anyone contacts Google about this issue, I would love to hear what they tell you.
Maybe we can get someone from Wyze to reach out to their Google Contacts to check into this too. Even if it isn’t Wyze’s fault specifically, I believe they have contacts with someone at Google Home they can try to report it to or work with, so they might be able to help this get some attention. I’ll try to pass this on, but it might be helpful if one or more users also report this to Google Customer Support so that it can be logged into their system officially from the support end.


But the Google Home devices that can display video feed from the cameras (i.e. Google Hub) are not run on iOS, and those don’t work for me either.

They recognize the device exists, just like my iPhone, but then they can’t connect/load.

No clue. Very annoying.

1 Like

My cameras are all streaming on my multiple Google Hubs though. :thinking: So in that case, I wonder if it only works on Google Hub for people who set it up with Android and then it will work everywhere else for those users. But if we try to set it up with iOS, maybe it doesn’t connect right and thus it won’t work on Google Hub either in that case. Thanks for pointing out that it’s not working for you on the hub either, that is worth considering that it’s more than just the app itself, but could be something where the app is not authenticating the link on the backend at all somehow.

I have had multiple people with both Android and iOS confirm that it is working for them on everything (including hubs, TV, etc) except for the Google Home App on iOS, so it seems like that is the common denominator for everyone having issues. Something in the Google Home iOS app must be preventing complete connectivity it seems to me.

If you have a spare Android device, try linking to Wyze through the Android Google Home app and then see if it suddenly starts working on your Google Hub like it does for me and others. If not, I guess have some patience while Google looks into it and pushes out a fix. I’ll try to keep an eye out for any updates/changes now that we have an idea of what might be going on.

The only Android device I have is an Amazon Fire tablet. I can see if I can get it to work on that and will let you all know.

1 Like

I have provided feedback thru Google Home app.

1 Like

Same here.

I will be trying a Google nest cam and replacing all wyze products as they don’t seem to care about this issue. Raised a ticket with support a month ago and support is stumped

Tried using 5G not connected to wifi. Same issue. I am not looking for possibilities, I am looking for a fix. Will see how the nest cam works.

Same issue with Alexa app. Devices linked and available, but do not respond to voice commands and the Alexa app cannot connect.

I’m pretty confident the Nest cams will work for you. Google has an incentive to fix their stuff to work with their own stuff, but if their app is messing up with another company, they don’t have an urgent incentive. I mean, look at your case, the google home app is causing a problem for you to see Wyze, so now you’re going to reward Google for not fixing their app by giving them more money through buying their higher profit margin cams instead. I’m not saying I blame you, I am simply pointing out a good example of why Google doesn’t have an incentive to urgently fix the problem in their app…they are getting more people to switch to them instead of complaining to them until they the fix the problem they introduced in their latest release.

I’m sure they’ll get around to it eventually, it’s just not urgent for them to fix their own mistakes when they are getting people to switch to them and pay them more money for their mistakes.

If you’re having an Alexa issue too, that is weird and might be something different. Both Google and Alexa have been working for me and Alexa has been working for others with iOS.
Have these ever worked for you or did they just recently stop?

About a month ago, just stopped responding to ok Google Commands saying wyze home is unavailable. It had said that before, but it would still complete the action. It’s like it started off minor and then escalated.

Gonna try a to link camera. Lower price point, good reviews, good brand works with Google.

That should help eliminate some things.

I installed a Wyze Camera v3 less than a month ago with the same issue as everyone else. The camera “card” appears in Google Home and on my Nest Hub but there is never any image. There is no image on my android phone either or my wife’s iPhone.

The camera live feed and motion detection is fine on the Wyze App on both phones, although a bit laggy. It also works when I am away on my phone over a cloud connection.

I have been in contact with Wyze support and I tried all of their suggestions but nothing fixes the issue. The last interaction required me to send the the logs from the device and they thanked me for contributing to the troubleshooting.

All of this is steering me away from the Wyze ecosystem. Their products seem well made at a very competitive price point. I bought the irrigation controller, the thermostat, the camera, and the smart socket to power the cam v3.

They all seem t work fine in the Wyze app.

Low cost isn’t a feature if hours must be spent troubleshooting basic functionality.

Just wanted to mention that I am having similar issues. I can add my Pan cam in the Home app on my Android and Google Home can sense if the cam is on or off but if I try to connect to the cam it just keeps saying “connecting” then gives up with “Camera unavailable” and below it says “Live video unavailable”. No issues pulling the video on the Wyze app.

Also, I wrote a Google Home automation script to turn the camera on and off. The on command succeeds but the off command fails with an “action failed” error.

This is quite annoying. The Wyze app’s automations are not robust enough and don’t integrate with non-Wyze devices, plus I can never get the app’s geofencing to work right (at least not without extreme battery drain on my phone) so Google Home automation would be a good alternative - if it worked as documented with the Wyze cam. Right now I am using an IFTTT script to sort of do what I need but am limited by the number of actions unless I pay IFTTT their 4 bucks a month.

I have seen other recent threads that mention connectivity issues between Wyze and Google, but the vibes I am getting is that Wyze is not in a hurry to fix things which is sad.