Can't get sprinkler schedule to work

Here’s this week’s fix it friday report on the issue:

Everyone in this thread should already know that update since Jason has thankfully been active in here. I figure it’s still worth including the official weekly response for those who are following the issue.

2 Likes

Was delayed because my sprinkler went offline again but I can now confirm that rules are working for me. It’s a pain to set up because you can’t put the Sprinkler action in a rule twice for some reason and will require more work for soak and cycle but hopefully this will help find a solution to the proper functionality

There is no notification but it shows up in the calendar as “App Quick Run”

Throw my name in the ring for people facing this issue. My lawn is getting torched so I went looking. The really weird thing for me is that one area of the app (where it shows all the zones) says manually skipped and the other area of the app says it ran and watered. Also my saturation is reading as 0 and projected to stay at 0. I’m curious if others are running defaulted sand types etc? I’m using smart schedule.

If any data is desired then let me know. I’m pretty well versed in troubleshooting devices and networks. I also happen to have a zabbix server running if you want any monitoring data.

1 Like

I pulled the logs from my android device and was just poking through them and I was curious if anyone can tell me why I see it trying to set the various timers to 1977? I’m assuming these are epoch times and if so then these are dates and times from around September of 1977.

Also is there anywhere that your API is documented? I would love to be able to query it and see what it thinks has run vs what has run.

07-21 06:14:05.539 1463 7261 I ActivityTaskManager: START u0 {flg=0x10000000 cmp=com.hualai/.home.device.WyzeCamplusABTestLinkPage (has extras)} from uid 10382
07-21 06:14:05.544 1463 7261 W ActivityTaskManager: Tried to set launchTime (0) < mLastActivityLaunchTime (244377880) <------ 244377880 appears to be unix epoch which converts to - Your time zone : Thursday, September 29, 1977 3:44:40 AM GMT-07:00 DST

07-21 06:14:05.564 1463 7261 I ActivityTaskManager: START u0 {flg=0x10000000 cmp=com.hualai/com.wyze.lockwood.activity.home.LockwoodOpenPluginActivity (has extras)} from uid 10382
07-21 06:14:05.569 1463 7261 W ActivityTaskManager: Tried to set launchTime (0) < mLastActivityLaunchTime (244383393)
07-21 06:14:05.587 1463 7261 I ActivityTaskManager: START u0 {cmp=com.hualai/com.wyze.lockwood.activity.home.LockwoodMainActivity (has extras)} from uid 10382
07-21 06:14:05.592 1463 7261 W ActivityTaskManager: Tried to set launchTime (0) < mLastActivityLaunchTime (244383417)

07-21 06:54:55.612 17202 26421 I WyzeNetwork:: 收到响应: code:200
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: 发送请求: method:GET
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: 发送请求: url:https://wyze-lockwood-service.wyzecam.com/plugin/irrigation/zone?device_id=&nonce=
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: 发送请求: 请求头:User-Agent: wyze_android/2.43.5.313 (Pixel 6a; Android 13; Scale/2.625; Height/2205; Width/1080)
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: appversion: 2.43.5.313
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: Accept-Language: en-US
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: env: Prod
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: access_token:
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: app_version: android_2.43.5.313
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: requestid: 88ae4a6dc5242a972fdc215e957242f6
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: appid: BSSC_83d270f3a6124d87
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: phoneid:
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: appinfo: wyze_android_2.43.5.313
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: Signature2:
07-21 06:54:55.612 17202 26421 I WyzeNetwork::
07-21 06:54:55.612 17202 26421 I WyzeNetwork:: 发送请求: 请求body:
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “code”:1,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “current”:1,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “data”:{
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “zones”:[
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “area”:500.0,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “available_water_capacity”:0.1,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “camera_device_id”:null,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “crop_coefficient”:0.8,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “crop_type”:“COOL_SEASON_GRASS”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “device_id”:“BS_WK1_7C78B20712E4”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “did_uid”:“BS_WK1_7C78B20712E4_c25813a74eb54b928a782f3a87816fa3”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “efficiency”:80.0,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “enabled”:true,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “exposure_type”:“SOME_SHADE”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “flow_rate”:0.7,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “garden_subtypes”:null,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “latest_events”:[
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:1200,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-20T09:49:57”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689871797,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“App Quick Run”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“MANUAL”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:1753,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-19T04:30:32”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689766232,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:1200,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-18T21:14:12”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689740052,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“App Quick Run”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“MANUAL”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:877,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-18T02:54:06”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689674046,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:877,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-17T03:26:11”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689589571,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:877,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-16T03:07:09”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689502029,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:877,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-15T03:06:09”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689415569,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:877,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-14T03:05:09”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689329109,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “duration”:877,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_local”:“2023-07-13T03:48:27”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “end_ts”:1689245307,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_name”:“Smart Schedule”,
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: “schedule_type”:“SMART”
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: },
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json: {
07-21 06:54:55.612 17202 26421 I WyzeNetwork::原始json:

Good find! Honestly an API would fix everything for me because then we could just do custom code to trigger it but obviously not everybody who’s having this issue would know how to set that up. I’ve tried both smart and not smart schedule and both have issues ghost skipping for me (no reason given, not even manual skip. Schedule just disappears from calendar)

I would like to double follow up and say the rules are working perfectly for me. So that makes it clear it’s something only wrong with the scheduling.

1 Like

For your ghost skips it would be interesting to see what is logged. You can enable developer mode (Settings >> System >> Developer Options – If this option isn’t there then go into Settings>> About Device/Phone >> Software Information >> Tap Build Number 7 times and that will enable it). Then you can download adb onto a computer and connect your device via usb. running adb logcat -b > logdump.txt will dump all the logs. If your schedule is set to run each night perhaps just plugin the phone to your pc so that debugging kicks on (you can set when to enable debug) and that will show you what it did and why.

I sent this info up to the team to see if it helps them at all.

1 Like

This week’s update:

2 Likes

Given that the schedule is API driven has anyone played with changing when it fires to ensure it’s not a connectivity issue?

Hope this gets fixed soon… This is ridiculous. Being able to schedule your sprinkler is kind of sprinkler system 101… Not exactly a luxury feature request.

Add me too… Not sure why this is so hard to get fixed I have been watching this thread for months and assumed they would fix this quickly… It’s just a schedling issue can’t be that hard to figure out right…lots of people reporting this already so I haven’t officially logged a ticket but will if I need to.

Unfortunately I have an iPhone so not sure how easy to rip the logs off it. I do have an older android device somewhere so I may attempt to use that just for this.

I tried different specific times and sunset vs sunrise to no avail. If you see my previous posts, you’ll see that I tried even putting it a few minutes into the future and it would still fail sometimes. One time I moved it a few minutes into the future and since it didn’t run, I did a quick run. After the quick run ended it said “Soaking” like it was actually running the schedule. Once the “Soaking” timer was done, the schedule completely disappeared with no reason listed (AKA it did not actually run the schedule).

I agree it’s ridiculous that a sprinkler system can’t do the basics. Even when not using smart schedules, skips or sunset/sunrise, it still fails. The people in this thread are definitely not the only ones who have it failing either. A look at Amazon reviews shows plenty of people having similar issues.

I’m a little more hopeful now that we’ve established that Rules work seemingly 100% of the time (as long as the sprinkler doesn’t offline itself) and that we’re part of Fix-It Friday. Hopefully we’ll see a fix soon.

When I found this thread and realized that it had been a year long issue I was pretty blown away. I don’t think it should take anywhere near this long to resolve it. However, I think there may be two issues. My smart schedule defaulted to a water holding capacity of .5in for sand but most sites and studies suggest it should be closer to .8in or more. So even if it’s firing normally I suspect the amount that it waters is too low and most people would just think it wasn’t running. I set a frisbee outside upside down and now I check it each morning to see if it has water in it lol – DannyBoi if you wanted to debug iphone you can - How to View Your iPhone's Debug Log/Console – Note I haven’t tested this but that SHOULD work…

Any updates on this? What have they found? What part of code is possibly causing the issue? Do you want help troubleshooting this?

Doesn’t look like there was a new update this Friday. What’s the point of the replacements if it’s suspected to be a cloud issue (I’m assuming since rules and quick run work)?

Same issues here. Probably for the past year or so. If it helps. About a month ago it was working fine. But then i manual skipped a day to mow that morning and it stopped working. It started saying it was soaking for 23 hours a day, so i tirned of soak cycles on the schedule and it just started to skip days and told me it would water the next morning, then never did. Endless loop of mo watering. Have set up rules for now but definitely considering moving away from this product. I bought this to make watering easier than a “dumb” controller. Now im having to monitor and do things more often… pretty ridiculous

The part that really kills me and I don’t understand is that this issue has gone on for a very long time and it appears to just be a code problem. I know those are not easy to fix always but surely after a year there should be some progress or at least signs of active troubleshooting.

After reading the thread and trying various resets and making new scheduleas on my device i also am convinced this is a code/firmware bug.

So I originally created this post in Jan 2022, but for the last two months it’s actually worked for me. Haven’t changed anything and afraid to, but my summer schedule is running well