Sprinkler Controller Somewhat Erratic Behavior

Recently I had had my Schedule disabled. I then enabled it yesterday PM. It should have run at about 4 AM in the morning but it failed.

I then had to run a quick time on all five zones and they worked fine. Would anyone have any thoughts as to why the schedule failed?

When there is a failure like this is there any way to to run a Quick Time collectively instead of have to step thru the zones one by one?

When you first open it, there should be a water drop icon on the bottom right before you select any specific zone. That one allows you to select all the zones at once and quick run them.

As for the schedule failure, it seems there is a bug they are looking into. They posted an update about their efforts to it yesterday:

As far as the schedule issue goes it has been functioning properly in regards to disableing and enabling.
Has there been an App update that could have caused this issue?
Is part of the scheduling in the cloud or is it entirely on my phone?

I believe it is on the cloud because there is a setting for “Offline Schedule” which implies that the other schedule is cloud-dependent.

Where might I find an example of a rule for this issue?

To set up Zone Watering as a scheduled rule, you can do the following:

  • Open your app
  • Select Account Tab
  • Select “Rules”
  • Select the “+” sign on the top right to start a new rule
  • Select “Schedule”
  • Set the Start Time and Which days you want it to water a certain zone
  • Select “Add Action”
  • Select your Sprinkler Controller
  • Select “Start Watering”
  • Choose a zone and how long you want it to water that zone.
  • Save the rule.

I don’t know what happens if you choose several zones within the same rule though. I have never tried (I personally don’t use a schedule, I just let the AI choose when to run my sprinklers based on the saturation level, and that works great for me). I would probably recommend scheduling a separate rule for each zone to start a minute or so after the previous zone is scheduled to stop running.

Thanks, if you can perhaps you could make a posting to this string when Wyze has the “schedule skipping days issue fixed”

1 Like

If rules are in the cloud could they not end up in the same situation as “Schedules Not Running”?

Certainly. I submitted this issue to the fix-it-Friday event, even though it’s not actually affecting me, just to help out the rest of you. And I have been copying in the weekly reports about it. So I’m sure I’ll continue to post any updates, unless someone else beats me to it. Jason, the Wyze employee, has also been posting in here. Either way, I’m sure any updates will get posted for anyone following this thread. :+1:

That is some good thinking, however, the rules were run through an entirely different system than the device schedules. So whatever bug is affecting the device schedule code has never affected any schedules being run on the Rules Engine. They appear to be separate things.

However, if a person is having constant Internet connectivity problems, then, yes, this could be an issue for those people with bad Internet. However, if you setup your "offline schedule"in the app to match the cloud rule schedule, then it should still execute the same watering schedule even if there are connectivity issues involved. So either way, it should be fine.

Tests so far have also been successful using the rules engine instead of the settings schedules. So it seems to be a successful workaround by all reports.
Hopefully they can still figure out the root cause.

I decided to add an additional day (today Tuesday) to my schedule and viola, my schedule ran this morning. I will take out the added day (today Tuesday) and see if it runs tomorrow as I have it set for M-W-F.

My schedules are back to functioning as they should.

1 Like

That’s GREAT to hear!

Is that because you switched to rules, or is that with your original schedule through the Sprinkler UI schedule?

If through the sprinkler UI schedule, keep an eye on it for a few weeks and make sure it is consistent for you again. I have heard of some people say that they have had it skip sometimes but work normal sometimes. So it’s good to watch and make sure it wasn’t just a fluke. Though maybe the bug has to do with a day of the week or something and making that change fixed it for you. IDK.

If you’re using rules instead though, like we discussed above, then it should be reliable, because that’s been working for everyone so far.