Wyze sprinkler issues

As some others have posted I am also having issues with the sprinkler controller. It functioned as expected for time and I believe it was after a firmware update it started having issues. Whether scheduled or run manually the controller will turn on a zone for about a second and then trun it off and it is like it deletes the instance immediately. Unplugging the controller will remedy this for a short time and then the behavior returns. I have checked and rechecked everything I can, disabled skips, you name it. I hope this post helps bring more attention to the issue and a remedy can be found.


I am having a similar problem. I spoke with support several times and they have stated and I can confirm the reason is the firmware update. Any time an update is applied you need to delete the sprinkler from the app and then readd following the instructions. This gets me back to running until the next firmware update. But I lose all watering history.
This is totally unacceptable. For one thing we live in a very hot climate where not watering for even a day or two has very bad consequences. We are also away sometimes for days or weeks so physically resetting the sprinkler is not possible until we return and by that time plants and vegetation have died. The whole purpose of an automated system is just that automation! If this continues we will need to pull out this system and install something else. Does Wyze have a workaround or solution for anytime there is a firmware update? Especially when they imply the update is a necessity and your system won’t work after a particular date if you do not update etc. This is becoming very frustrating.


Thanks for that. I deleted and re-added the controller and hopefully that will get me back up and running. At least I can delay the update until a convenient time for me to delete and re-add the controller assuming it works out for me. Hopefully given a little time maybe the nerds at wyze will sort this out. I can’t complain too much this device is a fraction of the investment of wifi connected controllers that don’t have as much functionality. I’m sorry it is affecting your situation so severly.

I have this issue too, tap the water button, the sprinkler watering 2 seconds and then turn off automatically. I reset the wyze sprinkler controller, this issue still happened.

Make sure you actually delete the sprinkler from the app and then re-add following the steps. Just pressing reset won’t be enough. I’m getting quite concerned. We are already experiencing 90F+ degree days here. If we are not home for several days this will be a disaster. Would really like to see someone from Wyze state they are actively working this problem. I am starting to look for yet another control system. If this is still a problem in another couple of months we will need to switch to something else.

Update for anyone following this thread. Firstly I agree with Simcheck, it would be nice to hear from Wyze that they are actively working on this problem.

I had tried deleting the device from the app, while the device was unplugged and reset, several times. The behavior would return immediately or just a little while after everything was set up again. My last instinct was that something in the device was persisting with only a short power interruption. I unplugged the device and left it overnight, since then (several days) function has been normal. It could be that is something others might want to try.

I removed from the app, reset the unit to factory defaults, reconfigured, and it started working again (just like power cycling resolves this issue), until it broke again later that afternoon. I finally grabbed one of my smart plugs and put it inline with the transformer powering the wyze. I have it power cycle the unit at midnight every day. After power cycle, the unit works normally. Wyze support is less than stellar, they were quick to push an RMA without even listening to us here on the forum.

The bad behavior eventually came back. Guess I will see if a Wyze plug will fit in the sprinkler box.

Mine has flat out stopped working. Each zone will fire up for a few seconds, then shut off, regardless of power cycling now. Even scheduled watering doesn’t work. I’m certainly at my wit’s end with it considering it’s a week old.

I guess I should be thankful that I can still reset mine. But it keeps dropping out every few days now. And it no longer seems to coincide with software updates so that theory from CS doesn’t hold much water anymore (pun intended!). I plan to call CS on Monday as a last resort. But very disappointed that no one from the company even acknowledges the problem here and no indication this is on their radar as something that needs to be fixed. We are rapidly approaching the time where even a day or two without watering will be disastrous here. And will often be away for several days or more so resetting is not an option. Looking for recommendations of a solid system. Don’t need a lot of bells and whistles. Just needs to work. Rain Bird kept dying but that was a known WIFI issue. Arghhh

I just got my controller 2 days ago. Worked fine for the first few tests. Then… the same issue here, the Zones work for only a moment. I went through the resets, power cycling, deleting and reinstalling the controller from the app. Called tech support yesterday. They are sending me a new controller. We will see. In the meantime I am getting a cheapo non-wifi to put in its place. Need to water my new sod.

Same issue and was thinking it must be something I am doing wrong. Nice to know I am not the only one. Several calls with CS and new units sent out (using 2 of them) and sure enough, works when you first install or power cycle, next day only turns a zone on for a couple seconds. Will try the firmware update then delete it hack and see how that goes. had high hopes here as I use several other products but this one might be the Wyse Edsel…

Sounds like same issues as described here → Can't get sprinkler schedule to work

There is a reply from Wyze in there addressing a potential fix.

1 Like

I just got off the phone for the third time. They put me on hold while they talked to engineering. Said they were working on a fix and should expect something in 48-72 hours. Wanted me to run a third party wifi sniffing routine. I couldn’t even get it to load. Plus I read some of the reviews of the app. Big invasion of privacy. It reports everything on your network etc. I have full signal strength at 2.4ghz at sprinkler which is about 6 feet away from wifi router albeit on other side of drywall. I don’t have time to mess with this app. Hopefully they will produce a firmware fix very soon. This has been going on for months with me. Have not been offered a replacement but from all the comments doesn’t sound like that will fix anything anyway.

I can wait 72 hours, but I can’t keep waiting 72 hours, for another 72 hour excuse. I’m a huge fan of Wyze, but the lack of support (besides sending a replacement controller that doesn’t fix anything) makes it hard to recommend their products to family and friends. A bit of transparency goes a long ways.

1 Like


Follow up post. Installed the 2 units. Firmware at 1.0.4. deleted from app completely. Turned off units for 4 hours. added back to the app. Only setup a single zone nothing fancy no schedules nothing. worked as expected. left over night. turns on for 2 seconds. turns back off… power cycle and they work as expected again. I happen to have 2 extra Wyse plugs. Looks like I need to replace the plug and maybe try the power cycle every night trick if there is no firmware fix for this.

1 Like

Since my last post (several days ago) I sent support an email on the issue, would suggest everyone having problems contact them in some way. Maybe that will elevate our cause.

@virtualmarshall - I have a smart plug that cycles power to my controller every night, and doesn’t resolve this irritating bug. Mine worked great upon setup (Mine arrived less than two weeks ago, so is very new), but then started this issue everyone else is posting about on 1.0.4. Even a power cycle doesn’t seem to bring it back to life most of the time any more. I’ll try a full reset again tomorrow and see where we end up.

@badsr71 well that sucks. sent email to support with video and pictures and added vid to other thread. Will give it a couple days and then order a rainbird I guess. Had high hopes for this one…