Alexa Integration issue?

Until very recently, I could use my Wyze cameras to “filter” motion detection to specifically Person Detection only. This made it so I could have the lights in my office turn on ONLY when a person is detected, vs. our cats which don’t count for “pet immune” motion detectors because they jump into chairs and on top of tables etc.

Now when I go into Alexa to set up any routine for Wyze, it basically just blanks out. I have to cancel the request or the app itself crashes. Granted, the routine I have set up still works, but I can’t set up any new ones based on the same criteria. Is anyone else having this issue?

I tried disabling and re-enabling the Wyze Skill as well as deleting and re-downloading the Alexa app.

Steps to recreate issue:

(I’m on iOS 15.4.1, iPhone 12 Pro Max) Alexa ->More->Routines->±>under When this happens, use: Smart Home and choose any of your Wyze Cameras. If what’s happening to me happens to you, the screen will blank and nothing will happen. I’ve even waited a few mins. You can touch cancel or another button to get out of there.



Hi @neoprimal,
I have tested your scenario. I am also seeing the same results

iPhone 12 Pro Max 15.4.1
Alexa 2.2.471115

I have all Wyze cameras except the V1 and I am experiencing the same results when trying to select any camera.

I also have all of the other Wyze devices and this only seems to happen when selecting a camera.

Not sure if this is a issue with Wyze or Amazon but instinct tells me Amazon.

A good place to start in this matter would be to create support tickets on both sides.


Android 11, Alexa version 2.2.456504.0

Confirmed fail.

Additional info: Does NOT affect routine build for Wyze Contact Sensors, Wyze Motion Sensors, other brands of IoT hardware linked skills, or Echo devices. It ALSO does not affect Alexa Routine Build for my VDBv1 Doorbell cam

The lockup only occurs when I select Wyze Cam V3 or PanCam V1 (don’t have others to test).

Time to light up the bat signal.


@R.Good and @SlabSlayer

Thanks much for the confirmation!

I’ll see if there’s any place I can go to through Amazon.

1 Like

Little late to the game, I also confirmed that both Android and iOS are having the same issue but presents differently.

1 Like

From Amazon Support Agents regarding this issue.



Great update. Thanks for doing the legwork.

But :thinking:… How do we provide support for Alexa Support? And who supports us while we are supporting them? I am so cornfused.

I have the same crash issue when setting up a new routine with Smart Home and a wyze cam. I have V2 and V3 cameras and I can’t select any of them. Any new update on the fix?

Welcome to the forum @lbeauvil!

I have been checking this daily and have not gotten back a response from Wyze or my Amazon Support ticket at this time.

Where I am more so awaiting Amazon’s response.

Just for awareness. I am a Wyze product user myself and not a Wyze employee, but a community volunteer and have no additional insight to the issue other than what I get in response to the normal support channels.


@R.Good got a response from Amazon several days ago.

They’ve updated the app 2 times since I noticed the bug but there’s still no fix for the Wyze issue atm.

Just have to be patient and wait it out I guess for now.

The good news is that the old routines still work. The bad news is that we can’t make any new routines for Wyze cameras right now.

Same problem - can’t add routines for any of my v3 or v2. App just freezes. Doorbells work though.

I submitted this issue in this months fix-it -Friday. The Wyze team is looking into it. See info below, You can watch the below thread for updates.


Same issue here, I’m just commenting so I can watch this thread for updates.

Why after a month has this not been fixed? I just installed smart switches, so it was time to write Alexa routines. Alexa sees the cameras but you can’t select one for a routine. The screen freezes in the app, you can however hit the home screen in the app (android) and get out of the screen. It doesn’t crash, it just doesn’t work.

I also have the exact same problem of the screen blanking out when trying to select any Wyze products within the routines portion of the Alexa app. I have an iPhone. Please share if this problem ever gets fixed……sure has been a long time. I’d honestly expect better from Wyze and Alexa.

I have the same problem along with a whole host of other issues
ever since the AWS outage in Jan/Feb I have no person detection on one of my V2’s not in Alex or in the Wyze app , also the same one V2 camera stopped working with both Alex and Google at the same time , and I noticed that Google does not show up in the account tab of the Wyze app under smart integrations , only Alexa shows up now, I do not have person detection announcements for the one cam in Alexa but all my other v2’s and my pan work
I can not see the live stream in the Alexa app for that same one cam and if I ask Alexa to show me the camera on any my devices it won’t work (echo show 8, 3 echo dot 3rd gens paired to 4k fire TV sticks) however the strange thing is that if I ask Google to show me that one camera from my ’ Google home hub it doesn’t work but if I ask Google to show me that same camera from my Google home mini pared to a CC with Google TV it will work, it also works from the mic on the CC remote too.

So ahs anyone tried to use the Alexa web interface to create the routine , (not even sure if that is an option from the web interface.)

This is very upsetting and Wyze support is denying me an RMA too, yeah my camera is out of warranty but there is nothing physically wrong with my camera , this is all on their end in their cloud/servers , not my fault
I had to buy a new camera to get person detection and to get the camera to show in Alexa
and now I find out that I can not even recreate my routine to have Alexa stat streaming the camera on my echo show when A person is detected .
been 5 months and nothing is being fixed, in fact it is only getting more broken

I keep watching this thread in hopes that the Alexa routine ability with the Wyze cameras will be restored. Sadly nothing has changed. Today I reached out to ALEXA support and customer service didn’t show any previous problems but she listened and I demonstrated the “routine issue with the blank page after choosing the Wyze cam under smart home” said she would send it to their technical support team. I figure the more we reach out to Alexa and Wyze the sooner this will get fixed?

1 Like

I just updated the Alexa app and the integration with the Wyze cameras in routines appears to be fixed.


What was the version and what type of device?

Also confirming an update on iOS to version

Resolved this issue.

Thank you for posting your findings @Eg22

It’s fixed for me too! Tried on existing app and it didn’t work, then upgraded and it worked!

1 Like