After firmware update cameras don't connect anymore

Yesterday, I updated firmware on six cam 3 and it updated only four.
Two of six have failed to update firmware and can’t connect to the local network anymore.
Reset cameras and router didn’t help. I reset one camera with updated firmware and it reconnected without issue. Looks like firmware update corrupted network portion on two cameras.
Anyone has the same problem with the latest firmware update process?


What v3 firmware version did you update to? I am on and no connection issues. Here is a thread discussion on the latest v3 Beta firmware.

If the cams are no longer online and won’t reset, they may have received incomplete update downloads or installs. The only fix for this is a manual flash if the firmware.

1 Like

My Wyze Cam V3 is having the same problem. I’ve done everything that could be done and nothing works. Support is a joke with it’s Chat Bot. After it told me to do everything i’ve already done it had me send an email explaining everything all over again. Good luck, I don’t really expect any results for myself.


Welcome to the Wyze User Community Forum @DeepSouthTech! :raising_hand_man:

Customer Support does what they do. There are topics here in the forum to discuss those interactions if you need to.

Here in the forum, I find quicker solutions from users helping other users. Most here have already experienced one kind of issue or another, perhaps multiple times, and found a solution.

So, by “having the same problem”, your V3 tried to firmware update but then went offline, won’t reboot after a power cycle, won’t factory reset, won’t enter a setup routine, and is generally unreachable.

What happened after you flashed the firmware manually?

1 Like

I apologize for my rant in this thread. I have been with Wyze for a few years now and this is the first time I’ve encountered a problem all while still using my original Cam v3. After doing a reset on the Cam everything goes smoothly until I get to the part where I try to connect the Cam to my network, thats where things fall apart. I have the same Router and Password that I’ve always had but yet the Cam announces that it can’t connect to my network. I’ve received another support email that differs slightly in what I’ve tried. I will try that and hopefully it works. Thank you for your quick response.

1 Like

Depending in the router you are using, you might try disabling the 5GHz network to force your phone to connect to the 2.4Ghz. Another possible benefit might come from power cycling the router, leaving it unplugged for 30s.

1 Like

Same problem here, updated firmware (demo_wcv3.bin) on Cam v3 and none of my cameras will connect. Tried manual flash but can’t get the purple light following the flash instructions. Camera wants to connect but can’t. I am not restating my router. What does Wyze have for this issue?


Are you using a blank 32GB SD Card?

I’m also having a problem with the manuel flashing process. I follow all the directions exactly but it goes to the setup process instead of light turning purple and flashing. I have also restarted my router numerous times and it makes no difference, it still will not connect to wifi. Very limited to what I can do with the router thanks to it being a cable company modem/router.

1 Like

As for me I am using a 64GB SD Card. It’s the same one that was working perfectly in the Camera itself. I reformatted the card to exFat by default before adding the unzipped file to it. The Cam still will not flash the software.

I would try following the steps in the 2nd post on this thread by SlabSlayer. It is somewhat tricky to manually flash.


Firmware flash will not work with a 64GB Card specifically because it is factory formatted exFAT.

Firmware flash in exFAT is not supported. While the cam can read from and write to exFAT AFTER the firmware has been successfully loaded, only FAT32 can be used for the Firmware Flash. That is why I posted to use a 32GB card because they come factory formatted FAT32.

Once a Factory Reset has been performed, router resets are pointless since the network credentials and the cam link to your account has been erased on the cam.


I just wanted to let you know along with everyone else that after getting a 32GB SD Card I finally succeeded in flashing my Cam. I made sure that it was formatted as Fat32 before adding the firmware and that made all the difference. It is now updated to the latest firmware and working like a charm. Thank you very much for your assistance,


Yes, I had the same problem. I tried the update for all cameras. One update failed and then that camera would no longer connect to the network. If they are destroying their own cameras with their updates, they should give us new cameras.


It is more likely that during the OTA file download of the firmware to that specific cam, the network lost connectivity with the cam momentarily and packets were lost during the transfer. The quality of the firmware is moot if the cam never gets the full package due to network WiFi connectivity loss.

To recover a cam that exhibits this, manually flash the firmware.

Very good! Now put yourself in your customer’s shoes. I don’t can what software, firmware, hardware, kitchenware did what to whom. If you are screwing up your customer’s cams, you should fix the problem.

Care to translate “manually flash the firmware” into terms we stupid laymen might understand?


I am in the customer’s shoes and have been wearing them daily for a very long time. I do not work for Wyze. I am a customer just like you and have had firmware updates fail because the cam lost connectivity. I do bulk updates on several dozen cams at once and occasionally, one doesn’t get the entire update. When this happens, I manually flash the firmware. It is the only way to get a complete copy onto it since it will no longer connect to get an OTA update.

It is also most likely the same suggestion that Customer Support will give you.

The update most likely isn’t the issue. More likely it was a loss of connectivity on your network during the update download process.

If the cam will not log into the network, will not enter a new setup routine, or will not factory reset, a firmware flash is the last resort.

Download the firmware, transfer to a blank 32GB card, unplug cam, insert card, press and hold setup button while plugging it back in and wait for the red\blue=purple lights


OK, I’m sorry I called you a post-pubescent nerd that eats zagnut candy bars. I guess I’ll learn about flashing my camera’s firmware.

1 Like

No offense taken. Since I am nearing the end of my second full retirement, I often get frustrated with the youth and their new fangled social technology. I am one of those old school nerds though. But there is absolutely nothing wrong with a Zagnut Bar! Those things ROCK!

If you have any questions or issues with manually flashing, don’t hesitate to ask. Tons of users have done it successfully and are eager to help.

1 Like