Wyze v3 beta firmware update (v4.36.3.19)

I seem to be having a number of abnormalities with my Wyze firmware/hardware lately… One with the recent beta update to the Wyze v3s, and one that seems to be happening with my Wyze HMS base that I believe may be hardware related (I will post that in the appropriate thread).

I received a notification a few days ago to update my 6 Wyze v3s to version (not .18). I don’t recall my previous version unfortunately, but it was not the .18 version. I chose to update all of them at once. I have 4 in my own home and 2 at another remote location (different city, obviously different network).

The ones on my home network have ALL become inoperable, while the 2 remote cameras successfully updated to They were all running the same previous version prior to the updates. As for the ones on my own network… They all showed offline within the app, but clicking on them would bring in the live feed. If you tried to change any settings, the system would tell you the camera is not connected. Yet I could back out of the settings and still view the live feed.

I started troubleshooting by removing all of the cameras from the camera group, and then completely removing one of them from my Wyze app. I removed the SD card, and performed a full factory reset on it (following the Wyze guide online… holding the reset button for 15-20 seconds then allowing some time to reboot). After rebooting, I hit the reset button and it says ready to connect (once, not repeatedly)… but then it would not scan the QR code when attempting to add it in the app. After approximately 4-5 minutes, it would start repeating “Ready to Connect” after which it would successfully scan the QR code, and go from blinking red, to blinking blue, and then blinking red again. It never connects to the network, and in the app, it says failed to connect. I then removed the other 3 v3s from my app and tried to connect them, with the same failure to connect.

Based on the prior troubleshooting, I have to assume there is an issue in the updating of the firmware, and I may need to manually flash it. This is the point I’m at right now, and I will provide an update if it updates and connects successfully.

1 Like

I struggled with the exact same problem 3 days ago. I power-cycled all v3s and it seemed to work. Alas, it lasted less than a day. After running through all the attempts you listed, I resorted to flashing half of my v3s this morning (14 of easiest to get to :neutral_face:). The only way I got them back to “normal” was to flash back to After flashing, for each cam, one at a time (don’t do bulk update), I ran through the 3 incremental updates that ended with They’ve been running all day and night. AI is back, no more app reporting cam is offline. I’m pretty sure the key is is essential and without it (directly jumping to or later), critical libraries are either out of date or missing. I have all 14 simultaneously live streaming and will leave them running until tomorrow. If the problem hasn’t resurfaced, I’ll update the other 14 similarly. Not looking forward to getting up on the ladder and making a road trip, but it is what it is. :upside_down_face:


Based on some other replies here, I had reached the same conclusion, there must be something critical within the .18 that is a prerequisite for the .19 update… would be good to hear from Wyze to know they are aware and working on a solution. Thank you for providing the steps you took as well, I will start my process tomorrow.

1 Like should include all essential, new and updated libraries contained in, but it doesn’t. :confused:

For each cam, after flashing to, go into the cam’s settings > Device Info > Firmware version. Tap the version and it will update to Repeat and make sure it updates to Repeat and it will update to

If for some reason my v3 cams are not working perfectly tomorrow, I’ll make a post here in your forum topic.

It would be nice if they brought back the option to downgrade firmware on the beta app


So far this morning I’ve had no success manually flashing the older firmware. I have to assume I’m doing something wrong but I’m following the instructions per Wyze’s support site.

I downloaded the firmware that you linked in your comment, extracted it, renamed it to demo_wcv3.bin, unplugged the camera, and pressed and held The reset button as I plugged it in. According to the instructions the light is supposed to turn purple after 3 to 6 seconds. I held it for over 30 seconds and nothing happened. It only said that it was ready to connect. I tried holding for 3 to 6 seconds and releasing, and the red light would simply blink indicating that it was ready to connect. I can’t seem to actually get the purple light to come on… ie the red and blue lights together.

My next assumption is that perhaps it’s looking for demo.bin but I’m not ready to try that just yet.

it’s been awhile since I’ve manually flashed a v3 but renaming to demo.bin is worth a try

The 14 v3 cams that I flashed yesterday have been live streaming for over 24 continuous hours with no problems… AI events and notifications are working, no offline issues, perfect. I’m headed out to flash the others. :+1:

v3 cams definitely need “demo_wcv3.bin” for a file name. Make sure you extract the .bin file from the .zip archive before renaming and copying to your card. Make sure you are using a 32GB (or smaller) card. Make sure the card is formatted as FAT32. Make sure “Hide extensions for known file types” is off or you’ll unknowingly end up with “demo_wcv3.bin.bin”. Make sure you feel a click when you push the reset button and before you plug into power. If it still isn’t working, try deep formatting your card. I use “SD Memory Card Formatter” from SD Association. Make sure you select Overwrite Format vs the default Quick Format. All of this assumes you’re using Windows. If you’re using a Mac let me know…


What version did you flash yours to?

Flashed each v3 to, then incremental updates via cam settings > Device Info > Firmware version to, then, then

Thanks, I will need to try it this weekend sometime

1 Like

OMG what a rookie mistake lol… I can’t believe I missed this…

I had not considered since of the steps you mentioned, and I can truly appreciate the process you listed as it helps identify potential conversation words others may have.

In my case, I had done a quick and dirty conversion, much like I’ve done it in the past, and it’s worked fine… I didn’t feel like trying to track down my SD card adapter, so I downloaded the zip file onto my phone, extracted the files, renamed it, and put the files onto a 64 gig micro SD… Perhaps in my haste to get the cameras back up and running, I renamed the folder instead of the actual bin file and placed the folder on the SD.

I just found the folder that I renamed on my phone and opened it to find the original file name on the bin file. I’ll rename the bin file and flash it tomorrow morning. This is what’s great about a community forum is because it helps you sometimes realize the tiniest little mistakes that you may have overlooked. Thanks again for all your help.



Just wanted to follow up on this topic…

I’ve actually been busy with some things at work and I wasn’t able to get to the bottom of this issue until today.

Despite having a 32GB SD card, formatting it as suggested above, and using the firmware version mentioned above… I could never get the camera to reset. That is to say, I have the same issue with all four cameras.

On a hunch, I downloaded the initial release firmware and flashed it using the above method. I then went to a different house with different Wi-Fi. Went through the reset and reflash process, and everything connected immediately. I then went through the update process within the app, and it updated through three different versions until it was up to date.

Once I took the camera home I tried connecting it to my own home Wi-Fi. I ran into the same issue of never connecting. Now my Wi-Fi has both 5 GHz and 2 GHz signals. Same name, same password. I’m sure it’s not password length, as I had that issue in the past with a wyze outlet. My password is 16 digits, but it has uppercase, lowercase, numbers, and special characters (as does the other Wi-Fi that did work).

I believe that I’ve narrowed the problem down to an issue with one of the special characters in my home Wi-Fi password. My SSID is a very simple name. So my question is, are the Wyze tech gurus aware of any special characters that would cause an issue within the password?

While waiting for a reply I’m going to try the only other option I can think of, which is to temporarily manually shut off the 5 GHz signal, in case it’s causing an issue.

I have the M9 Deco Plus Wi-Fi mesh system. I went into the settings disable the 5 GHz signal and allowed my phone to disconnect from Wi-Fi and then reconnect the 2 GHz. Then I tried adding the camera again. I can confirm it did not connect and continues to suffer the same issue.

At this point for me at least it seems to be a connectivity issue and I believe it’s coming from a password character. It’s the only thing I haven’t been able to hammer out. Short of having to change 40 plus devices in my house with a password change, I will wait patiently to hear any suggestions if there are any known issues with special characters.

Update #2.

My router supports both 2 and 5 gigahertz bands and a guest Wi-Fi with both 2 and 5 gigahertz.

While my main Wi-Fi password contains an ampersand (&), percent (%), and dollar sign ($)… My guest Wi-Fi only contains an exclamation mark (!).

I have tried connecting with my phone and v3 on both networks, both passwords. All in the 2 GHz options. No connection can be made at my home. I’m really confused by this because they were connected to the original main Wi-Fi with the same longer password all along without any issues until the update that caused all of this.

Update #3


… and I’m kind of an idiot…

When I initially connected the Wyze cameras to my network I assigned them to the group called Security Cameras. All of my devices on the network fall into certain categories. Each category controls what connectivity is allowed for those devices.

When the initial update happened and the camera stopped working, I had paused the internet connectivity for the Security Cameras group as a safety measure to prevent potential intrusion.

Well, you guessed it. I forgot to re-enable the internet. As soon as I did it connected immediately to my existing main network.

Once again thank you to everyone who offered up there experience and suggestions. The community here is what makes Wyze so great.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.