New v3 Firmware issue

Dang. After being nagged repeatedly to update the firmware by the app, I finally did it, knowing I shouldn’t mess with it if everything’s working fine. Now 6 of my 8 cameras are having connection issues. They’ll connect sometimes, and then die with the connection error after a few seconds, or they’ll just not connect at all. Power reset multiple times didn’t help.

Now I guess I’ll have to manually roll back all the cams to the previous firmware. SO FUN. Climbing up and down ladders and waiting to flash.

Wyze: I love your products and always recommending them to friends but I need you guys to be a bit more careful with these updates!

1 Like

Did you try rebooting the WiFi/router?


Yep, already tried. Unfortunately did not solve anything. The cameras are actually spread out over 5 different routers on different areas of the building so they all have strong signals.

I’m having the same issue. Since my cameras auto updated to the latest firmware they have been suuuper flakey, spending more time offline than on. It’s incredibly frustrating

Have tried changing WiFi channel, rebooting the router countless times. Nothing seems to help and it’s random when they connect again.

So, can anyone help me me with:

A) how to roll back the firmware, and;
B) turn off automatic updates

if you find out how to roll back firmware let me know also.
for over a year i have been donating money to wyze R&D. I think the money i have been donating probably has gone to pizza and beer.

so fed up with Wyze and the latest crap about not supporting android version 6 and below. This is the ONLY company that is causing me to do this.

I don’t want any new features. I am perfectly happy the way things were a month or so ago.

1 Like

You can download the previous firmware from here:

And follow these instructions to flash it:


thank you. i will give this a go.

Also, do you happen to know how to disable automatic updates? I’m pretty sure I didn’t approve for my cameras to be updated to the latest firmware and would like to stop this from happening again in the future.

For firmware updates it does not do it automatically, a pop up will appear when the cam connects saying there is new firmware available. It is possible to accidentally hit this, but you can select the check box that says ‘Don’t Ask Me Again’ next time it pops up


It is wierd how some people have issues like this with updates, yet others, like myself, have had no issues with the latest update

And this is why I don’t update things unless there is a darned good reason. It’s not broke so why fix it…

Wayne, you have Wyze App: iPhone/iPad. And probably can upgrade to the latest version and new hardware. I for one do not have the latest phone. I use Android and my version is 6. I don’t need a new phone nor can I afford a new one. And my phone is no longer supported. (original nexus 5). So with Wyze’s dumb move to not support Android less the version 7 does make a difference. So some of us do have issues with these updates, does that make any sense to you now? I hope so. I can not be the only one in the world with this problem. If I am, then maybe Wyze should send me the latest iPhone so that the products of theirs I purchased can get the latest updates of their software.


I understand, I am just making a statement how it is odd that some people have issues while other do not. For example, my V3 cameras are working flawlessly while lots of other are having all kinds of issues.

You can buy a refurbished Nexus 6p for $30-70 these days on e-bay & Amazon.

The Nexus 6p I have is running Android 8.1, I use that old smartphone for just a Wyze Cam monitor when I retired it. Even Android 8.1 is kind of slow compared to newer phones on Android 11

Also, usually Android phones stay on old versions because carriers lock them to force hardware upgrades. If you have a mainstream old phone or tablet, you can flash to the latest Android by looking for replacement ROMs from freeware sources.