V3 offline after firmware upgrade

I was able to upgrade firmware for 3 out of 5 Wyze v3 cams to the latest version **[]
The 2 that failed the upgrade, do not want to connect to Wi-Fi anymore.

I have tried to reconnect the cam to Wi-Fi by doing the setup again and it wont connect.
I have also tried doing the manual firmware upgrade by installing the file “demo_wcv3.bin” file on the SD card. That didn’t work either.

any assistance would be greatly appreciated.


1 Like

Hi @elvinchokie welcome to the community. Sorry to hear of your struggles.

It sounds like you did some good standard troubleshooting that I would’ve recommended and done myself in that situation. Since you already attempted setup and a firmware flash and it still didn’t resolve it, I would recommend contacting support. They will tell you to do some things you’ve already done, but just get through it so they can create an official support ticket about this issue. Also keep us updated on what they tell you.

One thing I might suggest is to make sure you use a 32GB SD card with FAT32 format with nothing else on it when you try a firmware flash. I have heard sometimes they get picky about flashing better with cards that way. IDK why.

Does your camera status light still come on at least? Does the camera make noises when you reboot it? Those will be good signs that it can probably be revived.

I have several Cam V3 up and no problem installing them all originally. Using Google then and the same network now. I updated one of the cameras and it will no longer connect. The 2.4 and 5 connection issue has never been an issue UNTIL this recent Firmware update. Ready to junk them all and buy something that has no such issues. I have over 25 devices on this network from a variety of makers and have had zero issues connecting. This does not point to my network, it points directly to the firmware update. Can the firmware be rolled back?

Hi Carverofchoice
I have emailed support, waiting to hear from them.

I used a 128 GB SD card formatted with FAT32 with the BIN file, does 32 gb matter?
One of the cameras blinks red and blue after I tried loading the bin file, that is all it does now even after rebooting.
With the other Camera, I did not do the bin file, just has a red light and won’t connect to Wi-Fi.
Both of them make noise when rebooting.

I will keep you updated.

Hi Lostjohnson
25 cameras is alot.
I have email support, waiting for their reply.

I have not tried doing a rollback, but a good idea.

will keep you posted


Yes, absolutely required for firmware updates. 32GB or smaller.

1 Like

32GB card or smaller in FAT32

1 Like

Sorry, it’s not all cameras. 5 total. Other items are outlets, lighting, security, etc. None of my devices have ever had a problem sorting through the networks in question and without effort connect this mesh net. Evidently more than a few have figured out how to accomplish this and not resort asking their customers to figure it out. Maybe bring in some expertise and solve the problem once and for all.

I lost 2 cameras in the latest firmware update too. They worked fine for 6 months and are now offline perpetually. I’ve tried everything suggested that can be done, nothing works. I can’t access the cams with the app because they’re not even there according to the app.
If I power cycle them the light is flashing red and blue like it’s trying to connect, but it won’t. I deleted them off the app, but try to setup again and they just tell me “unable to connect to network”
I’m so over this crap. These things last a few months then they brick them with garbage firmware updates, then you have to buy new ones again? There’s no “reset” button on the cams to put them back to factory settings?

1 Like

Which type of camera do you have? Did you download and try to add an older firmware?
The V3 and the V3 Pro both have a button on the bottom to do a factory reset but that will not change the firmware. I don’t have any other plug in cams so I don’t know how the reset.

1 Like

Had the same problem when I updated one seemed to be bricked so I reset everything by deleting the camera in the app restarted the camera and did the whole install all over again, it then showed back up!

1 Like

Can you share the type of network you’re using and are there Separate Named networks for the 2.4 and the 5?

Just using the 2.4 not the 5 but the 5 does have a name similar but different.

I got one of mine working again, the 2nd should work too. Followed the instructions to install the previous firmware onto the SD card and then installed it and plugged in the camera while holding the setup button. Light turned purple and then it was able to be reconnected to my network.
My assumption is, sometimes when doing firmware updates, if one or more decices, and it’s always the cameras, something goes wrong during the uploading of the new firmware and you end up here. Doesn’t make a lot of sense with mine though, since the 2 affected were indoors and closer to the routers they’re connected to than most others.

1 Like

I have one v3 camera looking down on my backyard. For me, this is not a critical location as it normally only catches rabbits going through my backyard. My backyard v3 is the one I will accept new public released firmware on when it becomes available. If the update goes bad (won’t connect, shuddering video etc.) I will live with it or manually install older working firmware.

My other v3 cameras in more critical locations I wait to accept new firmware until I read positive Wyze Forum comments. Threads like this one make me keep my critical v3 cameras on firmware

I am happy with the cost of ownership of my Wyze equipment, but have to be mindful of when to accept newer camera firmware and newer App versions. This is my strategy on balancing updates vs. functionality.


i will try using 32gb , thx

Thanks to all those that provided their input.
The issue is resolved by doing ROLLBACK to version **[].
But you MUST use a 32 GB SD card because it can format to FAT32. The bigger SD card only format to exFAT. That’s why it won’t work on bigger cards.
Then you add the camera back to the WYZE app. I also successfully upgraded to version **[] using the APP.

thanks again


Glad you’re back in business. Maybe they should say 32GB or smaller REQUIRED

1 Like

I agree with you …" recommended" doesn’t have an impact like "Required or MUST "

1 Like