Cam V3 Pro Latest firmware ***BRICKED*** CAMS

Seriously hard to believe. Today I used the latest iOS beta app to batch install beta firmware (at least I think that is the version) on 6 (six) V3 Pros that have worked for the last month without issue. ALL SIX can no longer connect to the LAN. I have no other problems with any other Wyze cams or devices.

As a test, I reset a V3 Pro camera, deleted the cache in the beta app, force closed the app and even deleted the devices in my DHCP server. Yes, everything is on 2.4G WIFI. When I try to reinstall/reconnect the V3 Pro, it gets to connecting to the WIFI and says “Unable to connect to local area network”. I tried several times. Same issue. I tried the same thing using the release app as well, with the same results.

If I take a brand new V3 Pro out of the box, it connects just fine and updates to the latest release firmware

I chose to do beta testing with Wyze ( I test with 5 other HA companies). I get it that stuff happens, but with Wyze its different. No only was the telephone support group completely ill equipped to help, but there is evidently no V3 PRO firmware file available (or procedure) for flashing the production firmware via SDCARD. Unbelievable. This is Beta testing, not Alpha testing.

I have been a Wyze user and Beta tester since day 1. Support from Wyze has always been marginal, but this is the worst I have seen it.

My only option now is to return all 6 cams … I guess if that is even possible.

Beware of the latest BETA firmware for V3 CAM PRO.



For whatever it’s worth, both of my V3 Pro cameras updated to just fine. I did them separately from the camera rather than the bulk firmware update page because only one camera was in WiFi range when I did the first one ( the other camera was in my truck at work). The truck dashcam was updated fine after I got home.

1 Like

Thanks for the info i did the new firmware on both V3,with no issues sounds like you need to flush your wifi/router it sure sounds corrupt

Look at the thread here. This isn’t just him. It’s happening to lots of us:

1 Like

Correct. I am pretty sure this issue has nothing to do with one’s access point or router. I use enterprise wifi 6 access points and a Windows Server for DHCP. Whatever might be corrupt is on the cam side. The V3 Pro’s have worked flawlessly for two months until this update and new V3 Pros without the update connect just fine. We need the firmware image so the cams can be downgraded to the last working firmware or beta firmware.

1 Like

Agreed. Hopefully they respond with a solution soon.

Well if i recall you can only go up in firmware and not downalso do you have 2 SSID setup 1 for the 2.4 and 1 for the 5GHz if not theres been an issue useing a single SSID and its up to the device to choose which one to use

Same problem here, my other Wyze gear still ok but my one v3 pro will no longer connect to
My Wi-Fi, tried many ideas with no help

same issue. i had to put stable firmware on sd card and flash back to it for now

This post just came in on the official Beta Firmware Release Thread for the V3Pro Beta FW. Something to check. Early reports are that changing router settings brings the cams back online.


I can confirm changing my router to wpa2 personal only allows my v3 pro to connect eg turning off wpa2/wpa3. Needs fixings

Great detective work! Not sure who figured out the issue was/is WPA for the cam 3 pros, but kudos!!

I don’t think I want to reduce the level of security on my LAN AP’s to test (as I have WPA3 devices), but I will set up a test network and try to confirm. Based on the comments, I am assuming, where possible, this firmware is trying to use WPA3, but fails.

If it is just a WPA issue, I hope it is acknowledged by WYZE and addressed quickly with a new beta firmware or the ability to load old firmware’s with an SDCard. I’d like to also hear more about what they are thinking with WPA3.

That would be @rsumpy99 in the linked post above who gets the credit.

Wyze is aware and working on it. Follow the Official V3Pro Beta Firmware Release Thread for details. has been available for download and manual flash reversion since its release.

1 Like


I see that the 3468 beta is nolonger being pushed to beta enabled cams. That is good.

Support was pretty adament that there were no procedures for either loading firmware on the V3 Pro using SDCard or a file for downloading the image. Can you send the procedure if different from the V3 and/or point me/us in the direction of the 3210 release firmware file for the V3 Pro?

Thanks again.

Flashing the Cam v3 Pro is the same as Cam v3. Use a FAT32-formatted 32GB microSD card and don’t forget to rename the .bin file to demo_wcv3.bin.

Firmware location (look for section Wyze Cam v3 Pro Firmware): Release Notes & Firmware

Flashing Instructions (look for section Flash Firmware for Wyze Cam v3): How to flash your Wyze Cam firmware manually

This is Beta Firmware actively being tested by users who have willingly volunteered to test it. Since it is test firmware and not Production Release Firmware, Customer Support isn’t going to have any visibility of issues or remedies for problems. Beta testers should already be familiar with reversion protocols.

There is no way to load Beta Firmware by SD Flash unless Wyze specifically provides it in special circumstances. Production firmware, however, is always available for download on the Wyze Support Website.

The link I already provided in my last post does that.


Thanks. I’ve beta tested with Wyze since the first cam.

I am curious, are you saying that the procedure for updating the firmware using an SDCard is the same for both the Cam V3 and the Cam V3 Pro? Also that the firmwares for the two are the same?

I must have missed the link to the V3 Pro 3210 firmware.

Yes. The .bin name is different. But it is a direct copy to the SD root & hold setup on powering, just like the V3

No. The V3 runs on or 4.36.10.xxxx

Look at my post above. Links are in teal:


Thank you!

One small mistake. I believe the file should be renamed to demo_wcv3p.bin (add the “p” for pro).

1 Like

I thought Wyze was a great company as I have many V3 cameras. I bought 6 V3 Pro’s. I wasted so much time with support and horrible e mail solutions. A loop of nothingness from Wyze. I am so DISQUESTED with Wyze company! I will NEVER trust them again! The worst customer experience of my life! Just HORRIBLE!