Wyze Vacuum gets lost and goes in circles

In the last week or so, the vacuum started going in circles like it is lost. Also the map it has been using for the last year or so seems to be corrupted. I just did a factory reset on the unit and tried to get it to quick map and after spinning in circles and bumping into everything, I finally just put it back on the charger. Please advise, is it time for a new one?

1 Like

If the vacuum gets lost it will mess up the map and go in circles like that. If it suddenly started, it could be because something changed in the house. Even something as simple as a box on the floor will confuse it, since it thinks that’s a wall. Try to keep the room (especially the one it’s base is in) exactly the same since it only sees stuff at one level.


I’m having same issue. The vacuum has worked perfectly for a year. In the last few weeks it gets lost against flat walls. The map shows the walls correctly.

It turns in a circle. Then rams into the wall and tries to climb it. It’s bumper sensor is getting pressed but it still powers into the wall. Used to track beautifully.

Did a firmware update create this issue?

Anyone else having issues?

1 Like

Same issue here. Vacuum goes in circles, tries to climb furniture. Both wheels seem to be turning freely. I have double checked and cleaned the sensors to no avail. I was an early adopter and vacuum is out of warranty. Should I take it apart and look for something? It seems like it cant get the wheels to turn in the right direction and speed? Mechanical fault? Computer fault? Help…

1 Like

I have to believe this was part of a firmware update. The vacuum has worked great for almost two years. Now it gets stuck against flat walls…it seems like it can’t track the wall. Also, it ignores its spring-loaded bumper. It will drive hard into the wall and continue to push until it runs up on the wall.

I’ve reset maps a few times (a hassle since you have to re-enter all of the no-go zones).

1 Like

Exact same problem here. Vacuum goes in arcs, half circles and spins only. Tried factory reset, map reset, taking apart as much as poss And cleaning parts and sensors. This is very frustrating. Vacuum is only two years old and essentially useless because it tries to damage walls and furniture. I’ve previously liked all my Wyze products but if this can’t be fixed, I don’t think I’ll be buying another.


Model: WRV200S
Firmware: 1.6.306
Plugin Ver: 2.36.1
Wyze App Ver: v2.38.0 (153)

Well, I finally got one of my Rosies to spin and reproduced it several times and it’s fixed now and she’s happy. Here is what I found and how I corrected Rosie’s “square dancing”… LOL.

  1. I moved the home charging device to another location without remapping it first. Then I told it to go clean! It was like I flipped on her she went nuts Spinning, Hitting walls, and then hitting the home key on Rosie to send her back to the base station. No way Rosie spun around and around for 3 minutes I finally had to shut her down and manually put her back charging… While looking at the map I realized that Rosiees station was returned to its original spot!!! on the map, she created initially on installation.
    The Fix I used :slight_smile: Shut Down App First
  2. Power Vac off and unplug the charge station for 3 minutes then plug in the base first and position the vacuum back on charging base contacts properly for charging. and wait 30 sec.
  3. Now press the power button on the vacuum unit till it powers up and says “Charging” for 30 sec.
  4. NOW! Open the app and make vac do a “quick remap” Once it leaves its base unit it knows where it’s coming from and scans all the rooms and returns with no apparent issues that I see…
    Hope this helps anyone
    Regards, Capt Rob

Didn’t work for me.

Others had similar issues after a firmware update…

One started struggling with a throw rug that it was fine with previously.

1 Like

I’ve had exactly the same problem in 2023. And have spent hours working with Wyze support.
I also asked to talk with supervisors and/or execs and they stopped responding to me.

I think Wyze is a soon to be failed company which makes me sad. I’ve purchased a lot from them in the past and now they won’t do anything to help.

What vacuum would you buy today instead of Wyze?

Even though I have one still working robot, I can’t trust them anymore. How about you?

Unfortunately, there isn’t a product out there to meet my needs either. I’ve been trying to wake people up to this fact however, they seem to ignore any business common sense, and maybe they like to online “talk a lot” I guess it helps them feel better about their purchase of bad products. I am glad you have opened your eye’s to the problems that all are about to ultimately face soon… Company files bankruptcy. Owners walk away with $millions$

Hello. My Wyze vacuum appeared to become a brick as well. It began going in circles, running into the side of the charger. Almost possessed. I tried resets, checked firmware, cleaned the sensor, and still death circles so to speak. Knowing it was out of warranty, I figured what the heck and opened it up. Screws from bottom. Then prying the top off. Sort of played with that as it snaps in place is all. Once the top was off, I began looking at all the connectors. Did not find any loose ones. However, after removing the motherboard to look under it, I found “one” gray wire that had broken off a connector close to one of the drive wheels. The wheel assembly goes up and down so my assumption was this may be the issue. Since it broke right off at the connector, was not an easy repair. After splicing a new wire into the connector, I put it all back together. At least for now, our “Cosmo” seems to be happy again.


Job Well Done! Thanks for the heads up!!
Stargazer II Capt. Rob

Thank you for posting it, I opened it but was not able to figure out about how to remove the wheels except removing springs. I did not remove the mother board and did not find any loose wire or connection. I assambled everything back after cleaning all the parts, but it still has the same issue. It circles around at one place, can’t do a mapping and cleaning. I’ll try removing mother board to check if any loose wire.

You are not alone. Same issue here…

Above got cross-posted, here’s the other thread…

I had the same problem on Wyze robot vacuum. The robot was doing half circles and could still clean the room but looked like he had lost his mind. Overall he wandered and hit walls, even fell down stairs, so I decide to open him up.

There was a broken white wire on the left wheel. Ive used a razor knife and heated it up to cut a chunk out of the termination block. Once that plastic section was removed, I carefully soldered the wire back on. After, I took clear fingernail polish and covered the area for protection and wire strength.

Now my Wyze vacuum robot works like new again! Thanks for the tip!

1 Like