Wyze robot vacuum basically useless after latest update

I’ve had the robot vacuum since June 2022. Everything worked fine until March 16th when I noticed the vacuum hasn’t been running (it was on a Saturday/Tuesday cleaning schedule) I manually started the vacuum from the app at this time. For the next 30 minutes, the vacuum made nonsensical movements near it’s charger. I moved the charger and reset all mapping. The quick mapping was fine (the vacuum went in straight lines to map the house like normal) I then manually started the cleaning and the robot was once again doing circles and other random movements near it’s charger. I then factory-reset the vacuum and went through the whole setup process. I started the vacuum for cleaning, and it once again made nonsensical movements near the charger until I stopped it. I then split the room and told the vacuum to clean a room far from the charger. The robot took a smart, straight path to the room that was to be cleaned. Once the vacuum starting sucking, it lost all control again.

I paid $165 for this vacuum at walmart 10 months ago. Wyze support didnt offer to fix or replace the vacuum, they only offered me a $165 Wyze Store gift card, where the same exact vacuum is sold for nearly $300. What a joke! With so many competitors out there making robot vacuums, I have no reason to ever buy a Wyze product again if this is the support they give customers.


Welcome to the Wyze User Community Forum @ry2m2! :raising_hand_man:

You mentioned that your vacuum recently underwent a Firmware Update that broke the unit. What firmware version is now on your Vacuum?

The Wyze Warranty is a 12 month Warranty:

“Wyze warrants to the original owner of the product that the product will be free from defects in materials and workmanship for a period of one (1) year from the date you purchased your product from Wyze or an authorized retailer (the “General Product Warranty Period”).”


Unfortunately, that same policy also states that:

“Wyze will, at its sole option, either (a) replace any defective product or component, or (b) accept the return of the product and refund the money actually paid by the original purchaser for the product (i) to the payment method used by the purchaser, (ii) as a Wyze store credit, or (iii) as a gift card.”

Did you contact support and specifically request a Warranty Replacement, RMA, and Return Shipping Label?

1 Like

Good morning Slabslayer,

The current firmware for the vacuum is 1.6.202, which the app claims is the latest firmware. Unfortunately the “factory reset” for the vacuum did not revert the firmware to anything else - it remained at 1.6.202.

After the customer service rep offered the $165 Wyze Store gift card, I replied stating that the vacuum is $300 on the Wyze Store and that i want a fix or a replacement vacuum instead of the credit. The CS rep then stated that the vacuum was out of stock on the website and they do not know when it will be in stock again. I was not offered the option to send the vacuum in for service.

I also started noticing this strange behavior. Within the last week or two, when activated, it would slide out of the dock, and instead of starting to clean, it would meander all over the floor, even go into a different room for a few minutes before the vacuum activated.

Have had a similar issue for a bit. Vacuum has one part of the room where it just decides that it’s going to vacuum repeatedly until the battery dies once it passes over it. This behavior persists through factory resets, remapping and its kind of clear at this point that it’s software related. I’m at the point where I’ve moved furniture to try and solve it, have 1 or 2 hail mary’s left until look towards replacing with something else.

Support’s also appears to only be interested factory resetting or giving a gift card.

@JayCee & @bshot1,

Please post your FW Versions.

I am on 1.6.306

The reason I ask is because both of your posts sound similar to what I may have just experienced.

I asked the Vac to start and then went out to the store. I was surprised coming back that I hadn’t received the push notification that it had finished. I checked the app and saw that it was just finishing up.

When I got home, it was still going and doing repeated passes around one chair and repeatedly trying to get under the chair, which it couldn’t do. But it never stopped. Just kept repeating and repeating. I had to cancel the cleaning and send it back to the dock.

1 Like

1.6.202 , guessing you’re on a beta firmware maybe? Here’s a few examples of the odd behavior.

1 Like

I’m on version 1.6.202 with the weird meandering/random behavior.

No. I am on the original firmware for units sold thru Walmart that came factory loaded with the updated Multi-floor mapping FW.

That is why I found the behavior of my Vac odd. I thought from the posts that it may have been a FW issue with the older units being updated, but now I’m not so sure. :thinking:. I will have to send it out again this weekend and closely monitor its behavior.

I did just try to get screenshots of the last run when this happened, but it didn’t save the results. There isn’t even a log in the cleaning history for it.

So playing around a bit more, the only short term solution I’ve come up with is splitting the room around the area it consistently happens. It didn’t fix the pathing in that area (pathing looks like a dumb vacuum), but if part of the area where it loops is split by rooms, it may prevent it from happening.

Heres a screenshot of mine

I also tried splitting the rooms but it did not change anything. As soon as the vacuum gets to where it should start cleaning, it loses any sort of control.

The path kind of looks like the bump or cliff sensors are being triggered constantly. Seems like a firmware issue since it can navigate to the target area just fine.

The other time I’ve seen a mess like that is when the map gets rotated. I wonder if the map rotation bug is still happening inside the robot, but some change to the app/firmware causes it to no longer be apparent in the app’s display of the map. With my old beta firmware, I found that certain places in the house kept causing the map to rotate. Splitting the map did work for me though.

So made one change when cleaning earlier today, removed an area rug that’s been in the same spot for several years and wasn’t a problem before.

Will put the rug back later and try again once the vacuums recharged.

One of the reasons I was thinking the rotation bug was happening to me was because the carpet is not in the best shape (mostly with the padding being flat in areas) causing too much bounce which caused the lidar to scan at an angle. Splitting the room made the robot take a different path that reduced the effect.

The one room I have left that it still happens sometimes does have a throw rug.

Adding a bit from experimentation, putting the rug back triggered the same issue as before.

It’s a rug that’s been present for a few years now and isn’t dark colored (white + blue). Cliff sensors were also cleaned several days ago.

When it goes over the rug, does it suddenly try to back off / go around it?

People suggest some methods to “disable” the sensor in this thread:

I think that’s one way to describe that behavior. Will give disabling the sensor a check.

Printed off the cliff sensor covers and applied them. Doesn’t appear to make a difference at all.

See if you can verify that the fix works, maybe you can pick-up the robot without it noticing now. Some materials are transparent to infrared so adding some glossy tape or foil should help to reflect it back.