Vacuum Mapping Failure

My vacuum fails to use the current map, and always adds extra rooms. In the most current case (see picture) it remapped the entire apartment and just added it on top of the actual map. Anyone else having this issue? Anyone know of ways to get around this? Or is it purely a software thing that Wyze needs to tackle?


Hi @mfmcfarland96 - sorry you are having this issue. Two suggestions:

  • Make sure you have updated both the App and the vacuum Firmware

  • If you are, you can try resetting the map (Settings/ Reset Map) and running a new sweep to remap your entire area.
    Hope this helps!

Same issue for me. Resetting the map helps for a day or two and then it gets all mangled and confused again. Rather frustrating having to reset it all the time.

Mine started doing this about a week after having the vacuum. It’s essentially redrawing the map, rotated, over the top of the existing map. It makes the vacuum unusable if you have virtual walls to block off areas or furniture it can get stuck under, unless you babysit it and delete the map and have it start fresh every single time it runs.

I called and waited on hold for 50 minutes about 10 days ago to explain the problem and get a fix. They’re supposedly replacing my unit. If you want it fixed, don’t wait on an email reply to a support ticket. I’m currently 21 days and counting for a reply to my email ticket I put through.

Just chiming in here as I am experiencing the same condition. Maps frequently are redrawn skewed, spot cleaning goes to the wrong room. The unit can’t find its way back to the charger and wanders around like a drunken sailor bumping into everything. When you look at the app during this condition, the app shows it in the wrong room.

Resetting the map works for a while but it is a bit of a pain putting all the virtual walls back in place.

Model 200S
Firmware 1.6.97
Plugin Version 1.7.6

Submitted a log with screenshots.

I’m curious, did they think it was a hardware issue and not something that can be corrected by a software update? My vacuum started doing the same thing about a week ago. It wouldn’t be that big of a deal but none of my virtual walls work and it can’t find it’s way back to the charging station half the time.

I’m not sure, they didn’t tell me. But I will say the behavior that occurred after 6-7 days of owning it where it just went to junk overnight, did not coincide with an sort of firmware or app update. And the behavior has continued through the various app updates and firmware updates that have occurred since.

Based on the above, I’m guessing it’s not firmware or app related.

Thank you. Not great news. I guess I’ll have to reach out to them. Good luck.

1 Like

I am also having these exact same problems. It worked great for the first few days, then started loosing its way, not realizing where it was. After tracing the house perimeter, it just stopped in a room without returning to the charger–no notification or anything. Still had plenty of charge too. The app’s map is not showing the correct location of the device.
If these problems are firmware-related, the firmware updates should be automatic. I shouldn’t have to reset everything every few days! We need your software developers to help!

Ok guys. This is important. Your robot vacuum has gone from great to an absolute horror story since I purchased it. Please, …oh please get your act together! I’ve had this device for a month now, and it worked well at first but for the past two weeks it hasn’t been able to clean our home even once! What is going on?
I’m a frequent reviewer of products and had high hope for this device, but lately it’s really let me down. This really appears to be a software issue. I’m a software engineer myself and I see the evidence that there are some flaws in the programming. The vacuum gets about half-way through perimeter detection, then just quits. It doesn’t even display the tracks up to that point on the app. There is still more that 30% of charge left too.
In the first week that I was using it, it was able to clean the entire house without an issue, so what’s happened now? The support forum moderator, tomp, says to just update the firmware and reset the map. As others have stated, this works for a few days, then it reverts back to its mindless state. I am running on the lastest version of firmware: version 1.6.97.
Please help before this product goes into the trash and killer reviews are written. I’m willing to do testing for you once a fix is ready.
I am copying this post via email to the executive board of Wyze:
David Crosby
Elana Fishman
Dongsheng Song
Yun Zhang

Have you contacted support about this?

WYZE Support

Live support is available:


Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT

Having the same issue. Mine eventually seems to get the entire apartment, double-cleaning some areas, and weirdly, the map seems to snap back in place afterward.

The vac does have to perform quite a reconnoiter before finding the charger again, bit it eventually does get home.

Phantom rooms added:

The long way home:

When finished, original map snaps back in and phantom rooms are gone (but the vac tracks are still there):

I contacted support about the issue and even though I explained to them that I have already reset the map multiple times and that the issue came back again they informed me to do it again anyway. When it happens again I’m going to send a log file (per their suggestion) and hope that gets a more effective response. I’m not sure why I couldn’t just submit a log from the last cleaning which never finished due to the map error. I’m really disappointed by this issue. I have many Wyze products and was an early adopter for many, if not all of them. This is the first long term issue I’ve had that wasn’t quickly addressed by an update. My future loyalty and praise for Wyze will likely change if they aren’t able to solve this issue soon. I’ll also likely cancel my open preorders as well.

1 Like

After the failure yesterday, I had the vac do just the room that gave it trouble. It went in and out without a problem.

Did the whole place today, worked like a charm. No changes to furniture layout, other obstacles. Just did its business efficiently.

This is a follow-up to suggest a possible path for others who have had this problem.

The vac ran fine again today. So…

  1. I did not reset the map after experiencing this round of “phantom room” creation. (I had reset it after an earlier mapping mess.) Instead, I just let it saunter around goofily and eventually stumble its way home.

  2. I then I vac’d a couple of rooms individually to make sure I got areas it missed in item 1 (including the room that seemed to trigger the appearance of the phantom rooms). It did that without a problem.

  3. The next two times I asked it to vacuum the whole place, and it did efficiently and without problems.

So it seemed self-healing, although the intermediate step of vacuuming individual rooms could conceivably have had something to do with it.

Echo what’s above… First image is the nice map of the office I got working finally. I went out of town and during that time when it was running jobs, it seems to have stopped working. Feb 17th was the last successful run. Last two screenshots are the floorplans in the system now. My WRV has also started stopping in the middle of the floor instead of going back to charge. I’m assuming the crazy map made it lose the route back to the charging station so it just meanders along and dies?

That’s exactly the same thing that has been happening with mine. Works great after first remapping run, then after that it skips rooms, won’t return to charging station, and doesn’t complete the cleaning cycle.
I’ve been working with Wyze on this and they’re sending me a beta firmware version to test in the next few days. Will keep you posted.

Thanks for the update. Tell them I can guinea pig firmware too if they want more test subjects.

Ok, will do.

I have had similar issues. Today it screwed up the map in two rooms (different schedules, within the day), but eventually made its way back to base. Seemed very confused.

The first time it got lost this morning, I moved it closer to the base, pressed the home button, it did its little look around, and then proceeded home. I area cleaned the room it had just attempted, and while the map was still a bit wonky, it succeeded (mostly). Later made its way to the office and worked fine. Later still went to the bedroom, and the map again was distorted.

While it did make its way back to base, the distorted map remained. I have to manually pull it out to empty it, and then I press home after replacing the dust bin, which I did after it vacuumed three rooms. It rotated around, returned to charge, and now the map is back to normal. We will see how it does tomorrow.

It does seem to temporarily update the map with unexpected objects (dog beds move around, but were off the floor during quick map), but remembers things that were there during the mapping (two dining chairs were used to hold the dog beds, and out of normal position for that quick map, so now the robot tends to avoid chair legs that are not really there). It has also has been giving a map that looks like it’s scanning beyond walls (corrupt). I wonder if the spinning lidar is obstructed, and is causing confusion. No windows or mirrors in most of the floor being serviced, and Wyze assures me that ambient light (direct sunlight) has no effect on the lidar.

This is what it should look like:

This is how it looked after vacuuming the bedroom:

This happened last week:

I also changed a bar chair from one which the robot could not fit under, to one that it can, and that too seemed to confuse matters. I may have to re-map again, but this means re-programming all the schedules, and re-defining the rooms again … oh, the horror!!! :grimacing:

In spite of this little issues, it has been better about docking on the first attempt lately, and the app seems better (map doesn’t move on the iPhone anymore, except when asked to move), so I think there are updates trickling through.

I am still trying to understand the function of the Notification feature. :thinking: