Wyze vacuum -- good and bad so far

I received my new wyze vacuum a few days. I bought it to replace two Roombas that I’ve had for a number of years and are become difficult to repair anymore.

I have the following observations about the Wyze:


I love the option to change the vacuum strength. The quiet mode is really nice.
I love that I can see exactly where the vacuum has actually vacuumed and what areas are being missed from the map.
I love the look of it.
I love that there is no separate power brick (like the Roomba) and that I can hide the extra wire inside the base. I hate seeing wires and the roomba power bricks were an eyesore…
I love that the dust bin can be washed. The roomba dust bins could not be washed.
I love that the app shows the charging level


There is zip, none, nada, no documentation whatsoever included in the box or printed anywhere on the box.
I first thought that there must be an app to download, but I finally figure it out that I just need to add the device to my existing wyze app along with my cams and lights. Once i figure this out, it want fairly easily.
I finally figured out that the top of the vacuum opens up. There is no indication of this at all and I just accidentally discovered it trying to find out where the dust bin was.
The bin instructions printed on the inside of the flap are so tiny (3pt font??) that I had to use a bright light and magnifying glass to read them.
The clear plastic dust bin is VERY difficult to open at first. I literally spent 10 minutes trying to figure out how to open it. There are no markings of any kind to show users how to open it and the hinges are not obvious. I had to use the very drawings under the lid to figure out what side the hinge had to be on.
It took me a while to figure out how to open the bottom of the charging station. No markings at all. I would not even have known that it needed to be opened except that is where the power socket is located. It also was not easy to open.
I have a pet gate blocking access to the back of my home that the vacuum will not be going into. The front part is a dining room, office, den and entry way. They are all separate rooms divided by walls with multiple doorways (with pocket doors) into each room. For example: the dining room opens into the kitchen (blocked by the gate), den, entry hall and office. The office opens to the entry hall and dining. The den opens into the dining and entry hall. The wzye vac maps all of these rooms as ONE single room and this cannot be changed. I would like to be able to vacuum specific rooms as needed.
Some of the doors between rooms have thresholds and the vacuum cannot get across them.


Yep, one single map, assuming it will retain the map data. So far after three try’s I have yet to retain a map or get the unit to return for a charge on it’s own. It got stuck on the last run today and I had to retrieve it, returning it to the charger. Once you do that the map data is lost and you start over again. Have done it three times so far in as many days. Can’t believe this was never tested prior to release. The room layout, even though it shows up on literature does not exist as far as I can tell on the latest app.
All in all a big disappointment from my old Roomba which can still run circles around this new model. Very frustrating to say the least.


I’ve notice that it does appear to recreated the map from scratch each time, but I’m not actually quite sure. It does return to it’s base though.

Poor Beta testing! Why Beta test when you can sell the customer one to do the Beta testing!
I am really not impressed with how Wyze does its beta program.

After writing the above reply, I figured I would test it again and yep I would have to agree with the last comment on poor beta testing. It started out good until it ran into the Xmas tree skirt in the living room, All I did was lift it gently off the cloth skirt and put it back down on the carpet no more that 6" from where it got stuck and map gone and it was lost, it had no idea where it was. Why would you ever want this thing to vacuum on a nightly schedule as you literally have to walk behind it at all times? Poor beta test at best, if even beta tested at all.

I run the vacuum in my hobby store every night and so far it is doing a fantastic job. It did get stuck under a store display shelf twice, but i ended up created a virtual wall around them to prevent that. Other than that I am really impressed. My store is so clean every morning.

there is a way to actually set your own area/ rooms with the editor. I am not using the public app currently so I am not sure if it is there or not ( seems like it should be though) it’s an editor ( similar to the tool you use to make virtual walls) and allows you to draw lines in a single “room” to separate and name each area. do you not have another tool next to the virtual wall tool on the home screen of the app?

@tmarino I had this same issue with the tree skirt as I hadn’t thought of what changed during the holidays. this is where use of the virtual walls comes in. you don’t have to track it constantly, you just have to be cognizant of what it can and can’t detect. and the reason it losses the map when you lift it is because it does a constant track of where it is. once it is lifted it loses this track so in order to keep the environment around it updated, it resets the map.

@lhntx00 it shouldn’t be recreating your map each time you start a sweep. it should be saving the map. unless you are lifting it at some point, that will reset the mapping system. what system and FW/app are you running?

1 Like

My vacuum also does not like wires. My wall sockets are in the baseboards, so a USB cord to a wyze cam was partially on the floor. The vac yanked the USB cord out of the wall socket and pulled the other end out of the wyze cam and wrapped the cord around the brush. It also wrapped a pair of apple wired earbuds that I had dropped on the floor around the brush.

The public app does not yet have the map editor although in the advertisement it appeared to be a feature.

The unit had to be lifted as it was snagged on the tree skirt and it has caught on something every run so far in my 5 days of testing. If it resets the map each time it gets stuck and has to be slightly lifted to be set free and any changes in ‘virtual walls’ has to be re-done also, basically stating over each time. Other bots on the market can save and recall the initial map, why wouldn’t this at least have that feature? Why introduce a new product and go backward in technology as it’s only software and not hardware?

Yep, one of the features I was looking for with the initial release as it WAS an advertised feature. Other bots have the capability so why not this one? Going back to the poor beta testing and quick release of the product.

1 Like

I’m hoping most of these issues get corrected before I get my Vaccum. I am shipping it in to Canada, so this is not an ultra cheap Vaccum for me. That mapping issues seems like a real big oversight. If the robot gets caught mapping it can never be able to set up a map. I guess I’ll try and clear my floor as much as possible. You could also block off the area but you risk messing up the map… There also doesn’t seem to be an option to update the map like most vaccums do.

Yes…some issues…cleans ok

  1. it only chooses to clean part of floorplan [I have NOT blocked off any area]. Tried starting in a different room but then it chooses to only clean different areas ??? no idea what or why it selects its own areas and excludes others???
  2. on average battery lasts only 45 minutes on standard…fully charged…not good
  3. 50% of time cannot find home base…I have to find it in manually place it
  4. lacking proper instructions on how to open dust bin—trial and error


  1. mapping is useful
    2 cleans fairly well
  2. like being able to control w/o remote…seems to keep a good wi fi connection

would certainly wait for improvement before purchasing a second one

1 Like

it has a limit on what it can see, its on the user to make sure things like cable are either not where they can get snagged or are marked off using the virtual walls.

and on this one, I think im misunderstanding, is this what is happening with you? it has been reported that is ou lift and move the robot the map can reset, I have had mine get stuck on things and I have paused it, removed the item from it, and then resumed the clean without losing my map.

this does save the map, I don’t have the details of how or where it is saved, but I have had no issues in losing my map.

I agree with you on never being able to set up a map, but I’m sure you will agree, there is some onus on the user to know what the “visual” limits of the robot are as to what it can see and avoid and what it can not. my issue comes with cat toys ( and a tree skirt once because I didn’t think enough), so I have to be aware to make sure my cat doesn’t leave certain toys out, but as far as cables or wires or other small things that would be on the user.

when you say update… what do you mean by update? I might be able to give you some insight on this.

So from what the current users are saying the map is not being updated after everyone run. Is there a way to update the map without it having to recreate the whole thing. For example, if I removed my Christmas tree that would just be a huge dead zone now.

Thanks for all of the insight to those who have deployed their new bot… about to send mine on its maiden voyage… half tempted to put a WCO on it and let’er rip.

if you had a virtual wall around it, and then removed the tree and deleted the virtual wall it should read it as an open zone ( digitally) and with the lidar not seeing anything there it should get adventurous and go do it’s thing. I have a couple chairs in my office that are never in the same place and it does a good job or going where they used to be without issue.

I would give it a shot and just be mindful of it when it goes to that area. if for some reason it doesn’t go to that spot I would send a log in because it definitely should!

I’ve noticed the map on mine gets a bit more accurate every time the unit runs like if I open a door between a room it will then venture into that room. BUT… the map still shows the entire home where the unit goes as one single room - even though it is four separate areas. I did notice that when I moved the base to another location I had to reset the map because it still went to the old spot.

1 Like

I came into this unit with minimal expectations as I have never owned a robovac. I appreciate reading everyone else’s insights so thought I would share my high level first thoughts going from out of box to first pass here.

Setup went fairly smooth, everything I needed to know was found in the Quick Start guide or WYZE Robot Vacuum Manual. The firmware updated instantly upon setup. Once charged I sent it on its way on my main floor (about 1600 sq ft minus what ever furniture covers)

Got almost 900 sq ft, then scurried home for a charge(Clean interrupted message) . I sent it with a 96% charge.

It found its way around very well, and I did remove anything that would obstruct, i.e. chairs, cords, etc… it did find a wayward nerf disc, I was alerted by some grinding sounds. Cleared it… all was good.


I was also impressed by what I found in the bin after having just shark vacuumed the floors 2 days ago. (8 people in the house)

It made its way over some low nap area rugs with no problems, but was mostly on textured laminate.

Even found a tissue hiding somewhere.

Again, I have no other experiences to compare this one to, so I am happy to this point. Curious if it will pick up where it left off once charged again.

All done on production latest release… will try with beta after a full first pass.

Pass 2

After 100% charge… I had to initiate the device to start again, it didnt just go. It took off and outlined the remainder of the primary floor then started cleaning the open areas… Odd to me that it didn’t go back to the rooms it outlined that it hadn’t swept but started cleaning an area it had already swept.

My primary floor is wide open minus the bathroom and an office near the living room, but I found it interesting it labeled some of the “rooms” and somewhat well.

I won’t make this any longer because the pics will get this post super deep. So here is the 2nd pass.


Ok so said I was done, but all the sudden as I am chilling on my couch. I hear recharge complete resuming cleaning from the robovac… look at app and its at 60% and and its off and running? And in a “room” it mapped but didn’t sweep. Hmmmm?

I promise last one… :grin: but I wanted to share for those that may come across this thread.

The robovac completed its job overnight all on it’s own and fully mapped my main floor very well. I even sent it on a short mission this morning using a scheduled cleaning (room 1) to see if it would lose the map starting a new clean and the map has held in place. Now… that being said, I did download the beta app to see if the map editor was there and it is not. I am happy with the results so far, but the 2.5 hour cleaning is more like 6-7 hours with charges in between, the way it has identified rooms is not the way I would want it… but no doubt these options will become available, when is the question… but I am a patient person, and know that this is was a pre-order that I got even earlier than I expected.


I’m using the beta app and don’t see the editor. Just got the vacuum today, so still getting used to it. I have an open floor plan too and really need an editor.
Do you know if there is beta firmware on the device? Since I’m in the beta program I assume it would include the vacuum.