Wyze Vacuum, first impressions

This is a first impressions post…
I have a Roomba, 600, and have had a Roomba of one model or another for years… I got the Wyze Vacuum today, and was just blown away by it… Pun intended…

Packaging was well done, and tight… Everything was clean, and well packaged. I unpacked it, of course skipped reading anything, and started charging it. I waited for the vacuum to charge, connected it to my WIFI. The first thing it did was grab an update. After it announced: “Update complete”, I hit the “Clean” button.

Off it went… I am frankly amazed at how it performs… The LIDAR started running, and I could see it mapping the room… It started cleaning, and as it worked it mapped more and more of my home. We were intending on moving a few months ago, and some of the boxes were still setup on the floor, making it a real mess for the Vacuum to navigate, I thought… It is amazing watch… It correctly avoided most everything, mapped the areas, and the boxes, as it worked, and finally finished the bottom floor…

At 1.13 hours run time it finished cleaning, then decided to head to the charger. I watched it navigate around several objects, never touching anything, head to the charger, then connect to the charger… It never touched anything going across several randomly placed boxes, and two room away.

It seems to clean well, we have a hardwood floor, so that makes it easy. The map is nice. Now comparing it to my Roomba, I will be removing the Roomba and placing it upstairs until I can afford a second Wyze Vacuum… The thing is so much better on my furniture than the Roomba. The Roomba is always bouncing off everything, and scraping the baseboards… An example is:

I have a small area on a set of speakers where the Roomba hits, every time… That area needs to be re-oiled far more often that any other location on the speaker finish… The Wyze Vacuum never touched it. It got really close to everything, but it was not banging off furniture as the Roomba does. It is far quieter, faster, and better performing than the Roomba…

A big surprise was after it was done I did the clean up… The dust bin is self contained, unlike the Roomba. On the Roomba when you remove the Dust Bin, one end is wide open to the inside of the Vacuum, and hence your home when it is out of the Roomba, scattering dust everywhere…

The Wyze Dust bin, (smaller than the Roomba), just pops out. The bottom of the chamber the dust bin lives in was clean as new, it was actually still shiny! That was a surprise… In any case, I cleaned the Dust Bin, and the unit and it is now charging…

The Bad:
Dust Bin could be larger.
The room editor does not appear to work, but that could be me, being new…
I can’t find a way to tell it to clean a single room.
I did not see a return home button on the Map.

The Good:
Very quick moving
Does not bang into everything
Picks up dirt very well
Hits the edges of things fairly well, better than teh Roomba by Far.
So quiet I can have a telephone conversation in the same room while it is cleaning…
It is far cheaper than the Roomba, and works FAR better…
Far less “Prep” needed prior to a Vacuum session as compared to the Roomba.

Overall I am VERY happy I bought this device, it is a far better product than my current Robot Vacuum…

01/08/21, additional data:
It is the next day, and the Vacuum took off on schedule and began cleaning the house. This time I had suction on high. Not much louder, (I could still have a phone discussion if I wanted in the same room), and not much faster or slower. However the battery does drain faster. Not much faster, but noticeably faster, as I would expect.

This time when I cleaned the dust bin, there was half the material in it as the first time, and a slight amount of dust in the dust bin compartment.

For a moment I saw the Map Editor with a map, (it seems to be missing when not vacuuming), but after the vacuum had finished, the map was gone again. House is clean and it is time to run the iRobot robot mop now…


Ya, the dust bin could be larger. I did just my Bedroom as a test. I filled that dustbin right up. I guess a lot of dust under my Ca King bed? I’m going to give it a second pass once it’s fully charged up. The suction level default seems to be in Quite Mode. there’s Standard and Strong also. I had my set to Strong. I assume you’ll get less run time using stronger suction.

Interesting, at our place, the dust bin was half filled, and it has been a bit from the last cleaning… I suspect your positing that there was a lot of dust under the bed is correct…

I had suction on high. The damn thing is really quiet… If I could afford a second one, I’d buy one for the upstairs…

Your assumption of less time is most likely correct, more suction means more current needed… Whatever Wyze did in the design phase of this device, they did correctly…

I very much hope they make it Alexa aware sooner than later…

I just got my Robot vacuum and I am trying to get it to connect to my WIFI and it just stalls there as it tries to update. Any suggestions, am i not waiting long enough, does it take an hour? How long should this take, it said a couple minutes. The other question is should it stay on the WVyze wifi or be switching back over to my internal wifi ?

I see what is happening now I am unable to join the WVCR_xxxxxxxx it keeps disconnecting so it will not upload. This is a problem. I am getting the error unable to join the network WVCR-XXXXXXXXXX
anyone else having this issue?

The first time I tried, the Vacuum failed to connect. I decided that was a “feature”, to keep things from updating, (auto update of a new device happens almost every time you first plug something in), with a dead battery, so I performed a full charge and it connected right up after that. The Vacuum then did an autoupdate. The update took maybe 5 minutes max.

Make sure you are connected to a 2.4GHz wireless network. Then open the Wyze app and go through the process of adding the vacuum. It should step you through the process. Once I connected to the WVCR-XXX network, a message popped up (Android) saying there was no connection, do you wish to stay connected. I click Yes and it continued to spin saying it was connecting. It took maybe 2 minutes tops for the whole process.

Edit: as a side note, the wireless setup process for the vacuum is very similar to their smart plugs. It took me a good 45 minutes to figure out how to connect the plug. Turns out, the VPN on my phone was blocking access somehow. I had to turn my VPN off and then I had no problem moving forward.

1 Like

I am excited to get mine.
As for connecting to the Wyze network, with my thermostats they would not finish setup because my firewall/content filtering was blocking it for some reason. The connections were silently dropped, so the firewall didn’t like where it was trying to connect. I had to whitelist the IP address of the thermostats so they would work, but I still can’t tell where they connect to. I am using Untangle.

Super impressed with it. I haven’t ever had a robot vacuum before so nothing to compare against but it picked up far more dirt and fiber than I have ever done with a regular floor vacuum which is 110v powered.

I do wish that the dustbin was bigger but the mapping isn’t good. The rooms aren’t labeled correctly. I have an open floor plan with living, kitchen, study all together and I want to label them separately. I can’t. And then I can’t get the vacuum to restart from a place even if I lift it and place it there after moving obstacles out of the way. Like no way to delete pre-existing walls/obstacles.

Everytime it starts from the same room and then runs of battery. I have a big house of 1900 sq ft so it takes quite an effort to map and clean the entire house. I had to lift the vacuum and close doors to force it to clean certain areas. That was not good.

Quick charge, great accuracy and clear voice prompts are impressive.

I just received my Wyze Vacuum yesterday and was also super impressed by it and agree with all the points in the original post, save one major issue I write about below. The mapping function was excellent, the path planning works real well, and there were only two small areas in our home where it had a bit of a hang-up problem that were easily resolved.

We have a big German Shepherd that sheds so we vacuum the house on a daily basis, sometimes twice a day. I’ve bought more Dyson vacuums than I care to count as a result. Remarkably, the Wyze Vacuum appears to clean at a similar level to these very expensive vacuums, and it does so without my wife or I pushing it around!

I found one major issue. It doesn’t appear to stop when the bin is full. That seems to be a major weakness in the design. I basically can’t “set it and forget it” because I have to check if the bin is full, sometimes in the middle of it vacuuming. Wyze has very intelligent product managers and engineers, did they actually not consider the extremely important feature of it stopping on its own when the bin is full?

New issue on second round of cleaning : the vacuum briefly lost its connection to wifi and stopped. When I restarted it continued on but had dumped its memory of where it had already cleaned so effectively was “starting over”. This probably could be remedied in a software update.

On a positive note: I moved the charger about 4 feet off carpet and onto tile (it had a hard time connecting to charger on carpet) while it was cleaning, and it was able to locate the new charger position and dock successfully.

I’ve had my new vac up and running for a couple of days. Overall, everything is working well. One issue i’ve experienced occurs during docking after a job. The robot returns to the base location, approaches slowly using the front sensor and then turns 180 degrees to back in so that the charging contacts touch. It will tap the contact points 2-3 times and then pull away to repeat the alignment process. After one run, it repeated the process 4 times before settling down to charge. After my last run, it actually repeated the alignment process 9 times before settling down.

I’ve validated that the contact points on the robot and base station align cleanly. The base station is setting on carpet, but is against a wall, aligned vertically and doesn’t move when contacted by the robot. Robot firmware is fully updated.

Does anyone have suggestions on what could be causing this?

Mine works flawlessly, but the charger is on hard floor, and against a wall. It it were me, I might play around with some Velcro on the bottom of the charger… I would also remember, that the Velcro may mess the carpet up over time…

1 Like

Not sure about velcroing to carpet. But maybe on the back side to the baseboard?

Just want to say the vacuum is amazing! I had a previous robotic vacuum and the Wyze Vac is a hundred fold better than my previous one. To the Wyze staff, excellent job.

1 Like

Probably a better idea… Be careful with Velcro, once the adhesive sticks on something it is stuck forever…

These smart vacs do not want to be picked up, doing so they forget where they are and your mapping has to start all over. If it is running out of juice before the initial out of box mapping make sure you use low power until so it can finish it’s first run. Some of them will do the mapping 2 or three times before it auto saves the map. After it has saved the map it will then allow you to edit the map with no go and divide the rooms into different sections. If you have multiple levels finish one level completely before attempting to map the second level. I have a different branded vac but I think the mapping is basically the same. Have fun and be patient.

I really enjoy mine, but I wish it could map without cleaning. Mine hasn’t mapped out the first floor entirely because of one issue or another. Once it got stuck and ran out the battery. Once it got tangled in it’s charging cord. When that happens, it has to start all over and clean the entire house again from scratch. I have nice clean floors, but I don’t want it to clean the same area 10 times trying to map the place!

I have the same issue. The mapping almost starts everytime and never really completes due to some issue or the other. And then I have a huge dining, living, kitchen, open study area so all of that becomes a single room and it can never finish cleaning that room on a single charge.

And once it goes back to charge, it almost never comes back and finishes the rest of this open layout. Cleaning the bedrooms is not a problem.

I’m surprised you have that issue with mapping. It took three charges to map my house, and during the mapping it had problems in two places where I had to “un-stick” the robot vacuum. It continued mapping afterwards. It was a 3 or 4 hour affair but it completed with a solid map.

Of course my wife decided to re-arrange a bunch of furniture a week or so afterwards so I may get the opportunity to map the house again! :slight_smile:

1 Like